]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
set default php on for ac on this branch
[packages/php.git] / php.spec
index 48e90383c56294155a894b9c5fd63999752bd978..7418199bdc9fc695b89fc167ac46a24ceb502d1a 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,3 @@
-# NOTE: mysqlnd does not support ssl or compression (see FAQ at http://dev.mysql.com/downloads/connector/php-mysqlnd/)
 # UNPACKAGED EXTENSION NOTES:
 # - com_dotnet is Win32-only
 # TODO:
@@ -44,7 +43,6 @@
 %bcond_without mhash           # without mhash extension (supported by hash extension)
 %bcond_with    mm              # without mm support for session storage
 %bcond_without mssql           # without MS SQL extension module
-# don't turn it on by default; see TODO item for mysqlnd in this spec
 %bcond_with    mysqlnd         # with mysqlnd support in mysql related extensions
 %bcond_without mysqli          # without mysqli support (Requires mysql > 4.1)
 %bcond_without odbc            # without ODBC extension module
@@ -68,7 +66,7 @@
 %bcond_without cgi             # disable CGI/FCGI SAPI
 %bcond_without fpm             # disable FPM
 %bcond_without embed           # disable Embedded API
-%bcond_without suhosin         # with suhosin patch
+%bcond_with    suhosin         # with suhosin patch
 %bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
 %bcond_with    gcov            # Enable Code coverage reporting
 %bcond_with    type_hints      # experimental support for strict typing/casting
@@ -113,13 +111,13 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 
 %if "%{pld_release}" == "ac"
 %define                _noautoreqdep libphp_common.*
-# if commandline --with was given. respect that
-%if 0%{!?_with_default_php:1}
-%undefine      with_default_php
+# if commandline --without was given. respect that
+%if 0%{!?_without_default_php:1}
+%define                with_default_php        1
 %endif
 %endif
 
-%define                rel     15
+%define                rel     18
 %define                orgname php
 %define                ver_suffix 53
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -219,6 +217,7 @@ Patch70:    mysql-lib-ver-mismatch.patch
 # git diff php-5.3.29..PHP-5.6 ./ext/fileinfo/Makefile.frag >> ~/rpm/packages/php/php-fileinfo.patch
 # git diff php-5.3.29..PHP-5.6 ./ext/fileinfo/data_file.c >> ~/rpm/packages/php/php-fileinfo.patch
 Patch71:       php-fileinfo.patch
+Patch72:       x32-suhosin.patch
 # Patch71-md5: 771e4934132c5f5c968248c954d1ef6e
 # Fixes for security bugs
 # https://repo.webtatic.com/yum/centos/5/SRPMS/repoview/php.html
@@ -463,9 +462,6 @@ Provides:   php(fcgi)
 Provides:      webserver(php) = %{version}
 Obsoletes:     php-cgi < 4:5.3.28-7
 Obsoletes:     php-fcgi < 4:5.3.0
-%if "%{pld_release}" != "ac"
-Conflicts:     logrotate < 3.8.0
-%endif
 
 %description cgi
 PHP as CGI or FastCGI program.
@@ -531,6 +527,9 @@ Provides:   php(fpm)
 Provides:      user(http)
 Provides:      webserver(php) = %{version}
 Obsoletes:     php-fpm < 4:5.3.28-7
+%if "%{pld_release}" != "ac"
+Conflicts:     logrotate < 3.8.0
+%endif
 
 %description fpm
 PHP FastCGI Process Manager.
@@ -2060,6 +2059,7 @@ cp -p php.ini-production php.ini
 %patch46 -p1
 %if %{with suhosin}
 %patch47 -p1
+%patch72 -p1
 %endif
 %patch68 -p1
 %patch48 -p1
@@ -2376,7 +2376,7 @@ for sapi in $sapis; do
        --with-mcrypt=shared \
        %{?with_mm:--with-mm} \
        %{?with_mssql:--with-mssql=shared} \
-       %{?with_mysqlnd:--with-mysqlnd=shared} \
+       %{?with_mysqlnd:--enable-mysqlnd=shared} \
        --with-mysql=shared%{?with_mysqlnd:,mysqlnd} \
        %{?with_mysqli:--with-mysqli=shared%{?with_mysqlnd:,mysqlnd}} \
        %{?with_oci:--with-oci8=shared%{?with_instantclient:,instantclient,%{_libdir}}} \
@@ -2715,7 +2715,7 @@ fi
 %service %{name}-fpm restart
 
 %preun fpm
-if [ "$1" = 0 ]; then
+if [ "$1" = "0" ]; then
        %service %{name}-fpm stop
        /sbin/chkconfig --del %{name}-fpm
 fi
@@ -2765,8 +2765,8 @@ for f in /etc/php/*.ini.rpmsave /etc/php/*.d/*.ini.rpmsave; do
        fn=${fn%.rpmsave}
        nf=%{_sysconfdir}/$dn/$fn
        test -f "$nf" || continue
-       cp -vf $nf{,.rpmnew}
-       mv -vf $f $nf
+       cp -vfb $nf{,.rpmnew}
+       cp -vfb $f $nf
        %{__sed} -i -e '
                s#%{_libdir}/php#%{_libdir}/%{name}#
                s#/etc/php#%{_sysconfdir}#
This page took 0.047672 seconds and 4 git commands to generate.