]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
Up to 8.0.0RC5
[packages/php.git] / php.spec
index 870530c5e62c71f0ccba928f9ab4efdc08c5ddfe..5eb388fc93c936e2b4077a6c96afc74ff2fbb71f 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -16,7 +16,7 @@
 %bcond_without alternatives    # use alternatives system to select default phar and php-fpm
 %bcond_with    default_php     # build this PHP as default PHP in system (disables alternatives)
 # - General options:
-%bcond_without embed           # disable building Embedded API
+%bcond_with    embed           # disable building Embedded API
 %bcond_with    gcov            # Enable Code coverage reporting
 %bcond_without kerberos5       # without Kerberos5 support
 %bcond_with    systemtap       # systemtap/DTrace support
 %define                orgname php
 %define                ver_suffix 80
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
+%define                subver RC5
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
 Summary(pt_BR.UTF-8):  A linguagem de script PHP
-Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
-Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
+Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
+Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       8.0.0
-Release:       0.beta4.0
+Release:       1.%{subver}.1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -158,8 +159,8 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
-Source0:       https://downloads.php.net/~pollita/php-%{version}beta4.tar.xz
-# Source0-md5: a30173dc7d5b75d82253dcbf4c7f2fe4
+Source0:       https://downloads.php.net/~carusogabriel/php-%{version}%{subver}.tar.xz
+# Source0-md5: 2809a29c4bb82640e4d0860f904d9d4f
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -181,7 +182,6 @@ Patch9:             libtool-tag.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
 Patch14:       %{orgname}-no_pear_install.patch
-Patch17:       %{orgname}-readline.patch
 Patch18:       %{orgname}-nohttpd.patch
 Patch21:       %{orgname}-dba-link.patch
 Patch22:       %{orgname}-both-apxs.patch
@@ -284,7 +284,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20200804
+%define                php_api_version         20200930
 %define                zend_module_api         %{php_api_version}
 %define                zend_extension_api      4%{zend_module_api}
 %define                php_pdo_api_version     20170320
@@ -298,7 +298,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.19.1-dev
+%define                zipver          1.19.1
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -1849,11 +1849,7 @@ compression support to PHP.
 Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
-%if 0
-%setup -q -n %{orgname}-%{version}
-%else
-%setup -q -n %{orgname}-%{version}beta4
-%endif
+%setup -q -n %{orgname}-%{version}%{?subver}
 
 cp -p php.ini-production php.ini
 %patch0 -p1
@@ -1862,29 +1858,25 @@ cp -p php.ini-production php.ini
 %patch3 -p1
 %patch4 -p1
 
-#%patch7 -p1 -b .sapi-ini-file
+%patch7 -p1 -b .sapi-ini-file
 %patch9 -p1
 %patch10 -p1 -b .ini
 %patch14 -p1
-#%patch17 -p1 -b readline
 %patch18 -p1
 %patch21 -p1
-#%patch22 -p1 -b .both-apxs
+%patch22 -p1
 %patch23 -p1
-#%patch24 -p1 -b .zlib-for-getimagesize
+%patch24 -p1 -b .zlib-for-getimagesize
 %patch25 -p1
 %patch27 -p1
 %patch29 -p1
 %patch31 -p1
-#%patch39 -p1 -b .use-prog_sendmail
+%patch39 -p1 -b .use-prog_sendmail
 %patch41 -p1
 %patch43 -p1
 %patch44 -p1
 %patch50 -p1
-
 %patch53 -p1
-%undos ext/spl/tests/SplFileInfo_getInode_basic.phpt
-
 %patch59 -p1 -b .systzdata
 %if %{with instantclient}
 %patch60 -p1 -b .instantclient
@@ -1892,7 +1884,7 @@ cp -p php.ini-production php.ini
 %patch66 -p1
 %patch67 -p1 -b .mysql-lib-ver-mismatch
 #%patch68 -p1 DROP or update to 7.0 APIs
-#%patch71 -p1 -b .libdb-info
+%patch71 -p1 -b .libdb-info
 
 sed -E -i -e '1s,#!\s*/usr/bin/env\s+(.*),#!%{__bindir}\1,' \
       ext/ext_skel.php \
This page took 0.046051 seconds and 4 git commands to generate.