]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- added missing %post(un) for pdo, pcntl and simplexml - if they were
[packages/php.git] / php.spec
index 34df36e9222a112f1a6823240a4adbdc45a88c82..559829ac495cf7e045f4f1db82485c5a6f7f2fd2 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,7 +1,6 @@
 # NOTE: mysqlnd does not support ssl or compression (see FAQ at http://dev.mysql.com/downloads/connector/php-mysqlnd/)
 # UNPACKAGED EXTENSION NOTES:
 # - com_dotnet is Win32-only
-# - enchant is packaged separately (php-pecl-enchant)
 # TODO:
 # - ttyname_r() misdetected http://bugs.php.net/bug.php?id=48820
 # - wddx: restore session support (not compiled in due DL extension check)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_with    instantclient   # build Oracle oci8 extension module against oracle-instantclient package
 %bcond_with    system_gd       # with system gd (we prefer internal since it enables few more features)
+%bcond_with    system_libzip   # with system libzip (reported broken currently)
 %bcond_without curl            # without CURL extension module
 %bcond_without filter          # without filter extension module
+%bcond_without enchant         # without Enchant extension module
 %bcond_without imap            # without IMAP extension module
 %bcond_without interbase       # without InterBase extension module
 %bcond_without kerberos5       # without Kerberos5 support
@@ -109,7 +110,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     9
+%define                rel     1
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -117,13 +118,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          php
-Version:       5.3.8
+Version:       5.3.14
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: 704cd414a0565d905e1074ffdc1fadfb
+# Source0-md5: 7caac4f71e2f21426c11ac153e538392
 Source2:       %{name}-mod_%{name}.conf
 Source3:       %{name}-cgi-fcgi.ini
 Source4:       %{name}-apache.ini
@@ -185,15 +186,13 @@ Patch50:  extension-shared-optional-dep.patch
 Patch51:       spl-shared.patch
 Patch52:       pcre-shared.patch
 Patch53:       fix-test-run.patch
-Patch54:       mysqlnd-shared.patch
-Patch55:       bug-52078-fileinode.patch
-Patch57:       bug-52448.patch
 Patch59:       %{name}-systzdata.patch
 Patch60:       %{name}-oracle-instantclient.patch
-Patch61:       %{name}-krb5-ac.patch
 Patch62:       mcrypt-libs.patch
 Patch63:       %{name}-mysql-nowarning.patch
 Patch64:       %{name}-m4.patch
+# http://spot.fedorapeople.org/php-5.3.6-libzip.patch
+Patch65:       system-libzip.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -205,9 +204,11 @@ BuildRequires:     bzip2-devel
 BuildRequires: cyrus-sasl-devel
 BuildRequires: db-devel >= 4.0
 BuildRequires: elfutils-devel
+%{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
 #BuildRequires:        fcgi-devel
 #BuildRequires:        flex
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
+%{?with_system_libzip:BuildRequires:   libzip-devel >= 0.10-3}
 BuildRequires: mysql-devel
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
@@ -287,6 +288,17 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                zend_module_api         20090626
 %define                zend_extension_api      220090626
 
+# Extension versions
+%define                bz2ver          1.0
+%define                enchantver      1.1.0
+%define                fileinfover     1.0.5-dev
+%define                hashver         1.0
+%define                intlver         1.1.0
+%define                jsonver         1.2.1
+%define                pharver         2.0.1
+%define                sqlitever       2.0-dev
+%define                zipver          1.9.1
+
 %define                zend_zts                %{!?with_zts:0}%{?with_zts:1}
 %define                php_debug               %{!?debug:0}%{?debug:1}
 
@@ -534,6 +546,7 @@ Requires:   libtool >= 2:2.2
 Requires:      libtool
 %endif
 %{?with_pcre:Requires: pcre-devel >= 8.10}
+%{?with_embed:Requires:        %{name}-embedded = %{epoch}:%{version}-%{release}}
 Requires:      shtool
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
@@ -593,10 +606,11 @@ Summary(pl.UTF-8):        Moduł bzip2 dla PHP
 Group:         Libraries
 URL:           http://www.php.net/manual/en/book.bzip2.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Provides:      php(bz2)
+Provides:      php(bz2) = %{bz2ver}
 Provides:      php(bzip2)
 Provides:      php-bzip2 = %{epoch}:%{version}-%{release}
 Obsoletes:     php-bzip2 < 4:5.2.14-3
+Obsoletes:     php-pecl-bz2 < %{bz2ver}
 
 %description bz2
 This is a dynamic shared object (DSO) for PHP that will add bzip2
@@ -685,6 +699,35 @@ support.
 %description dom -l pl.UTF-8
 Moduł PHP dodający nową obsługę DOM.
 
+%package enchant
+Summary:       libenchant binder
+Summary(pl.UTF-8):     dowiązania biblioteki libenchant
+Group:         Libraries
+URL:           http://www.php.net/manual/en/book.exif.php
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(enchant) = %{enchantver}
+Obsoletes:     php-pecl-enchant < %{enchantver}
+
+%description enchant
+Enchant is a binder for libenchant. Libenchant provides a common API
+for many spell libraries:
+- aspell/pspell (intended to replace ispell)
+- hspell (hebrew)
+- ispell
+- myspell (OpenOffice.org project, mozilla)
+- uspell (primarily Yiddish, Hebrew, and Eastern European languages) A
+  plugin system allows to add custom spell support.
+
+%description enchant -l pl.UTF-8
+Enchant jest dowiązaniem do biblioteki libenchant, która udostępnia
+ujednolicone API dla wielu narzędzi sprawdzających pisownię:
+- aspell/pspell (w zamierzeniu ma zastąpić ispell)
+- hspell (hebrajski)
+- ispell
+- myspell (projekt OpenOffice.org, mozilla)
+- uspell (głównie Jidysz, Hebrajski oraz języki wschodnioeuropejskie)
+  System wtyczek pozwala na dodanie wsparcia dla kolejnych narzędzi.
+
 %package exif
 Summary:       exif extension module for PHP
 Summary(pl.UTF-8):     Moduł exif dla PHP
@@ -707,9 +750,9 @@ Group:              Libraries
 URL:           http://www.php.net/manual/en/book.fileinfo.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-pcre = %{epoch}:%{version}-%{release}
-Provides:      php(fileinfo)
+Provides:      php(fileinfo) = %{fileinfover}
 Obsoletes:     php-mime_magic
-Obsoletes:     php-pecl-fileinfo
+Obsoletes:     php-pecl-fileinfo < %{fileinfover}
 
 %description fileinfo
 This extension allows retrieval of information regarding vast majority
@@ -823,13 +866,13 @@ Summary(pl.UTF-8):        Szkielet do obliczania skrótów wiadomości
 Group:         Libraries
 URL:           http://www.php.net/manual/en/book.gmp.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Provides:      php(hash)
+Provides:      php(hash) = %{hashver}
 %if %{with mhash}
 Provides:      php(mhash)
 Provides:      php-mhash = %{epoch}:%{version}-%{release}
 Obsoletes:     php-mhash < 4:5.3.0
 %endif
-Obsoletes:     php-pecl-hash
+Obsoletes:     php-pecl-hash < %{hashver}
 
 %description hash
 Native implementations of common message digest algorithms using a
@@ -899,7 +942,8 @@ Summary(pl.UTF-8):  Rozszerzenie do internacjonalizacji (interfejs do ICU)
 Group:         Libraries
 URL:           http://www.php.net/intl
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Provides:      php(intl)
+Provides:      php(intl) = %{intlver}
+Obsoletes:     php-pecl-intl < %{intlver}
 
 %description intl
 Internationalization extension (further is referred as Intl) is a
@@ -919,8 +963,8 @@ Summary(pl.UTF-8):  Rozszerzenie C PHP dla serializacji JSON
 Group:         Libraries
 URL:           http://www.php.net/manual/en/book.json.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Provides:      php(json)
-Obsoletes:     php-pecl-json
+Provides:      php(json) = %{jsonver}
+Obsoletes:     php-pecl-json < %{jsonver}
 
 %description json
 php-json is an extremely fast PHP C extension for JSON (JavaScript
@@ -1328,7 +1372,8 @@ Requires: %{name}-spl = %{epoch}:%{version}-%{release}
 # zlib is required by phar program, but as phar cli is optional should the dep be too
 Suggests:      %{name}-zlib
 Suggests:      php-program
-Provides:      php(phar)
+Provides:      php(phar) = %{pharver}
+Obsoletes:     php-pecl-phar < %{pharver}
 
 %description phar
 This is a dynamic shared object (DSO) for PHP that will add phar
@@ -1519,7 +1564,8 @@ URL:              http://www.php.net/manual/en/book.sqlite.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-pdo = %{epoch}:%{version}-%{release}
 Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
-Provides:      php(sqlite)
+Provides:      php(sqlite) = %{sqlitever}
+Obsoletes:     php-pecl-SQLite < %{sqlitever}
 
 %description sqlite
 SQLite is a C library that implements an embeddable SQL database
@@ -1793,8 +1839,9 @@ Summary(pl.UTF-8):        Zarządzanie archiwami zip
 Group:         Libraries
 URL:           http://www.php.net/manual/en/book.zip.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Provides:      php(zip)
-Obsoletes:     php-pecl-zip
+%{?with_system_libzip:Requires:        libzip >= 0.10-3}
+Provides:      php(zip) = %{zipver}
+Obsoletes:     php-pecl-zip < %{zipver}
 
 %description zip
 Zip is an extension to create, modify and read zip files.
@@ -1879,16 +1926,13 @@ cp -p php.ini-production php.ini
 %patch51 -p1
 %patch52 -p1
 %patch53 -p1
-%patch54 -p1
 %undos ext/spl/tests/SplFileInfo_getInode_basic.phpt
-%patch55 -p1
-%patch57 -p1
 %patch59 -p1
 %patch60 -p1
-%patch61 -p1
 %patch62 -p1
 %patch63 -p1
 %patch64 -p1
+%{?with_system_libzip:%patch65 -p1}
 %{__rm} -r sapi/litespeed
 gzip -dc %{SOURCE15} | tar xf - -C sapi/
 
@@ -1956,6 +2000,62 @@ if [ $API != %{zend_extension_api} ]; then
        exit 1
 fi
 
+# Check for some extension version
+ver=$(sed -n '/#define PHP_FILEINFO_VERSION /{s/.* "//;s/".*$//;p}' ext/fileinfo/php_fileinfo.h)
+if test "$ver" != "%{fileinfover}"; then
+       : Error: Upstream FILEINFO version is now ${ver}, expecting %{fileinfover}.
+       : Update the fileinfover macro and rebuild.
+       exit 1
+fi
+ver=$(sed -n '/#define PHP_PHAR_VERSION /{s/.* "//;s/".*$//;p}' ext/phar/php_phar.h)
+if test "$ver" != "%{pharver}"; then
+       : Error: Upstream PHAR version is now ${ver}, expecting %{pharver}.
+       : Update the pharver macro and rebuild.
+       exit 1
+fi
+ver=$(sed -n '/#define PHP_ZIP_VERSION_STRING /{s/.* "//;s/".*$//;p}' ext/zip/php_zip.h)
+if test "$ver" != "%{zipver}"; then
+       : Error: Upstream ZIP version is now ${ver}, expecting %{zipver}.
+       : Update the zipver macro and rebuild.
+       exit 1
+fi
+ver=$(sed -n '/#define PHP_JSON_VERSION /{s/.* "//;s/".*$//;p}' ext/json/php_json.h)
+if test "$ver" != "%{jsonver}"; then
+       : Error: Upstream JSON version is now ${ver}, expecting %{jsonver}.
+       : Update the jsonver macro and rebuild.
+       exit 1
+fi
+ver=$(sed -rne 's,.*<version>(.+)</version>,\1,p' ext/bz2/package.xml)
+if test "$ver" != "%{bz2ver}"; then
+       : Error: Upstream BZIP2 version is now ${ver}, expecting %{bz2ver}.
+       : Update the bz2ver macro and rebuild.
+       exit 1
+fi
+ver=$(sed -n '/#define PHP_ENCHANT_VERSION /{s/.* "//;s/".*$//;p}' ext/enchant/php_enchant.h)
+if test "$ver" != "%{enchantver}"; then
+       : Error: Upstream Enchant version is now ${ver}, expecting %{enchantver}.
+       : Update the enchantver macro and rebuild.
+       exit 1
+fi
+ver=$(awk '/#define PHP_HASH_EXTVER/ {print $3}' ext/hash/php_hash.h | xargs)
+if test "$ver" != "%{hashver}"; then
+       : Error: Upstream HASH version is now ${ver}, expecting %{hashver}.
+       : Update the hashver macro and rebuild.
+       exit 1
+fi
+ver=$(sed -n '/#define PHP_INTL_VERSION /{s/.* "//;s/".*$//;p}' ext/intl/php_intl.h)
+if test "$ver" != "%{intlver}"; then
+       : Error: Upstream Intl version is now ${ver}, expecting %{intlver}.
+       : Update the intlver macro and rebuild.
+       exit 1
+fi
+ver=$(awk '/#define PHP_SQLITE_MODULE_VERSION/ {print $3}' ext/sqlite/sqlite.c | xargs)
+if test "$ver" != "%{sqlitever}"; then
+       : Error: Upstream Sqlite version is now ${ver}, expecting %{sqlitever}.
+       : Update the sqlitever macro and rebuild.
+       exit 1
+fi
+
 export EXTENSION_DIR="%{php_extensiondir}"
 # configure once (for faster debugging purposes)
 if [ ! -f _built-conf ]; then
@@ -2094,6 +2194,7 @@ for sapi in $sapis; do
        %{__with_without curl curl shared} \
        --with-db4 \
        --with-iconv=shared \
+       %{?with_enchant:--with-enchant=shared,/usr} \
        --with-freetype-dir=shared \
        --with-gettext=shared \
        --with-gd=shared%{?with_system_gd:,/usr} \
@@ -2134,6 +2235,7 @@ for sapi in $sapis; do
        --with-xsl=shared \
        --with-zlib=shared \
        --with-zlib-dir=shared,/usr \
+       %{?with_system_libzip:--with-libzip} \
        --enable-zip=shared,/usr \
 
        # save for debug
@@ -2298,11 +2400,12 @@ cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
 
 # install FCGI PM
 %if %{with fpm}
-install -d $RPM_BUILD_ROOT{%{_sysconfdir}/fpm.d,%{_sbindir}}
+%{__make} -f Makefile.fpm install-fpm \
+       INSTALL_ROOT=$RPM_BUILD_ROOT
+# Makefile.fpm incorrectly installs libtool script instead of final binary so overwrite
 libtool --mode=install install -p sapi/fpm/php-fpm $RPM_BUILD_ROOT%{_sbindir}
-cp -p sapi/fpm/php-fpm.8 $RPM_BUILD_ROOT%{_mandir}/man8
-cp -p sapi/fpm/php-fpm.conf $RPM_BUILD_ROOT%{_sysconfdir}
-install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
+
+install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_sysconfdir}/fpm.d}
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/php-fpm
 install -d $RPM_BUILD_ROOT/etc/logrotate.d
 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/php-fpm
@@ -2372,8 +2475,10 @@ cp -a tests/* $RPM_BUILD_ROOT%{php_data_dir}/tests/php
 
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_common.la
+%if %{with embed}
 # libphp5.la contains our buildroot in dependency_libs
 sed -i -e "/dependency_libs/ s,/[^ ]*/libs/libphp_common.la,%{_libdir}/libphp_common.la," $RPM_BUILD_ROOT%{_libdir}/libphp5.la
+%endif
 # better solution?
 sed -i -e 's|libphp_common.la|$(libdir)/libphp_common.la|' $RPM_BUILD_ROOT%{_libdir}/php/build/acinclude.m4
 
@@ -2484,6 +2589,7 @@ fi
 %extension_scripts curl
 %extension_scripts dba
 %extension_scripts dom
+%extension_scripts enchant
 %extension_scripts exif
 %extension_scripts fileinfo
 %extension_scripts filter
@@ -2508,6 +2614,7 @@ fi
 %extension_scripts odbc
 %extension_scripts openssl
 %extension_scripts pcre
+%extension_scripts pdo
 %extension_scripts pdo-dblib
 %extension_scripts pdo-firebird
 %extension_scripts pdo-mysql
@@ -2516,11 +2623,13 @@ fi
 %extension_scripts pdo-sqlite
 %extension_scripts pgsql
 %extension_scripts phar
+%extension_scripts pcntl
 %extension_scripts posix
 %extension_scripts pspell
 %extension_scripts recode
 %extension_scripts session
 %extension_scripts shmop
+%extension_scripts simplexml
 %extension_scripts snmp
 %extension_scripts soap
 %extension_scripts sockets
@@ -2542,154 +2651,6 @@ fi
 %extension_scripts zip
 %extension_scripts zlib
 
-%triggerun bcmath -- %{name}-bcmath < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*bcmath\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun calendar -- %{name}-calendar < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*calendar\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun ctype -- %{name}-ctype < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*ctype\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun curl -- %{name}-curl < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*curl\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun dba -- %{name}-dba < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*dba\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun dom -- %{name}-dom < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*dom\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun exif -- %{name}-exif < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*exif\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun ftp -- %{name}-ftp < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*ftp\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun gd -- %{name}-gd < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*gd\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun gettext -- %{name}-gettext < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*gettext\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun gmp -- %{name}-gmp < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*gmp\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun iconv -- %{name}-iconv < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*iconv\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun imap -- %{name}-imap < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*imap\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun interbase -- %{name}-interbase < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*interbase\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun ldap -- %{name}-ldap < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*ldap\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun mbstring -- %{name}-mbstring < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*mbstring\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun mcrypt -- %{name}-mcrypt < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*mcrypt\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun mssql -- %{name}-mssql < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*mssql\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun mysql -- %{name}-mysql < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*mysql\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun mysqli -- %{name}-mysqli < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*mysqli\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun oci8 -- %{name}-oci8 < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*oci8\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun odbc -- %{name}-odbc < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*odbc\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun openssl -- %{name}-openssl < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*openssl\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun pcntl -- %{name}-pcntl < 4:5.1.2-9.5
-if [ -f %{_sysconfdir}/php-cgi.ini ]; then
-       %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*pcntl\.so/d' %{_sysconfdir}/php-cgi.ini
-fi
-if [ -f %{_sysconfdir}/php-cli.ini ]; then
-       %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*pcntl\.so/d' %{_sysconfdir}/php-cli.ini
-fi
-
-%triggerun pcre -- %{name}-pcre < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*pcre\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun pgsql -- %{name}-pgsql < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*pgsql\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun posix -- %{name}-posix < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*posix\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun pspell -- %{name}-pspell < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*pspell\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun readline -- %{name}-readline < 4:5.1.2-9.5
-if [ -f %{_sysconfdir}/php-cgi.ini ]; then
-       %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*readline\.so/d' %{_sysconfdir}/php-cgi.ini
-fi
-if [ -f %{_sysconfdir}/php-cli.ini ]; then
-       %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*readline\.so/d' %{_sysconfdir}/php-cli.ini
-fi
-
-%triggerun recode -- %{name}-recode < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*recode\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun session -- %{name}-session < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*session\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun shmop -- %{name}-shmop < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*shmop\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun snmp -- %{name}-snmp < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*snmp\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun soap -- %{name}-soap < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*soap\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun sockets -- %{name}-sockets < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*sockets\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun sqlite -- %{name}-sqlite < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*sqlite\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun sybase-ct -- %{name}-sybase-ct < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*sybase-ct\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun sysvmsg -- %{name}-sysvmsg < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*sysvmsg\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun sysvsem -- %{name}-sysvsem < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*sysvsem\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun sysvshm -- %{name}-sysvshm < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*sysvshm\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun tidy -- %{name}-tidy < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*tidy\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun wddx -- %{name}-wddx < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*wddx\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun xml -- %{name}-xml < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*xml\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun xmlrpc -- %{name}-xmlrpc < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*xmlrpc\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun xsl -- %{name}-xsl < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*xsl\.so/d' %{_sysconfdir}/php.ini
-
-%triggerun zlib -- %{name}-zlib < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*zlib\.so/d' %{_sysconfdir}/php.ini
-
 %if %{with apache1}
 %files -n apache1-mod_php
 %defattr(644,root,root,755)
@@ -2751,6 +2712,8 @@ fi
 %{_mandir}/man8/php-fpm.8*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/php-fpm
 %attr(754,root,root) /etc/rc.d/init.d/php-fpm
+%dir %{_datadir}/fpm
+%{_datadir}/fpm/status.html
 %endif
 
 %files common
@@ -2819,6 +2782,12 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/dom.ini
 %attr(755,root,root) %{php_extensiondir}/dom.so
 
+%files enchant
+%defattr(644,root,root,755)
+%doc ext/enchant/{CREDITS,docs/examples}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/enchant.ini
+%attr(755,root,root) %{php_extensiondir}/enchant.so
+
 %files exif
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/exif.ini
This page took 0.086262 seconds and 4 git commands to generate.