]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
fpm: provide php(fcgi) as it handles FCGI protocol as well
[packages/php.git] / php.spec
index 08f7f5817342bfee746ef6526c9a07f1651c0930..48e90383c56294155a894b9c5fd63999752bd978 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -42,7 +42,7 @@
 %bcond_without litespeed       # build litespeed module
 %bcond_without ldap            # without LDAP extension module
 %bcond_without mhash           # without mhash extension (supported by hash extension)
-%bcond_without mm              # without mm support for session storage
+%bcond_with    mm              # without mm support for session storage
 %bcond_without mssql           # without MS SQL extension module
 # don't turn it on by default; see TODO item for mysqlnd in this spec
 %bcond_with    mysqlnd         # with mysqlnd support in mysql related extensions
@@ -119,7 +119,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %endif
 %endif
 
-%define                rel     13
+%define                rel     15
 %define                orgname php
 %define                ver_suffix 53
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -133,7 +133,10 @@ Name:              %{orgname}%{php_suffix}
 Version:       5.3.29
 Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
-License:       PHP
+# All files licensed under PHP version 3.01, except
+# Zend is licensed under Zend
+# TSRM is licensed under BSD
+License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.bz2
 # Source0-md5: 9469e240cbe6ac865aeaec89b253dd30
@@ -210,20 +213,27 @@ Patch67:  php-litespeed.patch
 Patch68:       x32.patch
 Patch69:       fpm-conf-split.patch
 Patch70:       mysql-lib-ver-mismatch.patch
+# git clone git://github.com/php/php-src.git && git checkout PHP_5_6
+# git diff php-5.3.29..PHP-5.6 ./ext/fileinfo/libmagic > ~/rpm/packages/php/php-fileinfo.patch
+# git diff php-5.3.29..PHP-5.6 ./ext/fileinfo/config.m4 >> ~/rpm/packages/php/php-fileinfo.patch
+# git diff php-5.3.29..PHP-5.6 ./ext/fileinfo/Makefile.frag >> ~/rpm/packages/php/php-fileinfo.patch
+# git diff php-5.3.29..PHP-5.6 ./ext/fileinfo/data_file.c >> ~/rpm/packages/php/php-fileinfo.patch
+Patch71:       php-fileinfo.patch
+# Patch71-md5: 771e4934132c5f5c968248c954d1ef6e
 # Fixes for security bugs
 # https://repo.webtatic.com/yum/centos/5/SRPMS/repoview/php.html
 # also from RHEL6/CentOS7
 Patch220:      php-5.3.3-CVE-2011-4153.patch
-Patch238:      php-5.3.3-CVE-2014-2270.patch
+
 Patch247:      php-5.3.3-CVE-2014-2497.patch
-Patch248:      php-5.3.3-CVE-2014-3587.patch
+
 Patch249:      php-5.3.29-CVE-2014-3597.patch
 Patch250:      php-5.3.3-CVE-2014-4698.patch
 Patch251:      php-5.3.3-CVE-2014-4670.patch
 Patch252:      php-5.3.3-CVE-2014-3668.patch
 Patch253:      php-5.3.3-CVE-2014-3669.patch
 Patch254:      php-5.3.3-CVE-2014-3670.patch
-Patch255:      php-5.3.3-CVE-2014-3710.patch
+
 Patch256:      php-5.3.29-CVE-2014-8142.patch
 Patch257:      php-5.3.29-CVE-2015-0231.patch
 Patch258:      php-5.3.29-CVE-2015-0232.patch
@@ -239,7 +249,6 @@ BuildRequires:      cyrus-sasl-devel
 BuildRequires: db-devel >= 4.0
 BuildRequires: elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
-#BuildRequires:        fcgi-devel
 BuildRequires: file
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_system_libzip:BuildRequires:   libzip-devel >= 0.10-3}
@@ -262,13 +271,11 @@ BuildRequires:    libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
 BuildRequires: libmcrypt-devel >= 2.4.4
 BuildRequires: libpng-devel >= 1.0.8
-#BuildRequires:        libtiff-devel
 %if "%{pld_release}" != "ac"
 BuildRequires: libtool >= 2:2.2
 %else
 BuildRequires: libtool >= 1.4.3
 %endif
-#BuildRequires:        libwrap-devel
 BuildRequires: libxml2-devel >= 1:2.7.6-4
 BuildRequires: libxslt-devel >= 1.1.0
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
@@ -307,9 +314,6 @@ BuildRequires:      apache-devel >= 2.0.52-2
 BuildRequires: apr-devel >= 1:1.0.0
 BuildRequires: apr-util-devel >= 1:1.0.0
 %endif
-%if %{with fpm}
-#BuildRequires:        judy-devel
-%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                php_sysconfdir          /etc/%{name}
@@ -522,6 +526,7 @@ Requires(pre):      /bin/id
 Requires(pre): /usr/sbin/useradd
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      rc-scripts
+Provides:      php(fcgi)
 Provides:      php(fpm)
 Provides:      user(http)
 Provides:      webserver(php) = %{version}
@@ -612,6 +617,7 @@ Obsoletes:  php4-devel
 Obsoletes:     php52-devel
 Obsoletes:     php54-devel
 Obsoletes:     php55-devel
+Obsoletes:     php56-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -2074,18 +2080,19 @@ cp -p php.ini-production php.ini
 gzip -dc %{SOURCE15} | tar xf - -C sapi/
 %patch67 -p1
 %patch70 -p1
+%patch71 -p1
 
 %patch220 -p1
-%patch238 -p1
+
 %patch247 -p1
-%patch248 -p1
+
 %patch249 -p1
 %patch250 -p1
 %patch251 -p1
 %patch252 -p1
 %patch253 -p1
 %patch254 -p1
-%patch255 -p1
+
 %patch256 -p1
 %patch257 -p1
 %patch258 -p1
This page took 0.037495 seconds and 4 git commands to generate.