]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- pl for -ffi
[packages/php.git] / php.spec
index 8249f462918b59473d1e72fd12ed6e11ed31ef87..47c00cb3cb950724b89b20d05ebbdb5d1326a0d9 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -14,7 +14,7 @@
 %bcond_without alternatives    # use alternatives system to select default phar and php-fpm
 %bcond_with    default_php     # build this PHP as default PHP in system (disables alternatives)
 # - General options:
-%bcond_with    embed           # disable building Embedded API
+%bcond_without embed           # disable building Embedded API
 %bcond_with    gcov            # Enable Code coverage reporting
 %bcond_without kerberos5       # without Kerberos5 support
 %bcond_with    systemtap       # systemtap/DTrace support
 %undefine      with_pdo_sqlite
 %endif
 
-%define                subver RC3
-%define                rel     3
+%define                rel     1
 %define                orgname php
 %define                ver_suffix 74
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -151,17 +150,16 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.4.0
-Release:       2.%{subver}.%{rel}
+Version:       7.4.1
+Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
 # TSRM is licensed under BSD
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
-#Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
-Source0:       https://downloads.php.net/~derick/php-%{version}%{subver}.tar.xz
-# Source0-md5: 16bab715ced5f8af92344c4400d7bed5
+Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
+# Source0-md5: 6282f607a87c91b56ca14c3aacdba969
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -219,10 +217,6 @@ BuildRequires:     cyrus-sasl-devel >= 2
 BuildRequires: db-devel >= 4.0
 BuildRequires: elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
-%{?with_kerberos5:BuildRequires:       heimdal-devel}
-%{?with_argon2:BuildRequires:  libargon2-devel >= 20161029}
-%{?with_ffi:BuildRequires:     libffi-devel}
-%{?with_sodium:BuildRequires:  libsodium-devel >= 1.0.8}
 %if %{with pdo_dblib}
 BuildRequires: freetds-devel >= 0.82
 %endif
@@ -232,13 +226,17 @@ BuildRequires:    gd-devel >= 2.1
 %endif
 BuildRequires: gdbm-devel
 BuildRequires: gmp-devel >= 4.2
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_imap:BuildRequires:    imap-devel >= 1:2007e-2}
 %{?with_gcov:BuildRequires:    lcov}
 %{?with_fpm:BuildRequires:     libapparmor-devel}
+%{?with_argon2:BuildRequires:  libargon2-devel >= 20161029}
+%{?with_ffi:BuildRequires:     libffi-devel}
 %{?with_intl:BuildRequires:    libicu-devel >= 50.1}
 BuildRequires: libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
 BuildRequires: libpng-devel >= 1.0.8
+%{?with_sodium:BuildRequires:  libsodium-devel >= 1.0.8}
 %{?with_intl:BuildRequires:    libstdc++-devel}
 BuildRequires: libtool >= 2:2.4.6
 %{?with_webp:BuildRequires:    libwebp-devel}
@@ -833,7 +831,8 @@ support in image files.
 Moduł PHP dodający obsługę znaczników EXIF w plikach obrazków.
 
 %package ffi
-Summary:       %{modname} - Foreign Function Interface
+Summary:       Foreign Function Interface module for PHP
+Summary(pl.UTF-8):     Moduł Foreign Function Interface (interfejsu do obcych języków) dla PHP
 Group:         Libraries
 URL:           https://www.php.net/manual/en/book.ffi.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
@@ -843,6 +842,10 @@ Provides:  php(ffi) = %{version}
 FFI is a multi-platform extension for PHP that allows you to bind to
 functions from arbitrary shared libraries and call them.
 
+%description ffi -l pl.UTF-8
+FFI to wieloplatformowe rozszerzenie dla PHP pozwalające dowiązywać
+funkcje z dowolnych bibliotek współdzielonych i wywoływać je.
+
 %package fileinfo
 Summary:       libmagic bindings
 Summary(pl.UTF-8):     Wiązania do libmagic
@@ -1595,6 +1598,7 @@ Moduł PHP dodający obsługę gniazdek.
 
 %package sodium
 Summary:       Wrapper for the Sodium cryptographic library
+Summary(pl.UTF-8):     Interfejs do biblioteki kryptograficznej Sodium
 Group:         Libraries
 URL:           https://paragonie.com/book/pecl-libsodium
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
@@ -1603,6 +1607,9 @@ Provides: php(sodium) = %{sodiumver}
 %description sodium
 A simple, low-level PHP extension for libsodium.
 
+%description sodium -l pl.UTF-8
+Proste, niskopoziomowe rozszerzenie PHP wykorzystując libsodium.
+
 %package sqlite3
 Summary:       SQLite3 extension module for PHP
 Summary(pl.UTF-8):     Moduł SQLite3 dla PHP
@@ -1861,7 +1868,7 @@ compression support to PHP.
 Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
-%setup -q -n %{orgname}-%{version}%{?subver}
+%setup -q -n %{orgname}-%{version}
 cp -p php.ini-production php.ini
 %patch0 -p1
 %patch1 -p1
This page took 0.093401 seconds and 4 git commands to generate.