]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- xml bug stopper
[packages/php.git] / php.spec
index 956983fc23c50eb5658a22f27dc782532e3ac37e..42a215fbdd21a0f2dc018403fefb346b7155ee29 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2109,6 +2109,9 @@ cp -af php_config.h.cli main/php_config.h
 %{__make} sapi/cli/php -f Makefile.cli
 [ "$(echo '<?=php_sapi_name();' | ./sapi/cli/php -n)" = cli ] || exit 1
 
+# check for stupid xml parse breakage where &lt; and &gt; just get lost in parse result
+./sapi/cli/php -n -dextension_dir=modules -dextension=xml.so -r '$p = xml_parser_create(); xml_parse_into_struct($p, "<x>&lt;</x>", $vals, $index); exit(empty($vals[0]["value"]));'
+
 # Generate stub .ini files for each extension
 rm -rf conf.d
 install -d conf.d
This page took 0.03201 seconds and 4 git commands to generate.