]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
up to php-7.2.0RC6, likely last RC
[packages/php.git] / php.spec
index 797ec8ef7e33d2bc341f2ed1fcde1e6aa88eecc3..3281c9ccc92706a16ff9e236e722dcf4a98af8c1 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,6 +1,7 @@
+# NOTES
+# - mysqlnd driver doesn't support reconnect: https://bugs.php.net/bug.php?id=52561
 # TODO 7.2:
 # - https://github.com/php/php-src/blob/php-7.2.0alpha3/UPGRADING
-# - --with-password-argon2 https://wiki.php.net/rfc/argon2_password_hash
 # TODO 5.6:
 # - enable --with-fpm-systemd, but ensure it checks for sd_booted()
 # TODO 5.4:
@@ -96,6 +97,7 @@
 %bcond_without xmlrpc          # without XML-RPC extension module
 %bcond_without xsl             # without xsl extension module
 # extensions options
+%bcond_without argon2          # argon2 password hashing
 %bcond_without instantclient   # build Oracle oci8 extension module against oracle-instantclient package
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    mm              # without mm support for session storage
 %undefine      with_filter
 %endif
 
-%define                subver beta3
+%define                subver RC6
 %define                orgname php
 %define                ver_suffix 72
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -154,7 +156,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.2.0
-Release:       0.15
+Release:       2
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -162,8 +164,9 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 #Source0:      https://php.net/distributions/%{orgname}-%{version}.tar.xz
-Source0:       https://downloads.php.net/~remi/php-%{version}%{subver}.tar.xz
-# Source0-md5: fb658ee432cff906bd16aabc682caf27
+#Source0:      https://downloads.php.net/~remi/php-%{version}%{subver}.tar.xz
+Source0:       https://downloads.php.net/~pollita/php-%{version}%{subver}.tar.xz
+# Source0-md5: 43244f99613c6dc51a532b802cea17a8
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -232,6 +235,7 @@ BuildRequires:      db-devel >= 4.0
 BuildRequires: elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
+%{?with_argon2:BuildRequires:  libargon2-devel >= 20161029}
 %{?with_sodium:BuildRequires:  libsodium-devel >= 1.0.8}
 %if %{with pdo_dblib}
 BuildRequires: freetds-devel >= 0.82
@@ -309,7 +313,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # Extension versions
 %define                bz2ver          1.0
-%define                enchantver      1.1.0
+%define                enchantver      %{version}
 %define                fileinfover     1.0.5
 %define                hashver         1.0
 %define                intlver         1.1.0
@@ -628,6 +632,7 @@ Obsoletes:  php54-devel
 Obsoletes:     php55-devel
 Obsoletes:     php56-devel
 Obsoletes:     php70-devel
+Obsoletes:     php71-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -2004,19 +2009,21 @@ cp -p php.ini-production php.ini
 #%patch45 -p1 # imap annotations. fixme
 #%patch46 -p1 # imap myrights. fixme
 %patch50 -p1
-%patch51 -p1
+%patch51 -p1 -b .spl-shared
 %patch52 -p1 -b .pcre-shared
 %patch53 -p1
 %undos ext/spl/tests/SplFileInfo_getInode_basic.phpt
 %patch55 -p1
-%patch59 -p1
-%patch60 -p1
+%patch59 -p1 -b .systzdata
+%if %{with instantclient}
+%patch60 -p1 -b .instantclient
+%endif
 %patch66 -p1
 %patch67 -p1
 #%patch68 -p1 DROP or update to 7.0 APIs
 %patch70 -p1
 %patch71 -p1
-%patch72 -p1
+%patch72 -p1 -b .phar-shared
 
 %{__sed} -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
@@ -2191,10 +2198,8 @@ if test "$ver" != "%{bz2ver}"; then
        : Update the bz2ver macro and rebuild.
        exit 1
 fi
-ver=$(sed -n '/#define PHP_ENCHANT_VERSION /{s/.* "//;s/".*$//;p}' ext/enchant/php_enchant.h)
-if test "$ver" != "%{enchantver}"; then
-       : Error: Upstream Enchant version is now ${ver}, expecting %{enchantver}.
-       : Update the enchantver macro and rebuild.
+ver=$(awk '/#define PHP_ENCHANT_VERSION/ {print $3}' ext/enchant/php_enchant.h | xargs)
+if test "$ver" != "PHP_VERSION"; then
        exit 1
 fi
 ver=$(awk '/#define PHP_HASH_VERSION/ {print $3}' ext/hash/php_hash.h | xargs)
@@ -2300,6 +2305,7 @@ for sapi in $sapis; do
        --with-config-file-path=%{_sysconfdir} \
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-system-tzdata \
+       %{?with_argon2:--with-password-argon2} \
        --%{!?debug:dis}%{?debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        --enable-inline-optimization \
This page took 0.06029 seconds and 4 git commands to generate.