]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- fixed default_php bcond, added alternatives bcond
[packages/php.git] / php.spec
index 741fcaf9ea7b987a248543bad1b1bc86189a1be9..2f7380f6876ac6e1be7ab7419f3a8d6b02e8f078 100644 (file)
--- a/php.spec
+++ b/php.spec
 # Reflection
 #
 # Conditional build:
-%bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
-%bcond_with    oci             # with Oracle oci8 extension module     (BR: proprietary libs)
-%bcond_without instantclient   # build Oracle oci8 extension module against oracle-instantclient package
-%bcond_with    system_gd       # with system gd (we prefer internal since it enables few more features)
-%bcond_with    system_libzip   # with system libzip (reported broken currently)
-%bcond_with    default_php     # use this PHP as default PHP in distro
+# - packaging options
+%bcond_without alternatives    # use alternatives system to select default phar and php-fpm
+%bcond_with    default_php     # build this PHP as default PHP in system (disables alternatives)
+# - General options:
+%bcond_without embed           # disable building Embedded API
+%bcond_with    gcov            # Enable Code coverage reporting
+%bcond_without kerberos5       # without Kerberos5 support
+%bcond_with    suhosin         # with suhosin patch, has little point in PHP>=5.3, see https://github.com/stefanesser/suhosin/issues/42#issuecomment-41728178
+%bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
+%bcond_with    type_hints      # experimental support for strict typing/casting
+%bcond_with    zts             # Zend Thread Safety
+# - SAPI
+%bcond_without apache1         # disable building Apache 1.3.x SAPI
+%bcond_without apache2         # disable building Apache 2.x SAPI
+%bcond_without cgi             # disable CGI/FCGI SAPI
+%bcond_without fpm             # disable FPM SAPI
+%bcond_without litespeed       # build litespeed SAPI
+# - Extensions
+%bcond_without bcmath          # without bcmath extension module
+%bcond_without bz2             # without bz2 extension module
+%bcond_without calendar        # without calendar extension module
+%bcond_without ctype           # without ctype extension module
 %bcond_without curl            # without CURL extension module
 %bcond_without enchant         # without Enchant extension module
 %bcond_without filter          # without filter extension module
 %bcond_without imap            # without IMAP extension module
 %bcond_without interbase       # without InterBase extension module
 %bcond_without intl            # without Intl extension module
-%bcond_without kerberos5       # without Kerberos5 support
-%bcond_without litespeed       # build litespeed module
 %bcond_without ldap            # without LDAP extension module
 %bcond_without mhash           # without mhash extension (supported by hash extension)
-%bcond_without mm              # without mm support for session storage
 %bcond_without mssql           # without MS SQL extension module
 # don't turn it on by default; see TODO item for mysqlnd in this spec
 %bcond_with    mysqlnd         # with mysqlnd support in mysql related extensions
 %bcond_without mysqli          # without mysqli support (Requires mysql > 4.1)
+%bcond_with    oci             # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_without odbc            # without ODBC extension module
 %bcond_without openssl         # without OpenSSL support and OpenSSL extension (module)
 %bcond_without pcre            # without PCRE extension module
 %bcond_without sqlite3         # without SQLite3 extension module
 %bcond_without sybase_ct       # without Sybase-CT extension module
 %bcond_without tidy            # without Tidy extension module
-%bcond_without webp            # Without WebP support in GD extension (imagecreatefromwebp)
 %bcond_without wddx            # without WDDX extension module
 %bcond_without xmlrpc          # without XML-RPC extension module
-%bcond_without apache1         # disable building Apache 1.3.x SAPI
-%bcond_without apache2         # disable building Apache 2.x SAPI
-%bcond_with    zts             # Zend Thread Safety
-%bcond_without cgi             # disable CGI/FCGI SAPI
-%bcond_without fpm             # disable FPM
-%bcond_with    embed           # disable Embedded API
-%bcond_with    suhosin         # with suhosin patch
-%bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
-%bcond_with    gcov            # Enable Code coverage reporting
-%bcond_with    type_hints      # experimental support for strict typing/casting
+# extensions options
+%bcond_without instantclient   # build Oracle oci8 extension module against oracle-instantclient package
+%bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
+%bcond_with    mm              # without mm support for session storage
+%bcond_with    system_gd       # with system gd (imageantialias function is missing then)
+%bcond_with    system_libzip   # with system libzip (reported broken currently)
+%bcond_without webp            # Without WebP support in GD extension (imagecreatefromwebp)
 
 %define apxs1          /usr/sbin/apxs1
 %define        apxs2           /usr/sbin/apxs
 %undefine      with_litespeed
 %endif
 
+%if %{with default_php}
+%undefine      with_alternatives
+%endif
+
 # mm is not thread safe
 %if %{with zts}
 %undefine      with_mm
@@ -124,7 +138,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     8
+%define                rel     12
 %define                orgname php
 %define                ver_suffix 54
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -505,6 +519,8 @@ Requires(postun):   /usr/sbin/userdel
 Requires(pre): /bin/id
 Requires(pre): /usr/sbin/useradd
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+%{?with_alternatives:Requires: alternatives}
+Requires:      php-dirs >= 1.4-2
 Requires:      rc-scripts
 Provides:      php(fpm)
 Provides:      user(http)
@@ -1410,7 +1426,7 @@ Group:            Libraries
 URL:           http://www.php.net/manual/en/book.phar.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
-Requires:      alternatives
+%{?with_alternatives:Requires: alternatives}
 Suggests:      %{name}-cli
 # zlib is required by phar program, but as phar cli is optional should the dep be too
 Suggests:      %{name}-zlib
@@ -1984,22 +2000,22 @@ sed -i -e 's#-fvisibility=hidden##g' configure*
 
 # disable broken tests
 # says just "Terminated" twice and fails
-mv sapi/cli/tests/022.phpt{,.broken}
+%{__mv} sapi/cli/tests/022.phpt{,.broken}
 
 # really dumb test, executable binary name is .libs/ something when building
 # https://bugs.php.net/bug.php?id=54514
-mv tests/basic/bug54514.phpt{,.disable}
+%{__mv} tests/basic/bug54514.phpt{,.disable}
 
 # breaks whole testsuite unexpectedly:
 # Fatal error: Call to undefined function gzencode() in run-tests.php on line 1714
 # probably broken as zlib is built as shared
-mv ext/soap/tests/server019.phpt{,disable}
+%{__mv} ext/soap/tests/server019.phpt{,disable}
 # Fatal error: Call to undefined function gzcompress() in run-tests.php on line 1728
-mv ext/soap/tests/server020.phpt{,disable}
+%{__mv} ext/soap/tests/server020.phpt{,disable}
 
 # runs out of memory and kills carme vserver
 # PASS Bug #39438 (Fatal error: Out of memory) [Zend/tests/bug39438.phpt]
-mv Zend/tests/bug39438.phpt{,.disable}
+%{__mv} Zend/tests/bug39438.phpt{,.disable}
 
 # php-5.3.3/ext/standard/tests/file/statpage.phpt
 %{__rm} ext/standard/tests/file/statpage.phpt
@@ -2420,13 +2436,17 @@ cp -pf Makefile.cli Makefile
        phpbuilddir=%{_libdir}/%{name}/build \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
+%if %{without default_php}
 # version the .phar files
-mv $RPM_BUILD_ROOT%{_bindir}/phar{,%{ver_suffix}}.phar
-mv $RPM_BUILD_ROOT%{_mandir}/man1/phar{,%{ver_suffix}}.1
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/phar{,%{php_suffix}}.phar
+%{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/phar{,%{php_suffix}}.1
+%endif
+%if %{with alternatives}
 # touch for ghost
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/phar
 touch $RPM_BUILD_ROOT%{_bindir}/phar
 touch $RPM_BUILD_ROOT%{_mandir}/man1/phar.1
+%endif
 
 # version suffix
 v=$(echo %{version} | cut -d. -f1-2)
@@ -2434,14 +2454,14 @@ v=$(echo %{version} | cut -d. -f1-2)
 # install Apache1 DSO module
 %if %{with apache1}
 libtool --mode=install install -p sapi/apache/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache1
-mv $RPM_BUILD_ROOT%{_libdir}/apache1/libphp5{,-$v}.so
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/apache1/libphp5{,-$v}.so
 ln -s libphp5-$v.so $RPM_BUILD_ROOT%{_libdir}/apache1/mod_php.so
 %endif
 
 # install Apache2 DSO module
 %if %{with apache2}
 libtool --mode=install install -p sapi/apache2handler/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache
-mv $RPM_BUILD_ROOT%{_libdir}/apache/libphp5{,-$v}.so
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/apache/libphp5{,-$v}.so
 ln -s libphp5-$v.so $RPM_BUILD_ROOT%{_libdir}/apache/mod_php.so
 %endif
 
@@ -2474,6 +2494,11 @@ cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
 %{__sed} -i -e '/su/d' $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-fpm
 %endif
 
+%if %{with alternatives}
+# touch for ghost for alternatives
+touch $RPM_BUILD_ROOT%{_sbindir}/php-fpm
+%endif
+
 %{__sed} -i -e '
        s#/usr/lib/php#%{php_extensiondir}#
        s#/etc/php#%{_sysconfdir}#
@@ -2525,7 +2550,7 @@ cp -p conf.d/*.ini $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/{cgi-fcgi,cli,apache,apache2handler}.d
 
 # for CLI SAPI only
-mv $RPM_BUILD_ROOT%{_sysconfdir}/{conf.d/readline.ini,cli.d}
+%{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/{conf.d/readline.ini,cli.d}
 
 # use system automake and {lib,sh}tool
 ln -snf /usr/share/automake/config.{guess,sub} $RPM_BUILD_ROOT%{_libdir}/%{name}/build
@@ -2590,11 +2615,17 @@ fi
 %post fpm
 /sbin/chkconfig --add %{name}-fpm
 %service %{name}-fpm restart
+%if %{with alternatives}
+update-alternatives --install %{_sbindir}/php-fpm php-fpm %{_sbindir}/php%{ver_suffix}-fpm %{ver_suffix} || :
+%endif
 
 %preun fpm
 if [ "$1" = 0 ]; then
        %service %{name}-fpm stop
        /sbin/chkconfig --del %{name}-fpm
+%if %{with alternatives}
+       update-alternatives --remove php-fpm %{_sbindir}/php-fpm || :
+%endif
 fi
 
 %postun fpm
@@ -2605,7 +2636,7 @@ fi
 %post  embedded -p /sbin/ldconfig
 %postun        embedded -p /sbin/ldconfig
 
-%post common
+%posttrans common
 # PHP 5.3 requires timezone being setup, try setup it from tzdata
 if ! grep -q '^date.timezone[[:space:]]*=' %{_sysconfdir}/php.ini && [ -f /etc/sysconfig/timezone ]; then
        TIMEZONE=
@@ -2615,7 +2646,6 @@ if ! grep -q '^date.timezone[[:space:]]*=' %{_sysconfdir}/php.ini && [ -f /etc/s
        fi
 fi
 
-%posttrans common
 # minimizing apache restarts logics. we restart webserver:
 #
 # 1. at the end of transaction. (posttrans, feature from rpm 4.4.2)
@@ -2735,15 +2765,19 @@ fi \
 
 %post phar
 %ext_post
+%if %{with alternatives}
 update-alternatives \
        --install %{_bindir}/phar phar %{_bindir}/phar%{ver_suffix}.phar %{ver_suffix} \
        --slave %{_mandir}/man1/phar.1 phar.1 %{_mandir}/man1/phar%{ver_suffix}.1* || :
+%endif
 
 %postun phar
 %ext_postun
+%if %{with alternatives}
 if [ $1 -eq 0 ]; then
        update-alternatives --remove phar %{_bindir}/phar || :
 fi
+%endif
 
 %if %{with apache1}
 %files -n apache1-mod_%{name}
@@ -2805,6 +2839,9 @@ fi
 %dir %{_sysconfdir}/fpm.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-fpm.conf
 %attr(755,root,root) %{_sbindir}/%{name}-fpm
+%if %{with alternatives}
+%ghost %{_sbindir}/php-fpm
+%endif
 %{_mandir}/man8/%{name}-fpm.8*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}-fpm
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-fpm
@@ -3137,11 +3174,15 @@ fi
 %doc ext/phar/{CREDITS,TODO}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/phar.ini
 %attr(755,root,root) %{php_extensiondir}/phar.so
-%attr(755,root,root) %{_bindir}/phar%{ver_suffix}.phar
-%{_mandir}/man1/phar.phar.1
-%{_mandir}/man1/phar%{ver_suffix}.1*
+%attr(755,root,root) %{_bindir}/phar%{php_suffix}.phar
+%{_mandir}/man1/phar%{php_suffix}.1*
+%{_mandir}/man1/phar.phar.1*
+%if %{with alternatives}
 %ghost %{_bindir}/phar
 %ghost %{_mandir}/man1/phar.1
+%else
+%attr(755,root,root) %{_bindir}/phar
+%endif
 %endif
 
 %files posix
This page took 0.086949 seconds and 4 git commands to generate.