]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- xmlwriter obsoletes php-pecl-xmlwriter
[packages/php.git] / php.spec
index ef8eca0488a219ca0456a328159e2579d351a230..282e20e32220a595278e773696f77ed947925c1a 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -5,14 +5,10 @@
 #    - pfpro,
 #   These extensions BuildRequires proprietary libraries...
 # - deal with modules removed from php and not moved to PECL
-#   (existing only in php4):
-#   db, hyperwave, java, mcal, overload, qtdom
-#   and removed from php 5.1:
-#   cpdf, fam, yp, oracle
-#   and removed from php 5.2:
+#   removed from php 5.2:
 #   filepro, hw
 # - mime_magic can't handle new "string/*" entries in magic.mime
-#   thus doesn't work with system magic.mime databse
+#   thus doesn't work with system magic.mime database
 # - make additional headers added by mail patch configurable
 # - apply -hardened patch by default ?
 # - modularize session, standard (output from pure php -m)?
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_without curl            # without CURL extension module
+%bcond_without filter          # without filter extension module
 %bcond_without imap            # without IMAP extension module
 %bcond_with    interbase       # with InterBase extension module
 %bcond_without ldap            # without LDAP extension module
 %bcond_without mhash           # without mhash extension module
+%bcond_without mime_magic      # without mime-magic module
 %bcond_without ming            # without ming extension module
 %bcond_without mm              # without mm support for session storage
 %bcond_without mssql           # without MS SQL extension module
 %bcond_without mysqli          # without mysqli support (Requires mysql > 4.1)
-%bcond_without mime_magic      # without mime-magic module
 %bcond_without odbc            # without ODBC extension module
 %bcond_without openssl         # without OpenSSL support and OpenSSL extension (module)
 %bcond_without pcre            # without PCRE extension module
 %undefine      with_interbase
 %endif
 
-%if %{without apache1} && %{without apache2}
+%if !%{with apache1} && !%{with apache2}
 ERROR: You need to select at least one Apache SAPI to build shared modules.
 %endif
 
-%define        _rel 0.11
+# filter depends on pcre
+%if %{without pcre}
+%undefine      with_filter
+%endif
+
+%define        _rel 3
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr):   Le langage de script embarque-HTML PHP
 Summary(pl):   Jêzyk skryptowy PHP
@@ -91,17 +93,21 @@ Source6:    %{name}-apache.ini
 Source7:       %{name}-cli.ini
 Source8:       http://www.hardened-php.net/hardening-patch-5.0.4-0.3.0.patch.gz
 # Source8-md5: 47a742fa9fab2826ad10c13a2376111a
+# Taken from: http://browsers.garykeith.com/downloads.asp
+Source9:       %{name}_browscap.ini
 Patch0:                %{name}-shared.patch
 Patch1:                %{name}-pldlogo.patch
 Patch2:                %{name}-mail.patch
 Patch3:                %{name}-link-libs.patch
 Patch4:                %{name}-libpq_fs_h_path.patch
+Patch5:                %{name}-filter-shared.patch
 Patch6:                %{name}-build_modules.patch
 Patch7:                %{name}-sapi-ini-file.patch
 Patch8:                %{name}-no-metaccld.patch
-
+Patch9:                %{name}-sh.patch
 Patch10:       %{name}-ini.patch
 Patch11:       %{name}-acam.patch
+Patch12:       %{name}-curl.patch
 Patch14:       %{name}-allow-db31.patch
 Patch15:       %{name}-threads-acfix.patch
 Patch16:       %{name}-tsrmlsfetchgcc2.patch
@@ -119,8 +125,10 @@ Patch32:   %{name}-builddir.patch
 Patch33:       %{name}-zlib-for-getimagesize.patch
 Patch35:       %{name}-versioning.patch
 Patch36:       %{name}-linkflags-clean.patch
-Patch38:       %{name}-amd64.patch
+Patch38:       %{name}-memory-limit.patch
 Patch39:       %{name}-pear.patch
+Patch40:       %{name}-db4.5.patch
+Patch41:       %{name}-config-dir.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -211,11 +219,7 @@ database-enabled web page with PHP is fairly simple. The most common
 use of PHP coding is probably as a replacement for CGI scripts. The
 mod_php module enables the Apache web server to understand and process
 the embedded PHP language in web pages. This package contains php
-version %{version}. If you use applications which specifically rely on
-PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
-module contained in the phpfi package. If you're just starting with
-PHP, you should install this package. You'll also need to install the
-Apache web server.
+version %{version}.
 
 %description -l fr
 PHP est un langage de script embarque dans le HTM. PHP essaye de
@@ -227,18 +231,18 @@ des bases de donnees. L'utilisation la plus commune de PHP est
 probablement en remplacement de scripts CGI. Le module mod_php permet
 au serveur web apache de comprendre et de traiter le langage PHP
 integre dans des pages web. Ce package contient php version
-%{version}. Si vous utilisez des applications qui utilisent
-specifiquement PHP/FI, vous devrez installer le module PHP/FI inclus
-dans le package mod_php. Si vous debutez avec PHP, vous devriez
-installer ce package. Vous aurez egalement besoin dinstaller le
-serveur web Apache.
+%{version}.
 
 %description -l pl
 PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w
-plikach HTML. Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP
-(jak np. Apache), który interpretuje te polecenia. Umo¿liwia to
-tworzenie dynamicznie stron WWW. Spora czê¶æ sk³adni PHP zapo¿yczona
-zosta³a z jêzyków: C, Java i Perl.
+plikach HTML. Jest prób± u³atwienia programistom pisania dynamicznie
+generowanych stron WWW. Oferuje tak¿e wbudowan± integracjê z bazami
+danych dla kilku komercyjnych i niekomercyjnych systemów baz danych,
+co czyni tworzenie stron korzystaj±cych z baz danych w miarê ³atwym.
+Najczê¶ciej PHP jest u¿ywany prawdopodobnie jako zamiennik skryptów
+CGI. Modu³ mod_php pozwala serwerowi WWW Apache rozumieæ i przetwarzaæ
+jêzyk PHP osadzony w stronach. Ten pakiet zawiera php w wersji
+%{version}.
 
 %description -l pt_BR
 PHP: Preprocessador de Hipertexto versão 4 é uma linguagem script
@@ -256,7 +260,7 @@ PHP - 
 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÁÍÏÄÏÓÔÁÔÏÞÎÕÀ (CGI) ×ÅÒÓÉÀ ÉÎÔÅÒÐÒÅÔÁÔÏÒÁ ÑÚÙËÁ.
 ÷Ù ÄÏÌÖÎÙ ÔÁËÖÅ ÕÓÔÁÎÏ×ÉÔØ ÐÁËÅÔ %{name}-common. åÓÌÉ ×ÁÍ ÎÕÖÅÎ
 ÉÎÔÅÒÐÒÅÔÁÔÏÒ PHP × ËÁÞÅÓÔ×Å ÍÏÄÕÌÑ apache, ÕÓÔÁÎÏ×ÉÔÅ ÐÁËÅÔ
-apache-php.
+apache-mod_php.
 
 %description -l uk
 PHP - ÃÅ ÍÏ×Á ÎÁÐÉÓÁÎÎÑ ÓËÒÉÐÔ¦×, ÝÏ ×ÂÕÄÏ×ÕÀÔØÓÑ × HTML-ËÏÄ. PHP
@@ -266,7 +270,8 @@ PHP - 
 
 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÁÍÏÄÏÓÔÁÔÎÀ (CGI) ×ÅÒÓ¦À ¦ÎÔÅÒÐÒÅÔÁÔÏÒÁ ÍÏ×É. ÷É
 ÍÁ¤ÔÅ ÔÁËÏÖ ×ÓÔÁÎÏ×ÉÔÉ ÐÁËÅÔ %{name}-common. ñËÝÏ ×ÁÍ ÐÏÔÒ¦ÂÅÎ
-¦ÎÔÅÒÐÒÅÔÁÔÏÒ PHP × ÑËÏÓÔ¦ ÍÏÄÕÌÑ apache, ×ÓÔÁÎÏצÔØ ÐÁËÅÔ apache-php.
+¦ÎÔÅÒÐÒÅÔÁÔÏÒ PHP × ÑËÏÓÔ¦ ÍÏÄÕÌÑ apache, ×ÓÔÁÎÏצÔØ ÐÁËÅÔ
+apache-mod_php.
 
 %package -n apache1-mod_php
 Summary:       PHP DSO module for apache 1.3.x
@@ -276,7 +281,6 @@ Requires(triggerpostun):    sed >= 4.0
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      apache1(EAPI) >= 1.3.33-2
 Requires:      apache1-mod_mime
-Provides:      php = %{epoch}:%{version}-%{release}
 Provides:      webserver(php) = %{version}
 Obsoletes:     apache-mod_php < 1:4.1.1
 Obsoletes:     phpfi
@@ -294,7 +298,6 @@ Group:              Development/Languages/PHP
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      apache(modules-api) = %{apache_modules_api}
 Requires:      apache-mod_mime
-Provides:      php = %{epoch}:%{version}-%{release}
 Provides:      webserver(php) = %{version}
 Obsoletes:     phpfi
 
@@ -309,7 +312,6 @@ Summary:    php as FastCGI program
 Summary(pl):   php jako program FastCGI
 Group:         Development/Languages/PHP
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Provides:      php = %{epoch}:%{version}-%{release}
 Provides:      webserver(php) = %{version}
 
 %description fcgi
@@ -364,17 +366,12 @@ Group:            Libraries
 # because of dlclose() bugs in glibc <= 2.3.4 causing SEGVs on exit
 Requires:      glibc >= 6:2.3.5
 Requires:      php-dirs
-Provides:      %{name}-libxml = %{epoch}:%{version}-%{release}
-Provides:      %{name}-overload = %{epoch}:%{version}-%{release}
-%{?with_pcre:Provides: %{name}-pcre = %{epoch}:%{version}-%{release}}
-Provides:      %{name}-session = %{epoch}:%{version}-%{release}
-Provides:      %{name}-simplexml = %{epoch}:%{version}-%{release}
-Provides:      %{name}-spl = %{epoch}:%{version}-%{release}
-Provides:      %{name}-standard = %{epoch}:%{version}-%{release}
+Provides:      php(date)
 Provides:      php(libxml)
 Provides:      php(modules_api) = %{php_api_version}
 Provides:      php(overload)
 %{?with_pcre:Provides: php(pcre)}
+Provides:      php(reflection)
 Provides:      php(session)
 Provides:      php(simplexml)
 Provides:      php(spl)
@@ -383,10 +380,10 @@ Provides: php(zend_extension_api) = %{zend_extension_api}
 Provides:      php(zend_module_api) = %{zend_module_api}
 Provides:      php5(debug) = %{php_debug}
 Provides:      php5(thread-safety) = %{zend_zts}
-#Obsoletes:    php-pcre < 4:5.2.0
+Obsoletes:     php-pcre < 4:5.2.0
 Obsoletes:     php-pecl-domxml
 Obsoletes:     php-session < 3:4.2.1-2
-# for the posttrans scriptlet, conflicts because in vserver enviroinment rpm package is not installed.
+Conflicts:     php4-common < 3:4.4.4-8
 Conflicts:     rpm < 4.4.2-0.2
 
 %description common
@@ -556,10 +553,9 @@ Summary:   DOM extension module for PHP
 Summary(pl):   Modu³ DOM dla PHP
 Group:         Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-# it has some compatibility functions
 Provides:      php(dom)
+# it has some compatibility functions
 Provides:      php(domxml)
-Provides:      php-domxml = %{epoch}:%{version}-%{release}
 Obsoletes:     php-domxml <= 3:4.3.8-1
 
 %description dom
@@ -598,6 +594,28 @@ library.
 Modu³ PHP dodaj±cy obs³ugê formularzy PDF poprzez bibliotekê Adobe
 FDFTK.
 
+%package filter
+Summary:       Extension for safely dealing with input parameters
+Summary(pl):   Rozszerzenie do bezpiecznej obs³ugi danych wej¶ciowych
+Group:         Libraries
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(filter)
+Obsoletes:     php-pecl-filter
+
+%description filter
+We all know that you should always check input variables, but PHP does
+not offer really good functionality for doing this in a safe way. The
+Input Filter extension is meant to address this issue by implementing
+a set of filters and mechanisms that users can use to safely access
+their input data.
+
+%description filter -l pl
+Wiadomo, ¿e trzeba zawsze sprawdzaæ zmienne wej¶ciowe, ale PHP nie
+oferuje naprawdê dobrej funkcjonalno¶ci do robienia tego w sposób
+bezpieczny. Rozszerzenie Input Filter ma rozwi±zaæ ten problem poprzez
+zaimplementowanie zestawu filtrów i mechanizmów, których u¿ytkownicy
+mog± bezpiecznie u¿ywaæ do dostêpu do danych.
+
 %package ftp
 Summary:       FTP extension module for PHP
 Summary(pl):   Modu³ FTP dla PHP
@@ -658,6 +676,21 @@ length number support with GNU MP library.
 Modu³ PHP umo¿liwiaj±cy korzystanie z biblioteki gmp do obliczeñ na
 liczbach o dowolnej d³ugo¶ci.
 
+%package hash
+Summary:       HASH Message Digest Framework
+Summary(pl):   Szkielet do obliczania skrótów wiadomo¶ci
+Group:         Libraries
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(hash)
+
+%description hash
+Native implementations of common message digest algorithms using a
+generic factory method.
+
+%description hash -l pl
+Natywne implementacje popularnych algorytmów obliczania skrótów
+wiadomo¶ci przy u¿yciu wspólnego interfejsu.
+
 %package iconv
 Summary:       iconv extension module for PHP
 Summary(pl):   Modu³ iconv dla PHP
@@ -705,6 +738,22 @@ and Firebird database support.
 %description interbase -l pl
 Modu³ PHP umo¿liwiaj±cy dostêp do baz danych InterBase i Firebird.
 
+%package json
+Summary:       PHP C extension for JSON serialization
+Summary(pl):   Rozszerzenie C PHP dla serializacji JSON
+Group:         Libraries
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(json)
+Obsoletes:     php-pecl-json
+
+%description json
+php-json is an extremely fast PHP C extension for JSON (JavaScript
+Object Notation) serialisation.
+
+%description json -l pl
+php-json to bardzo szybkie rozszerzenie C PHP dla serializacji JSON
+(JavaScript Object Notation).
+
 %package ldap
 Summary:       LDAP extension module for PHP
 Summary(pl):   Modu³ LDAP dla PHP
@@ -1407,9 +1456,9 @@ acts as a cursor going forward on the document stream and stopping at
 each node on the way.
 
 %description xmlreader -l pl
-Modu³ PHP umo¿liwiaj±cy parsowanie plików XML w trybie Pull. Czytnik
+Modu³ PHP umo¿liwiaj±cy analizê plików XML w trybie Pull. Czytnik
 dzia³a jako kursor przechodz±cy przez strumieñ dokumentu i
-zatrzymuj±cy siê naka¿dym wê¼le po drodze.
+zatrzymuj±cy siê na ka¿dym wê¼le po drodze.
 
 %package xmlrpc
 Summary:       xmlrpc extension module for PHP
@@ -1429,6 +1478,24 @@ Modu
 
 Uwaga: to jest modu³ eksperymentalny.
 
+%package xmlwriter
+Summary:       Fast, non-cached, forward-only means to write XML data
+Summary(pl):   Szybka, nie cachowana metoda zapisu danych w formacie XML
+Group:         Libraries
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(xmlwriter)
+Obsoletes:     php-pecl-xmlwriter
+
+%description xmlwriter
+This extension wraps the libxml xmlWriter API. Represents a writer
+that provides a non-cached, forward-only means of generating streams
+or files containing XML data.
+
+%description xmlwriter -l pl
+To rozszerzenie obudowuje API xmlWriter z libxml. Reprezentuje obs³ugê
+zapisu dostarczaj±c± nie cachowanych metod generowania strumieni lub
+plików zawieraj±cych dane XML.
+
 %package xsl
 Summary:       xsl extension module for PHP
 Summary(pl):   Modu³ xsl dla PHP
@@ -1482,16 +1549,18 @@ Modu
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-
+%patch5 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 cp php.ini-dist php.ini
 %patch10 -p1
 # for ac2.53b/am1.6b - AC_LANG_CXX has AM_CONDITIONAL, so cannot be invoked
 # conditionally...
 %patch11 -p1
+%patch12 -p1
 %patch14 -p1
 %patch15 -p1
 %patch16 -p1
@@ -1512,10 +1581,12 @@ patch -p1 < %{PATCH30} || exit 1
 %patch32 -p1
 %patch33 -p1
 %{?with_versioning:%patch35 -p1}
-%if "%{_lib}" == "lib64"
+%ifarch %{x8664} alpha
 %patch38 -p1
 %endif
 %patch39 -p1
+%patch40 -p1
+%patch41 -p1
 
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
@@ -1626,10 +1697,13 @@ for sapi in $sapis; do
        --enable-mbregex \
        --enable-pcntl=shared \
        --enable-pdo=shared \
+       --enable-json=shared \
+       --enable-hash=shared \
+       --enable-xmlwriter=shared \
 %if %{with mssql} || %{with sybase} || %{with sybase_ct}
        --with-pdo-dblib=shared \
 %endif
-%if %{with interbase} && %{without interbase_inst}
+%if %{with interbase} && !%{with interbase_inst}
        --with-pdo-firebird=shared \
 %endif
        --with-pdo-mysql=shared \
@@ -1689,7 +1763,8 @@ for sapi in $sapis; do
        %{?with_oci8:--with-oci8=shared} \
        %{?with_openssl:--with-openssl=shared} \
        --with-kerberos \
-       %{!?with_pcre:--without-pcre-regex --disable-filter}%{?with_pcre:--with-pcre-regex=/usr} \
+       %{!?with_pcre:--without-pcre-regex}%{?with_pcre:--with-pcre-regex=/usr} \
+       %{!?with_filter:--disable-filter}%{?with_filter:--enable-filter=shared} \
        --with-pear=%{php_pear_dir} \
        %{!?with_pgsql:--without-pgsql}%{?with_pgsql:--with-pgsql=shared,/usr} \
        --with-png-dir=/usr \
@@ -1793,6 +1868,7 @@ install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
 %endif
 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi.ini
 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/php-cli.ini
+install %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/browscap.ini
 
 %if %{with apache1}
 install %{SOURCE2} php.gif $RPM_BUILD_ROOT/home/services/apache/icons
@@ -1843,26 +1919,6 @@ install -D ext/pcre/php_pcre.h $RPM_BUILD_ROOT%{_includedir}/php/ext/pcre/php_pc
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post
-if [ "$1" = "1" ]; then
-%if %{with apache1}
-       %service -q apache restart
-%endif
-%if %{with apache2}
-       %service -q httpd restart
-%endif
-fi
-
-%postun
-if [ "$1" = "0" ]; then
-%if %{with apache1}
-       %service -q apache restart
-%endif
-%if %{with apache2}
-       %service -q httpd restart
-%endif
-fi
-
 %post -n apache1-mod_php
 if [ "$1" = "1" ]; then
        %service -q apache restart
@@ -1883,21 +1939,6 @@ if [ "$1" = "0" ]; then
        %service -q httpd restart
 fi
 
-# so tired of typing... so decided to create macros
-# macro called at extension post scriptlet
-%define        extension_post \
-if [ "$1" = "1" ]; then \
-       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart \
-       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart \
-fi
-
-# macro called at extension postun scriptlet
-%define        extension_postun \
-if [ "$1" = "0" ]; then \
-       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart \
-       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart \
-fi
-
 %post  common -p /sbin/ldconfig
 %postun        common -p /sbin/ldconfig
 
@@ -1933,353 +1974,90 @@ if [ -f %{_sysconfdir}/php-apache.ini.rpmsave ]; then
 fi
 %endif
 
-%post bcmath
-%extension_post
-
-%postun bcmath
-%extension_postun
-
-%post bzip2
-%extension_post
-
-%postun bzip2
-%extension_postun
-
-%post calendar
-%extension_post
-
-%postun calendar
-%extension_postun
-
-%post ctype
-%extension_post
-
-%postun ctype
-%extension_postun
-
-%post curl
-%extension_post
-
-%postun curl
-%extension_postun
-
-%post dba
-%extension_post
-
-%postun dba
-%extension_postun
-
-%post dbase
-%extension_post
-
-%postun dbase
-%extension_postun
-
-%post dom
-%extension_post
-
-%postun dom
-%extension_postun
-
-%post exif
-%extension_post
-
-%postun exif
-%extension_postun
-
-%post fdf
-%extension_post
-
-%postun fdf
-%extension_postun
-
-%post ftp
-%extension_post
-
-%postun ftp
-%extension_postun
-
-%post gd
-%extension_post
-
-%postun gd
-%extension_postun
-
-%post gettext
-%extension_post
-
-%postun gettext
-%extension_postun
-
-%post gmp
-%extension_post
-
-%postun gmp
-%extension_postun
-
-%post iconv
-%extension_post
-
-%postun iconv
-%extension_postun
-
-%post imap
-%extension_post
-
-%postun imap
-%extension_postun
-
-%post interbase
-%extension_post
-
-%postun interbase
-%extension_postun
-
-%post ldap
-%extension_post
-
-%postun ldap
-%extension_postun
-
-%post mbstring
-%extension_post
-
-%postun mbstring
-%extension_postun
-
-%post mcrypt
-%extension_post
-
-%postun mcrypt
-%extension_postun
-
-%post mhash
-%extension_post
-
-%postun mhash
-%extension_postun
-
-%post mime_magic
-%extension_post
-
-%postun mime_magic
-%extension_postun
-
-%post ming
-%extension_post
-
-%postun ming
-%extension_postun
-
-%post mssql
-%extension_post
-
-%postun mssql
-%extension_postun
-
-%post mysql
-%extension_post
-
-%postun mysql
-%extension_postun
-
-%post mysqli
-%extension_post
-
-%postun mysqli
-%extension_postun
-
-%post oci8
-%extension_post
-
-%postun oci8
-%extension_postun
-
-%post odbc
-%extension_post
-
-%postun odbc
-%extension_postun
-
-%post openssl
-%extension_post
-
-%postun openssl
-%extension_postun
-
-%post pdo-dblib
-%extension_post
-
-%postun pdo-dblib
-%extension_postun
-
-%post pdo-firebird
-%extension_post
-
-%postun pdo-firebird
-%extension_postun
-
-%post pdo-mysql
-%extension_post
-
-%postun pdo-mysql
-%extension_postun
-
-%post pdo-odbc
-%extension_post
-
-%postun pdo-odbc
-%extension_postun
-
-%post pdo-pgsql
-%extension_post
-
-%postun pdo-pgsql
-%extension_postun
-
-%post pdo-sqlite
-%extension_post
-
-%postun pdo-sqlite
-%extension_postun
-
-%post pgsql
-%extension_post
-
-%postun pgsql
-%extension_postun
-
-%post posix
-%extension_post
-
-%postun posix
-%extension_postun
-
-%post pspell
-%extension_post
-
-%postun pspell
-%extension_postun
-
-%post recode
-%extension_post
-
-%postun recode
-%extension_postun
-
-%post shmop
-%extension_post
-
-%postun shmop
-%extension_postun
-
-%post snmp
-%extension_post
-
-%postun snmp
-%extension_postun
-
-%post soap
-%extension_post
-
-%postun soap
-%extension_postun
-
-%post sockets
-%extension_post
-
-%postun sockets
-%extension_postun
-
-%post sqlite
-%extension_post
-
-%postun sqlite
-%extension_postun
-
-%post sybase
-%extension_post
-
-%postun sybase
-%extension_postun
-
-%post sybase-ct
-%extension_post
-
-%postun sybase-ct
-%extension_postun
-
-%post sysvmsg
-%extension_post
-
-%postun sysvmsg
-%extension_postun
-
-%post sysvsem
-%extension_post
-
-%postun sysvsem
-%extension_postun
-
-%post sysvshm
-%extension_post
-
-%postun sysvshm
-%extension_postun
-
-%post tidy
-%extension_post
-
-%postun tidy
-%extension_postun
-
-%post tokenizer
-%extension_post
-
-%postun tokenizer
-%extension_postun
-
-%post wddx
-%extension_post
-
-%postun wddx
-%extension_postun
-
-%post xml
-%extension_post
-
-%postun xml
-%extension_postun
-
-%post xmlreader
-%extension_post
-
-%postun xmlreader
-%extension_postun
-
-%post xmlrpc
-%extension_post
-
-%postun xmlrpc
-%extension_postun
-
-%post xsl
-%extension_post
-
-%postun xsl
-%extension_postun
+# macro called at extension post scriptlet
+%define        extension_post \
+if [ "$1" = "1" ]; then \
+       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart \
+       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart \
+fi
 
-%post zip
-%extension_post
+# macro called at extension postun scriptlet
+%define        extension_postun \
+if [ "$1" = "0" ]; then \
+       [ ! -f /etc/apache/conf.d/??_mod_php.conf ] || %service -q apache restart \
+       [ ! -f /etc/httpd/httpd.conf/??_mod_php.conf ] || %service -q httpd restart \
+fi
 
-%postun zip
+%define        extension_scripts() \
+%post %1 \
+%extension_post \
+\
+%postun %1 \
 %extension_postun
 
-%post zlib
-%extension_post
-
-%postun zlib
-%extension_postun
+# extension scripts defines
+%extension_scripts bcmath
+%extension_scripts bzip2
+%extension_scripts calendar
+%extension_scripts ctype
+%extension_scripts curl
+%extension_scripts dba
+%extension_scripts dbase
+%extension_scripts dom
+%extension_scripts exif
+%extension_scripts fdf
+%extension_scripts filter
+%extension_scripts ftp
+%extension_scripts gd
+%extension_scripts gettext
+%extension_scripts gmp
+%extension_scripts hash
+%extension_scripts iconv
+%extension_scripts imap
+%extension_scripts interbase
+%extension_scripts json
+%extension_scripts ldap
+%extension_scripts mbstring
+%extension_scripts mcrypt
+%extension_scripts mhash
+%extension_scripts mime_magic
+%extension_scripts ming
+%extension_scripts mssql
+%extension_scripts mysql
+%extension_scripts mysqli
+%extension_scripts oci8
+%extension_scripts odbc
+%extension_scripts openssl
+%extension_scripts pdo-dblib
+%extension_scripts pdo-firebird
+%extension_scripts pdo-mysql
+%extension_scripts pdo-odbc
+%extension_scripts pdo-pgsql
+%extension_scripts pdo-sqlite
+%extension_scripts pgsql
+%extension_scripts posix
+%extension_scripts pspell
+%extension_scripts recode
+%extension_scripts shmop
+%extension_scripts snmp
+%extension_scripts soap
+%extension_scripts sockets
+%extension_scripts sqlite
+%extension_scripts sybase
+%extension_scripts sybase-ct
+%extension_scripts sysvmsg
+%extension_scripts sysvsem
+%extension_scripts sysvshm
+%extension_scripts tidy
+%extension_scripts tokenizer
+%extension_scripts wddx
+%extension_scripts xml
+%extension_scripts xmlreader
+%extension_scripts xmlrpc
+%extension_scripts xmlwriter
+%extension_scripts xsl
+%extension_scripts zip
+%extension_scripts zlib
 
 %triggerun bcmath -- %{name}-bcmath < 4:5.0.4-9.1
 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*bcmath\.so/d' %{_sysconfdir}/php.ini
@@ -2508,6 +2286,7 @@ fi
 %dir %{_sysconfdir}
 %dir %{_sysconfdir}/conf.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/browscap.ini
 %attr(755,root,root) %{_libdir}/libphp_common-*.so
 %dir %{extensionsdir}
 
@@ -2575,6 +2354,13 @@ fi
 %attr(755,root,root) %{extensionsdir}/fdf.so
 %endif
 
+%if %{with filter}
+%files filter
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/filter.ini
+%attr(755,root,root) %{extensionsdir}/filter.so
+%endif
+
 %files exif
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/exif.ini
@@ -2600,6 +2386,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/gmp.ini
 %attr(755,root,root) %{extensionsdir}/gmp.so
 
+%files hash
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/hash.ini
+%attr(755,root,root) %{extensionsdir}/hash.so
+
 %files iconv
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/iconv.ini
@@ -2619,6 +2410,11 @@ fi
 %attr(755,root,root) %{extensionsdir}/interbase.so
 %endif
 
+%files json
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/json.ini
+%attr(755,root,root) %{extensionsdir}/json.so
+
 %if %{with ldap}
 %files ldap
 %defattr(644,root,root,755)
@@ -2719,7 +2515,7 @@ fi
 %attr(755,root,root) %{extensionsdir}/pdo_dblib.so
 %endif
 
-%if %{with interbase} && %{without interbase_inst}
+%if %{with interbase} && !%{with interbase_inst}
 %files pdo-firebird
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/pdo_firebird.ini
@@ -2791,7 +2587,9 @@ fi
 %endif
 
 %if 0
-# simplexml is needed by spl, and spl can't be built shared as of now (5.1.0RC3)
+# simplexml is needed by spl, and spl can't be built shared as of now (5.2.0)
+# simplexml can be built shared, but SPL startup fails
+# we could add R: -simplexml to -common...
 %files simplexml
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/simplexml.ini
@@ -2892,6 +2690,11 @@ fi
 %attr(755,root,root) %{extensionsdir}/xmlrpc.so
 %endif
 
+%files xmlwriter
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/xmlwriter.ini
+%attr(755,root,root) %{extensionsdir}/xmlwriter.so
+
 %files xsl
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/xsl.ini
This page took 0.065607 seconds and 4 git commands to generate.