]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
This commit was manufactured by cvs2git to create branch 'RA-
[packages/php.git] / php.spec
index a8faa995c1fb9a216894aba63ec6569d38715b61..211ffb304296d32c28af196be5d3c327a74a9b7f 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -4,19 +4,19 @@
 #   (any crash reports related to session modules?)
 #
 # Conditional build:
-%bcond_without db3             # do not use db3 packages instead of db (4.x) for Berkeley DB support
 %bcond_with    fdf             # with FDF (PDF forms) module           (BR:proprietary lib)
+%bcond_with    fribidi         # with FriBiDi extension module
+%bcond_with    interbase       # with InterBase extension module
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR:proprietary libs)
 %bcond_with    java            # with Java extension module            (BR:jdk)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR:proprietary libs)
 %bcond_with    oracle          # with oracle extension module          (BR:proprietary libs)
+%bcond_with    qtdom           # with QT DOM extension module
 %bcond_without cpdf            # without cpdf extension module
 %bcond_without curl            # without CURL extension module
+%bcond_without db3             # use db packages instead of db3 (3.x) for Berkeley DB support
 %bcond_without domxslt         # without DOM XSLT/EXSLT support in DOM XML extension module
-%bcond_with    fribidi         # with FriBiDi extension module
-%bcond_without gif             # build GD extension module with gd library without GIF support
 %bcond_without imap            # without IMAP extension module
-%bcond_with    interbase       # with InterBase extension module
 %bcond_without ldap            # without LDAP extension module
 %bcond_without mhash           # without mhash extension module
 %bcond_without ming            # without ming extension module
@@ -31,7 +31,6 @@
 %bcond_without pgsql           # without PostgreSQL extension module
 %bcond_without pspell          # without pspell extension module
 %bcond_without recode          # without recode extension module
-%bcond_with    qtdom           # with QT DOM extension module
 %bcond_without snmp            # without SNMP extension module
 %bcond_without sybase          # without Sybase and Sybase-CT extension modules
 %bcond_without wddx            # without WDDX extension module
@@ -40,9 +39,6 @@
 %bcond_without xslt            # without XSLT extension module
 %bcond_without yaz             # without YAZ extension module
 #
-# Automatic pear requirements finding:
-%include       /usr/lib/rpm/macros.php
-#
 %define        _apache2        %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
 %define        apxs            /usr/sbin/apxs
 # some problems with apache 2.x
@@ -57,6 +53,7 @@
 %ifnarch %{ix86}
 %undefine      with_msession
 %endif
+# Automatic pear requirements finding:
 %include       /usr/lib/rpm/macros.php
 Summary:       The PHP HTML-embedded scripting language for use with Apache
 Summary(fr):   Le langage de script embarque-HTML PHP pour Apache
@@ -65,18 +62,19 @@ Summary(pt_BR):     A linguagem de script PHP
 Summary(ru):   PHP ÷ÅÒÓÉÉ 4 -- ÑÚÙË ÐÒÅÐÒÏÃÅÓÓÉÒÏ×ÁÎÉÑ HTML-ÆÁÊÌÏ×, ×ÙÐÏÌÎÑÅÍÙÊ ÎÁ ÓÅÒ×ÅÒÅ
 Summary(uk):   PHP ÷ÅÒÓ¦§ 4 -- ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
-Version:       4.3.8
+Version:       4.3.10
 %define        _rc     %{nil}
 Release:       0.1
 Epoch:         3
 Group:         Libraries
 License:       PHP
-Source0:       http://downloads.php.net/ilia/%{name}-%{version}%{_rc}.tar.bz2
-# Source0-md5: e8ab484fcb94cd2e0d7ecfd0762cfd33
+Source0:       http://www.php.net/distributions/%{name}-%{version}%{_rc}.tar.bz2
+# Source0-md5: 7e56824dae9679c59a8234eb848aa542
 Source1:       FAQ.%{name}
 Source2:       zend.gif
-Source4:       %{name}-module-install
-Source5:       %{name}-mod_%{name}.conf
+Source3:       %{name}-module-install
+Source4:       %{name}-mod_%{name}.conf
+Source5:       %{name}-cgi-fcgi.ini
 Source6:       %{name}-cgi.ini
 Source7:       %{name}-apache.ini
 Source8:       %{name}-cli.ini
@@ -109,14 +107,14 @@ Patch25:  %{name}-no_pear_install.patch
 Patch26:       %{name}-zlib.patch
 Patch27:       %{name}-db-shared.patch
 Patch28:       %{name}-sybase-fix.patch
-Patch29:       %{name}-mssql-fix.patch
 Patch30:       %{name}-lib64.patch
 Patch31:       %{name}-mnogosearch-fix.patch
+Patch32:       %{name}-gd_imagerotate_enable.patch
 Icon:          php4.gif
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 BuildRequires: apache-devel
-%{?with_pspell:BuildRequires:  aspell-devel}
+%{?with_pspell:BuildRequires:  aspell-devel >= 2:0.33.7}
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1.4d
 BuildRequires: bison
@@ -130,15 +128,15 @@ BuildRequires:    cyrus-sasl-devel
 BuildRequires: expat-devel
 %endif
 %{?with_fdf:BuildRequires:     fdftk-devel}
+BuildRequires: file >= 4.00
 BuildRequires: flex
 %if %{with mssql} || %{with sybase}
 BuildRequires: freetds-devel
 %endif
 BuildRequires: freetype-devel >= 2.0
 %{?with_fribidi:BuildRequires: fribidi-devel >= 0.10.4}
-BuildRequires: gd-devel >= 2.0.1
-%{?with_gif:BuildRequires:     gd-devel(gif)}
-%{!?with_gif:BuildConflicts:   gd-devel(gif)}
+BuildRequires: gd-devel >= 2.0.28-1.3
+BuildRequires: gd-devel(gif)
 BuildRequires: gdbm-devel
 BuildRequires: gmp-devel
 %{?with_imap:BuildRequires:    imap-devel >= 1:2001-0.BETA.200107022325.2 }
@@ -656,9 +654,9 @@ Summary(pl):        Modu
 Group:         Libraries
 Requires(post,preun):  %{name}-common = %{epoch}:%{version}
 Requires:      %{name}-common = %{epoch}:%{version}
-Requires:      gd >= 2.0.20
-%{?with_gif:Requires:  gd(gif)}
-%{?with_gif:Provides:  %{name}-gd(gif) = %{epoch}:%{version}-%{release}}
+Requires:      gd >= 2.0.28-1.3
+Requires:      gd(gif)
+Provides:      %{name}-gd(gif) = %{epoch}:%{version}-%{release}
 
 %description gd
 This is a dynamic shared object (DSO) for PHP that will add GD
@@ -1465,6 +1463,7 @@ Summary(pl):      PEAR - Rozszerzenie PHP i Repozytorium Aplikacji
 Group:         Development/Languages/PHP
 Requires:      %{name}-pcre = %{epoch}:%{version}
 Requires:      %{name}-xml = %{epoch}:%{version}
+Obsoletes:     php-pear-additional_classes <= 4.3
 
 %description pear
 PEAR - PHP Extension and Application Repository.
@@ -1548,15 +1547,15 @@ cp php.ini-dist php.ini
 %patch22 -p1
 %patch23 -p1
 %patch24 -p1
-%{!?with_pear:%patch25 -p1}
+%patch25 -p1
 %patch26 -p1
 %patch27 -p1
 %patch28 -p1
-%patch29 -p1
 %ifarch amd64
 %patch30 -p1
 %endif
-%patch31 -p1
+#%patch31 -p1
+%patch32 -p1
 
 %build
 CFLAGS="%{rpmcflags} -DEAPI=1 -I%{_prefix}/X11R6/include"
@@ -1565,12 +1564,12 @@ EXTENSION_DIR="%{extensionsdir}"; export EXTENSION_DIR
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
-PROG_SENDMAIL="%{_prefix}/lib/sendmail"; export PROG_SENDMAIL
+PROG_SENDMAIL="/usr/lib/sendmail"; export PROG_SENDMAIL
 for i in fcgi cgi cli apxs ; do
 %configure \
        `[ $i = cgi ] && echo --enable-discard-path` \
        `[ $i = cli ] && echo --disable-cgi` \
-`[ $i = fcgi ] && echo --enable-fastcgi --with-fastcgi=%{_prefix}` \
+       `[ $i = fcgi ] && echo --enable-fastcgi --with-fastcgi=%{_prefix}` \
 %if %{_apache2}
        `[ $i = apxs ] && echo --with-apxs2=%{apxs}` \
        --enable-experimental-zts \
@@ -1726,17 +1725,18 @@ install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache},%{_sysconfdir}/{apache,cgi}}
        INSTALL_IT="\$(LIBTOOL) --mode=install install libphp_common.la $RPM_BUILD_ROOT%{_libdir} ; \$(LIBTOOL) --mode=install install libphp4.la $RPM_BUILD_ROOT%{_libdir}/apache ; \$(LIBTOOL) --mode=install install sapi/cgi/php $RPM_BUILD_ROOT%{_bindir}/php.cgi ; \$(LIBTOOL) --mode=install install sapi/fcgi/php $RPM_BUILD_ROOT%{_bindir}/php.fcgi" \
        INSTALL_CLI="\$(LIBTOOL) --mode=install install sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/php.cli"
 
+install -d $RPM_BUILD_ROOT%{php_pear_dir}/pear/{Archive,Console,Crypt,Image,Net,Science,XML,HTML/Template}
+
 # compatibility (/usr/bin/php used to be CGI SAPI)
 ln -sf php.cgi $RPM_BUILD_ROOT%{_bindir}/php
 
 %{?with_java:install ext/java/php_java.jar $RPM_BUILD_ROOT%{extensionsdir}}
 
 install php.ini        $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
-install %{SOURCE6} %{SOURCE7} %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}
-install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
+install %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}
 install %{SOURCE2} php.gif $RPM_BUILD_ROOT%{httpdir}/icons
-install %{SOURCE4} $RPM_BUILD_ROOT%{_sbindir}
-install %{SOURCE5} $RPM_BUILD_ROOT/etc/httpd/httpd.conf/70_mod_php.conf
+install %{SOURCE3} $RPM_BUILD_ROOT%{_sbindir}
+install %{SOURCE4} $RPM_BUILD_ROOT/etc/httpd/httpd.conf/70_mod_php.conf
 
 install %{SOURCE1} .
 
@@ -2761,28 +2761,13 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/zlib.so
 
-%if %{with pear}
 %files pear
 %defattr(644,root,root,755)
 %dir %{php_pear_dir}
-%dir %{php_pear_dir}/Archive
-%dir %{php_pear_dir}/Auth
-%dir %{php_pear_dir}/Console
-%dir %{php_pear_dir}/Crypt
-%dir %{php_pear_dir}/Date
-%dir %{php_pear_dir}/DB
-%dir %{php_pear_dir}/File
-%dir %{php_pear_dir}/HTML
-%dir %{php_pear_dir}/HTML/Template
-%dir %{php_pear_dir}/HTTP
-%dir %{php_pear_dir}/Image
-%dir %{php_pear_dir}/Mail
-%dir %{php_pear_dir}/Net
-%dir %{php_pear_dir}/PEAR
-%dir %{php_pear_dir}/Schedule
-%dir %{php_pear_dir}/Science
-%dir %{php_pear_dir}/XML
+%dir %{php_pear_dir}/*
+%dir %{php_pear_dir}/*/*
 
+%if 0
 %files pear-additional_classes
 %defattr(644,root,root,755)
 %attr(644,root,root) %{php_pear_dir}/Crypt/HCEMD5.php
This page took 0.149187 seconds and 4 git commands to generate.