]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- build on x32 with a help of slightly modified upstream patch
[packages/php.git] / php.spec
index 16e7b61a824d6e47d28af9e6a3c603fb224e4207..177f67ab913c04469e04ca241976a122540ede1f 100644 (file)
--- a/php.spec
+++ b/php.spec
 %undefine      with_mm
 %endif
 
-%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha
+%ifnarch %{ix86} %{x8664} x32 sparc sparcv9 alpha
 # ppc disabled (broken on th-ppc)
 %undefine      with_interbase
 %endif
 
-%ifnarch %{ix86} %{x8664}
+%ifnarch %{ix86} %{x8664} x32
 # unsupported, see sapi/cgi/fpm/fpm_atomic.h
 %undefine      with_fpm
 %endif
@@ -119,7 +119,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %endif
 %endif
 
-%define                rel     11
+%define                rel     12
 %define                orgname php
 %define                ver_suffix 53
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -207,8 +207,9 @@ Patch64:    %{orgname}-m4.patch
 Patch65:       system-libzip.patch
 Patch66:       %{orgname}-db.patch
 Patch67:       php-litespeed.patch
-Patch68:       mysql-lib-ver-mismatch.patch
+Patch68:       x32.patch
 Patch69:       fpm-conf-split.patch
+Patch70:       mysql-lib-ver-mismatch.patch
 # Fixes for security bugs
 # https://repo.webtatic.com/yum/centos/5/SRPMS/repoview/php.html
 # also from RHEL6/CentOS7
@@ -2072,6 +2073,7 @@ cp -p php.ini-production php.ini
 gzip -dc %{SOURCE15} | tar xf - -C sapi/
 %patch67 -p1
 %patch68 -p1
+%patch70 -p1
 
 %patch220 -p1
 %patch238 -p1
@@ -2767,6 +2769,10 @@ done
 %triggerpostun common -- %{name}-common < 4:5.3.29-7, php-common < 4:5.3.29-7
 # switch to browscap package if the ini file has original value
 %{__sed} -i -e 's#%{_sysconfdir}/browscap.ini#/usr/share/browscap/php_browscap.ini#' %{_sysconfdir}/php.ini
+# disable browscap, if optional package not present
+if [ ! -e /usr/share/browscap/php_browscap.ini ]; then
+       %{__sed} -i -e 's#^browscap = /usr/share/browscap/php_browscap.ini#;&#' %{_sysconfdir}/php.ini
+fi
 
 # common macros called at extension post/postun scriptlet
 %define        extension_scripts() \
This page took 0.039094 seconds and 4 git commands to generate.