]> git.pld-linux.org Git - packages/php.git/blobdiff - php-fpm-config.patch
adjust x32 patch for 5.3 branch
[packages/php.git] / php-fpm-config.patch
index f953a12e975069ba8169a45226d74cc6d8a91632..8f5bf23a9a9a520dccfda4ed02322e9cf70ceac1 100644 (file)
@@ -1,6 +1,89 @@
---- php-5.3.3/sapi/fpm/php-fpm.conf.in~        2010-05-29 13:39:35.000000000 +0300
-+++ php-5.3.3/sapi/fpm/php-fpm.conf.in 2010-07-24 22:29:56.752470466 +0300
-@@ -245,7 +245,7 @@
+--- php-5.3.29/sapi/fpm/php-fpm.conf.in        2014-10-27 07:58:34.296908403 +0200
++++ php-5.3.29.old/sapi/fpm/php-fpm.conf.in    2014-10-27 07:46:00.292540344 +0200
+@@ -14,14 +15,14 @@
+ ; Pid file
+ ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
+ ; Default Value: none
+-;pid = run/php-fpm.pid
++pid = /var/run/@processname@.pid
+ ; Error log file
+ ; If it's set to "syslog", log is sent to syslogd instead of being written
+ ; in a local file.
+ ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
+ ; Default Value: log/php-fpm.log
+-;error_log = log/php-fpm.log
++error_log = /var/log/php/@processname@.log
+ ; syslog_facility is used to specify what type of program is logging the
+ ; message. This lets syslogd specify that messages from different facilities
+--- php-5.3.29.old/sapi/fpm/php-fpm.conf-d.in  2014-10-27 07:46:00.639222822 +0200
++++ php-5.3.29/sapi/fpm/php-fpm.conf-d.in      2014-10-27 08:02:11.543472244 +0200
+@@ -30,7 +30,7 @@
+ ;                            specific port;
+ ;   '/path/to/unix/socket' - to listen on a unix socket.
+ ; Note: This value is mandatory.
+-listen = 127.0.0.1:9000
++listen = /var/run/php/@processname@.sock
+ ; Set listen(2) backlog. A value of '-1' means unlimited.
+ ; Default Value: 128 (-1 on FreeBSD and OpenBSD)
+@@ -41,9 +41,9 @@
+ ; BSD-derived systems allow connections regardless of permissions. 
+ ; Default Values: user and group are set as the running user
+ ;                 mode is set to 0660
+-;listen.owner = @php_fpm_user@
+-;listen.group = @php_fpm_group@
+-;listen.mode = 0660
++listen.owner = root
++listen.group = @php_fpm_group@
++listen.mode = 0660
+  
+ ; List of ipv4 addresses of FastCGI clients which are allowed to connect.
+ ; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original
+@@ -51,7 +51,7 @@
+ ; must be separated by a comma. If this value is left blank, connections will be
+ ; accepted from any ip address.
+ ; Default Value: any
+-;listen.allowed_clients = 127.0.0.1
++listen.allowed_clients = 127.0.0.1
+ ; Specify the nice(2) priority to apply to the pool processes (only if set)
+ ; The value can vary from -19 (highest priority) to 20 (lower priority)
+@@ -106,12 +106,12 @@
+ ; The desired minimum number of idle server processes.
+ ; Note: Used only when pm is set to 'dynamic'
+ ; Note: Mandatory when pm is set to 'dynamic'
+-pm.min_spare_servers = 1
++pm.min_spare_servers = 2
+ ; The desired maximum number of idle server processes.
+ ; Note: Used only when pm is set to 'dynamic'
+ ; Note: Mandatory when pm is set to 'dynamic'
+-pm.max_spare_servers = 3
++pm.max_spare_servers = 5
+ ; The number of seconds after which an idle process will be killed.
+ ; Note: Used only when pm is set to 'ondemand'
+@@ -221,7 +221,7 @@
+ ;       anything, but it may not be a good idea to use the .php extension or it
+ ;       may conflict with a real PHP file.
+ ; Default Value: not set 
+-;pm.status_path = /status
++;pm.status_path = /fpm-status
+  
+ ; The ping URI to call the monitoring page of FPM. If this value is not set, no
+ ; URI will be recognized as a ping page. This could be used to test from outside
+@@ -347,7 +347,7 @@
+ ; Note: on highloaded environement, this can cause some delay in the page
+ ; process time (several ms).
+ ; Default Value: no
+-;catch_workers_output = yes
++catch_workers_output = yes
+ ; Limits the extensions of the main script FPM will allow to parse. This can
+ ; prevent configuration mistakes on the web server side. You should only limit
+@@ -361,7 +361,7 @@
  ; the current environment.
  ; Default Value: clean env
  ;env[HOSTNAME] = $HOSTNAME
@@ -9,3 +92,25 @@
  ;env[TMP] = /tmp
  ;env[TMPDIR] = /tmp
  ;env[TEMP] = /tmp
+--- php-5.3.9/sapi/fpm/status.html.in~ 2011-10-08 23:43:12.000000000 +0300
++++ php-5.3.9/sapi/fpm/status.html.in  2012-01-12 02:19:09.573191879 +0200
+@@ -96,7 +96,7 @@
+                       var sort_index;
+                       var sort_order;
+-                      doc_url.value = location.protocol + '//' + location.host + "/status?json&full";
++                      doc_url.value = location.protocol + '//' + location.host + "/fpm-status?json&full";
+                       ths = document.getElementsByTagName("th");
+                       for (var i=0; i<ths.length; i++) {
+--- php-5.3.29/sapi/fpm/Makefile.frag~ 2014-10-27 07:57:09.000000000 +0200
++++ php-5.3.29/sapi/fpm/Makefile.frag  2014-10-27 07:57:29.523957175 +0200
+@@ -21,7 +21,7 @@
+       @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
+       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/fpm.d || :
+-      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default || :
++      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf || :
+       @$(INSTALL_DATA) sapi/fpm/php-fpm.conf-d $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf || :
+       @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"
This page took 0.028155 seconds and 4 git commands to generate.