]> git.pld-linux.org Git - packages/php.git/blobdiff - php-fpm-config.patch
moved C: logrotate to proper subpackage (containing logrotate file)
[packages/php.git] / php-fpm-config.patch
index ad3bf69ef21388267cb4cc4e0c67191bbb78433e..8f5bf23a9a9a520dccfda4ed02322e9cf70ceac1 100644 (file)
@@ -1,33 +1,56 @@
---- php-5.3.9/sapi/fpm/php-fpm.conf.in~        2012-01-11 21:38:12.000000000 +0200
-+++ php-5.3.9/sapi/fpm/php-fpm.conf.in 2012-01-11 21:39:02.535951773 +0200
-@@ -22,7 +22,7 @@
+--- php-5.3.29/sapi/fpm/php-fpm.conf.in        2014-10-27 07:58:34.296908403 +0200
++++ php-5.3.29.old/sapi/fpm/php-fpm.conf.in    2014-10-27 07:46:00.292540344 +0200
+@@ -14,14 +15,14 @@
  ; Pid file
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
  ; Default Value: none
 -;pid = run/php-fpm.pid
-+pid = /var/run/php/fpm.pid
++pid = /var/run/@processname@.pid
  
  ; Error log file
+ ; If it's set to "syslog", log is sent to syslogd instead of being written
+ ; in a local file.
  ; Note: the default prefix is @EXPANDED_LOCALSTATEDIR@
-@@ -93,7 +93,7 @@
+ ; Default Value: log/php-fpm.log
+-;error_log = log/php-fpm.log
++error_log = /var/log/php/@processname@.log
+ ; syslog_facility is used to specify what type of program is logging the
+ ; message. This lets syslogd specify that messages from different facilities
+--- php-5.3.29.old/sapi/fpm/php-fpm.conf-d.in  2014-10-27 07:46:00.639222822 +0200
++++ php-5.3.29/sapi/fpm/php-fpm.conf-d.in      2014-10-27 08:02:11.543472244 +0200
+@@ -30,7 +30,7 @@
  ;                            specific port;
  ;   '/path/to/unix/socket' - to listen on a unix socket.
  ; Note: This value is mandatory.
 -listen = 127.0.0.1:9000
-+listen = /var/run/php/fpm.sock
++listen = /var/run/php/@processname@.sock
  
  ; Set listen(2) backlog. A value of '-1' means unlimited.
  ; Default Value: 128 (-1 on FreeBSD and OpenBSD)
-@@ -105,7 +105,7 @@
+@@ -41,9 +41,9 @@
+ ; BSD-derived systems allow connections regardless of permissions. 
+ ; Default Values: user and group are set as the running user
+ ;                 mode is set to 0660
+-;listen.owner = @php_fpm_user@
+-;listen.group = @php_fpm_group@
+-;listen.mode = 0660
++listen.owner = root
++listen.group = @php_fpm_group@
++listen.mode = 0660
+  
+ ; List of ipv4 addresses of FastCGI clients which are allowed to connect.
+ ; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original
+@@ -51,7 +51,7 @@
  ; must be separated by a comma. If this value is left blank, connections will be
  ; accepted from any ip address.
  ; Default Value: any
 -;listen.allowed_clients = 127.0.0.1
 +listen.allowed_clients = 127.0.0.1
  
- ; Set permissions for unix socket, if one is used. In Linux, read/write
- ; permissions must be set in order to allow connections from a web server. Many
-@@ -208,12 +208,12 @@
+ ; Specify the nice(2) priority to apply to the pool processes (only if set)
+ ; The value can vary from -19 (highest priority) to 20 (lower priority)
+@@ -106,12 +106,12 @@
  ; The desired minimum number of idle server processes.
  ; Note: Used only when pm is set to 'dynamic'
  ; Note: Mandatory when pm is set to 'dynamic'
@@ -42,7 +65,7 @@
  
  ; The number of seconds after which an idle process will be killed.
  ; Note: Used only when pm is set to 'ondemand'
-@@ -214,7 +214,7 @@
+@@ -221,7 +221,7 @@
  ;       anything, but it may not be a good idea to use the .php extension or it
  ;       may conflict with a real PHP file.
  ; Default Value: not set 
   
  ; The ping URI to call the monitoring page of FPM. If this value is not set, no
  ; URI will be recognized as a ping page. This could be used to test from outside
-@@ -277,7 +277,7 @@
+@@ -347,7 +347,7 @@
+ ; Note: on highloaded environement, this can cause some delay in the page
+ ; process time (several ms).
+ ; Default Value: no
+-;catch_workers_output = yes
++catch_workers_output = yes
+ ; Limits the extensions of the main script FPM will allow to parse. This can
+ ; prevent configuration mistakes on the web server side. You should only limit
+@@ -361,7 +361,7 @@
  ; the current environment.
  ; Default Value: clean env
  ;env[HOSTNAME] = $HOSTNAME
  
                        ths = document.getElementsByTagName("th");
                        for (var i=0; i<ths.length; i++) {
---- php-5.3.9/sapi/fpm/Makefile.frag~  2012-01-11 21:49:42.000000000 +0200
-+++ php-5.3.9/sapi/fpm/Makefile.frag   2012-01-12 02:20:25.553355153 +0200
+--- php-5.3.29/sapi/fpm/Makefile.frag~ 2014-10-27 07:57:09.000000000 +0200
++++ php-5.3.29/sapi/fpm/Makefile.frag  2014-10-27 07:57:29.523957175 +0200
 @@ -21,7 +21,7 @@
        @echo "Installing PHP FPM config:        $(INSTALL_ROOT)$(sysconfdir)/" && \
-       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir) || :
+       $(mkinstalldirs) $(INSTALL_ROOT)$(sysconfdir)/fpm.d || :
  
 -      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf.default || :
 +      @$(INSTALL_DATA) sapi/fpm/php-fpm.conf $(INSTALL_ROOT)$(sysconfdir)/php-fpm.conf || :
+       @$(INSTALL_DATA) sapi/fpm/php-fpm.conf-d $(INSTALL_ROOT)$(sysconfdir)/fpm.d/www.conf || :
  
        @echo "Installing PHP FPM man page:      $(INSTALL_ROOT)$(mandir)/man8/"
-       @$(mkinstalldirs) $(INSTALL_ROOT)$(mandir)/man8
This page took 0.152752 seconds and 4 git commands to generate.