]> git.pld-linux.org Git - packages/php.git/blobdiff - fix-test-run.patch
adjust x32 patch for 5.3 branch
[packages/php.git] / fix-test-run.patch
index 12dd192951b1786563c15373598076c68d843918..15f3d3b61c3ff6a5c2f984b2d6c5ca4f6bb9660e 100644 (file)
@@ -12,8 +12,8 @@
  PHP_SUBST(PHP_MODULES)
  PHP_SUBST(PHP_ZEND_EX)
  
---- php-5.3.29/Makefile.global~        2014-08-19 16:59:48.000000000 +0300
-+++ php-5.3.29/Makefile.global 2014-08-19 17:47:47.112627301 +0300
+--- php-5.3.29/Makefile.global 2014-11-23 04:22:05.601031944 +0200
++++ php-5.3.29/Makefile.global 2015-01-21 15:04:38.046113239 +0200
 @@ -77,8 +77,15 @@
                done; \
        fi
        if test "x$(PHP_MODULES)" != "x"; then \
                for i in $(PHP_MODULES)""; do \
                        . $$i; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
-@@ -114,7 +114,9 @@
+@@ -92,7 +99,7 @@
+ PHP_DEPRECATED_DIRECTIVES_REGEX = '^(define_syslog_variables|register_(globals|long_arrays)?|safe_mode|magic_quotes_(gpc|runtime|sybase)?|(zend_)?extension(_debug)?(_ts)?)[\t\ ]*='
+ test: all
+-      -@if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
++      @if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
+               INI_FILE=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r 'echo php_ini_loaded_file();' 2> /dev/null`; \
+               if test "$$INI_FILE"; then \
+                       $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini; \
+@@ -107,7 +114,10 @@
                TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
                TEST_PHP_SRCDIR=$(top_srcdir) \
                CC="$(CC)" \
 -                      $(PHP_EXECUTABLE) -n -c $(top_builddir)/tmp-php.ini $(PHP_TEST_SETTINGS) $(top_srcdir)/run-tests.php -n -c $(top_builddir)/tmp-php.ini -d extension_dir=$(top_builddir)/modules/ $(PHP_TEST_SHARED_EXTENSIONS) $(TESTS); \
++                      $(PHP_EXECUTABLE) -n -c $(top_builddir)/tmp-php.ini \
 +                      -d extension_dir=$(top_builddir)/modules/ -d 'extension=$(EXTENSION_DIR)/pcre.$(SHLIB_DL_SUFFIX_NAME)' \
 +                      $(PHP_TEST_SETTINGS) $(top_srcdir)/run-tests.php -n -c $(top_builddir)/tmp-php.ini -d extension_dir=$(top_builddir)/modules/ $(PHP_TEST_SHARED_EXTENSIONS) \
 +                      $(RUN_TESTS_SETTINGS) $(TESTS); \
This page took 0.05025 seconds and 4 git commands to generate.