]> git.pld-linux.org Git - packages/php.git/blame_incremental - php.spec
- -gd R: gd(gif) made conditional (disabled if building w/o gif support); release 3
[packages/php.git] / php.spec
... / ...
CommitLineData
1#
2# Automatic pear requirements finding:
3%include /usr/lib/rpm/macros.php
4
5%define _apache2 %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
6%define apxs /usr/sbin/apxs
7
8%if %{_apache2}
9%define _without_recode 1
10%define _without_mm 1
11%endif
12
13%ifnarch %{ix86}
14%define _without_msession 1
15%endif
16
17# Conditional build:
18# _with_interbase - with InterBase extension module (BR: proprietary libs)
19# _with_java - with Java extension module (BR: jdk)
20# _with_oci8 - with Oracle oci8 extension module (BR: proprietary libs)
21# _with_oracle - with oracle extension module (BR: proprietary libs)
22# _with_pcntl - with pcntl extension module (problems: SEGV on exit)
23# _without_cpdf - without cpdf extension module
24# _without_domxslt - without DOM XSLT/EXSLT support in DOM XML extension module
25# _without_gif - build GD extension module with gd library without GIF support
26# _without_imap - without IMAP extension module
27# _without_ldap - without LDAP extension module
28# _without_mm - without mm support for session storage
29# _without_msession - without msession extension module
30# _without_odbc - without ODBC extension module
31# _without_openssl - without OpenSSL support and OpenSSL extension module
32# _without_pcre - without PCRE extension module
33# _without_pdf - without PDF extension module
34# _without_snmp - without SNMP extension module
35# _without_recode - without recode extension module
36# _without_sybase_ct - without Sybase-CT extension module
37# _without_wddx - without WDDX extension module
38# _without_xml - without XML extension module
39# _without_xmlrpc - without XML-RPC extension module
40# _without_xslt - without XSLT extension module
41Summary: The PHP HTML-embedded scripting language for use with Apache
42Summary(fr): Le langage de script embarque-HTML PHP pour Apache
43