]> git.pld-linux.org Git - packages/php.git/blame_incremental - php.spec
- todo cleanup (--enable-versioning does not work with shared modules and probably...
[packages/php.git] / php.spec
... / ...
CommitLineData
1# TODO:
2# - think of including support for:
3# - mcve,
4# - ovrimos,
5# - pfpro,
6# These extensions BuildRequires proprietary libraries...
7# - deal with modules removed from php and not moved to PECL
8# (existing only in php4):
9# db, hyperwave, java, mcal, overload, qtdom
10# and removed from php 5.1:
11# cpdf, dio, dbx, fam, yp, oracle
12# - mime_magic can't handle new "string/*" entries in magic.mime
13# - make additional headers added by mail patch configurable
14# - apply -hardened patch by default ?
15# - modularize session, standard (output from pure php -m)?
16#
17# Conditional build:
18%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
19%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
20%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
21%bcond_with hwapi # with Hw API support (BR: proprietary libs)
22%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
23%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
24%bcond_without curl # without CURL extension module
25%bcond_without imap # without IMAP extension module
26%bcond_without interbase # with InterBase extension module
27%bcond_without ldap # without LDAP extension module
28%bcond_without mhash # without mhash extension module
29%bcond_without ming # without ming extension module
30%bcond_without mm # without mm support for session storage
31%bcond_without msession # without msession extension module
32%bcond_without mssql # without MS SQL extension module
33%bcond_without mime_magic # without mime-magic module
34%bcond_without odbc # without ODBC extension module
35%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
36%bcond_without pcre # without PCRE extension module
37%bcond_without pgsql # without PostgreSQL extension module
38%bcond_without pspell # without pspell extension module
39%bcond_without recode # without recode extension module
40%bcond_without snmp # without SNMP extension module
41%bcond_without sqlite # without SQLite extension module
42%bcond_without sybase # without Sybase extension module
43%bcond_without sybase_ct # without Sybase-CT extension module
44%bcond_without tidy # without Tidy extension module
45%bcond_without wddx # without WDDX extension module
46%bcond_without xmlrpc # without XML-RPC extension module
47%bcond_without apache1 # disable building apache 1.3.x module
48%bcond_without apache2 # disable building apache 2.x module
49%bcond_without fcgi # disable building FCGI SAPI
50%bcond_without zts # disable experimental-zts
51%bcond_without mysqli # with mysqli support (Requires mysql > 4.1)
52
53%define apxs1 /usr/sbin/apxs1
54%define apxs2 /usr/sbin/apxs
55
56# some problems with apache 2.x
57%if %{with apache2}
58%undefine with_mm
59%endif
60
61%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
62%undefine with_interbase
63%endif
64
65%if %{without apache1} && %{without apache2}
66ERROR: You need to select at least one Apache SAPI to build shared modules.
67%endif
68
69# x86-only lib
70%ifnarch %{ix86}
71%undefine with_msession
72%endif
73
74Summary: The PHP HTML-embedded scripting language for use with Apache
75Summary(fr): Le langage de script embarque-HTML PHP pour Apache
76