]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- strange SEGVs seem to be caused by dlclose() bugs in glibc <= 2.3.4 - R: glibc...
[packages/php.git] / php.spec
CommitLineData
6404edba 1#
82bb3a40 2# TODO:
54eb743b 3# - php-shared is SERIOUSLY broken. Try compiling with --enable-versioning.
8c91402c
AM
4# - think of including support for:
5# - mcve,
6# - ovrimos,
7# - pfpro,
8# - ircg,
9# These extensions BuildRequires proprietary libraries...
d0822c6c
JB
10# - deal with modules removed from php and not moved to PECL
11# (existing only in php4):
737e42ad 12# db, hyperwave, java, mcal, overload, qtdom
1ffa7abd 13# - mime_magic can't handle new "string/*" entries in magic.mime
6392ee57 14# - make additional headers added by mail patch configurable
543a3683 15# - apply -hardened patch by default ?
82bb3a40 16#
6f91d99f
JB
17# Conditional build:
18%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 19%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
4f8ad92f 20%bcond_with hardened # build with hardened patch applied (http://www.hardened-php.net/)
28106fe7 21%bcond_with hwapi # with Hw API support (BR: proprietary libs)
6f91d99f 22%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f
JB
23%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
24%bcond_with oracle # with oracle extension module (BR: proprietary libs)
74f7e4ba 25%bcond_with apache1 # build with apache1
ec7c6e14 26%bcond_without mysqli # with mysqli support (Requires mysql > 4.1)
6f91d99f
JB
27%bcond_without cpdf # without cpdf extension module
28%bcond_without curl # without CURL extension module
8c91402c 29%bcond_without fam # without FAM (File Alteration Monitor) extension module
6f91d99f
JB
30%bcond_without imap # without IMAP extension module
31%bcond_without interbase # without InterBase extension module
32%bcond_without ldap # without LDAP extension module
33%bcond_without mhash # without mhash extension module
34%bcond_without ming # without ming extension module
35%bcond_without mm # without mm support for session storage
36%bcond_without mnogosearch # without mnogosearch extension module
37%bcond_without msession # without msession extension module
38%bcond_without mssql # without MS SQL extension module
39%bcond_without odbc # without ODBC extension module
40%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
41%bcond_without pcre # without PCRE extension module
6f91d99f 42%bcond_without pgsql # without PostgreSQL extension module
274395e3 43%bcond_without pspell # without pspell extension module
6f91d99f 44%bcond_without recode # without recode extension module
6f91d99f 45%bcond_without snmp # without SNMP extension module
8c91402c 46%bcond_without sqlite # without SQLite extension module
41a6f471 47%bcond_without sybase # without Sybase extension module
4cc60252 48%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 49%bcond_without tidy # without Tidy extension module
6f91d99f
JB
50%bcond_without wddx # without WDDX extension module
51%bcond_without xmlrpc # without XML-RPC extension module
74f7e4ba
ER
52
53%define _apache2 %{?with_apache1:0}%{!?with_apache1:1}
7f3d706a 54%if %{_apache2}
41a9af21 55%define apxs /usr/sbin/apxs
7f3d706a 56%else
85a72066 57%define apxs /usr/sbin/apxs1
7f3d706a 58%endif
6f91d99f 59# some problems with apache 2.x
ab092fe1 60%if %{_apache2}
6f91d99f 61%undefine with_mm
ab092fe1 62%endif
c37dabc8 63%ifnarch %{ix86} amd64 sparc sparcv9 alpha ppc
6f91d99f 64%undefine with_interbase
52bba439 65%endif
6e4962cf 66# x86-only lib
52bba439 67%ifnarch %{ix86}
6f91d99f 68%undefine with_msession
c2388c7d 69%endif
6f91d99f 70%include /usr/lib/rpm/macros.php
caff8ce9 71Summary: The PHP HTML-embedded scripting language for use with Apache
72Summary(fr): Le langage de script embarque-HTML PHP pour Apache
881802d3 73