]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- Release: 4 (STBR after AMD64 fixes)
[packages/php.git] / php.spec
CommitLineData
6404edba 1#
82bb3a40 2# TODO:
4342041a 3# - fastcgi option in cgi SAPI? or separate fcgi SAPI?
ce68b400
JB
4# - make sure that session-unregister patch is no longer needed
5# (any crash reports related to session modules?)
82bb3a40 6#
6f91d99f
JB
7# Conditional build:
8%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
9%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
10%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
11%bcond_with java # with Java extension module (BR: jdk)
12%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
13%bcond_with oracle # with oracle extension module (BR: proprietary libs)
14%bcond_without cpdf # without cpdf extension module
15%bcond_without curl # without CURL extension module
16%bcond_without domxslt # without DOM XSLT/EXSLT support in DOM XML extension module
17%bcond_without fribidi # without FriBiDi extension module
18%bcond_without gif # build GD extension module with gd library without GIF support
19%bcond_without imap # without IMAP extension module
20%bcond_without interbase # without InterBase extension module
21%bcond_without ldap # without LDAP extension module
22%bcond_without mhash # without mhash extension module
23%bcond_without ming # without ming extension module
24%bcond_without mm # without mm support for session storage
25%bcond_without mnogosearch # without mnogosearch extension module
26%bcond_without msession # without msession extension module
27%bcond_without mssql # without MS SQL extension module
28%bcond_without odbc # without ODBC extension module
29%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
30%bcond_without pcre # without PCRE extension module
31%bcond_without pdf # without PDF extension module
32%bcond_without pgsql # without PostgreSQL extension module
274395e3 33%bcond_without pspell # without pspell extension module
6f91d99f
JB
34%bcond_without recode # without recode extension module
35%bcond_without qtdom # without QT DOM extension module
36%bcond_without snmp # without SNMP extension module
37%bcond_without sybase # without Sybase and Sybase-CT extension modules
38%bcond_without wddx # without WDDX extension module
39%bcond_without xmlrpc # without XML-RPC extension module
40%bcond_without xml # without XML and DOMXML extension modules
41%bcond_without xslt # without XSLT extension module
42%bcond_without yaz # without YAZ extension module
43#
c2388c7d 44%define _apache2 %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
41a9af21 45%define apxs /usr/sbin/apxs
6f91d99f 46# some problems with apache 2.x
ab092fe1 47%if %{_apache2}
6f91d99f
JB
48%undefine with_recode
49%undefine with_mm
ab092fe1 50%endif
6f91d99f 51# x86-only libs
c2388c7d 52%ifnarch %{ix86}
6f91d99f
JB
53%undefine with_interbase
54%undefine with_msession
c2388c7d 55%endif
6f91d99f 56%include /usr/lib/rpm/macros.php
caff8ce9 57Summary: The PHP HTML-embedded scripting language for use with Apache
58Summary(fr): Le langage de script embarque-HTML PHP pour Apache
59