]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- 5.2.1, but threading libs not found
[packages/php.git] / php.spec
CommitLineData
82bb3a40 1# TODO:
b2a7d06d
ER
2
3Configuring TSRM
4checking for i686-pld-linux-ranlib... no
5checking for ranlib... ranlib
6checking for stdarg.h... (cached) yes
7checking for pthreads_cflags... (cached) -pthread
8checking for pthreads_lib... (cached) pthread
9configure: error: Your system seems to lack POSIX threads.
10error: Bad exit status from /var/tmp/rpm-tmp.2373 (%build)
11
12
13RPM build errors:
14 Bad exit status from /var/tmp/rpm-tmp.2373 (%build)
15
16shell returned 1
17
18
ae9fd9ae
JB
19# - deal with modules removed from php and not moved to PECL, still not obsoleted anywhere
20# - removed from php 5.0 (currently in php4):
21# db, hyperwave, java, mcal, overload, qtdom
22# - removed from php 5.1:
23# cpdf, fam, oracle
24# - removed from php 5.2:
7aa94fdb 25# filepro, hw
1ffa7abd 26# - mime_magic can't handle new "string/*" entries in magic.mime
9091cd7b 27# thus doesn't work with system magic.mime database
1706bf93 28# - make additional headers and checking added by mail patch configurable
543a3683 29# - apply -hardened patch by default ?
768d3bda 30# - modularize session, standard (output from pure php -m)?
82bb3a40 31#
6f91d99f 32# Conditional build:
6e4962cf 33%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
43d48a12 34%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
6f91d99f 35%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f 36%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
ffda81cd 37%bcond_without curl # without CURL extension module
696cac8d 38%bcond_without filter # without filter extension module
6f91d99f 39%bcond_without imap # without IMAP extension module
8279590e 40%bcond_without interbase # without InterBase extension module
6f91d99f
JB
41%bcond_without ldap # without LDAP extension module
42%bcond_without mhash # without mhash extension module
420fb8d4 43%bcond_without mime_magic # without mime-magic module
6f91d99f
JB
44%bcond_without ming # without ming extension module
45%bcond_without mm # without mm support for session storage
6f91d99f 46%bcond_without mssql # without MS SQL extension module
ffda81cd 47%bcond_without mysqli # without mysqli support (Requires mysql > 4.1)
6f91d99f
JB
48%bcond_without odbc # without ODBC extension module
49%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
50%bcond_without pcre # without PCRE extension module
6f91d99f 51%bcond_without pgsql # without PostgreSQL extension module
274395e3 52%bcond_without pspell # without pspell extension module
6f91d99f 53%bcond_without recode # without recode extension module
6f91d99f 54%bcond_without snmp # without SNMP extension module
8c91402c 55%bcond_without sqlite # without SQLite extension module
41a6f471 56%bcond_without sybase # without Sybase extension module
4cc60252 57%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 58%bcond_without tidy # without Tidy extension module
6f91d99f
JB
59%bcond_without wddx # without WDDX extension module
60%bcond_without xmlrpc # without XML-RPC extension module
aa39c584 61%bcond_without apache1 # disable building apache 1.3.x module
3f700db8 62%bcond_without apache2 # disable building apache 2.x module
e8c48c38 63%bcond_without fcgi # disable building FCGI SAPI
1a64b68d 64%bcond_without zts # disable experimental-zts
1706bf93 65%bcond_with versioning # build with experimental versioning (to load php4/php5 into same apache)
74f7e4ba 66
3f700db8
ER
67%define apxs1 /usr/sbin/apxs1
68%define apxs2 /usr/sbin/apxs
69
6f91d99f 70# some problems with apache 2.x
3f700db8 71%if %{with apache2}
6f91d99f 72%undefine with_mm
ab092fe1 73%endif
3f700db8 74
8279590e
JB
75%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha
76# ppc disabled (broken on th-ppc)
6f91d99f 77%undefine with_interbase
52bba439 78%endif
3f700db8 79
f6477c6e 80%if !%{with apache1} && !%{with apache2}
8d79014f
ER
81ERROR: You need to select at least one Apache SAPI to build shared modules.
82%endif
83
696cac8d
ER
84# filter depends on pcre
85%if %{without pcre}
86%undefine with_filter
87%endif
88
b2a7d06d 89%define _rel 0.1
c256acfe 90Summary: PHP: Hypertext Preprocessor
0c6ea8ca
JB
91Summary(fr): Le langage de script embarque-HTML PHP
92