]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- fix bcond comment
[packages/php.git] / php.spec
CommitLineData
6404edba 1#
82bb3a40 2# TODO:
54eb743b 3# - php-shared is SERIOUSLY broken. Try compiling with --enable-versioning.
8c91402c
AM
4# - think of including support for:
5# - mcve,
6# - ovrimos,
7# - pfpro,
8# - ircg,
9# These extensions BuildRequires proprietary libraries...
d0822c6c
JB
10# - deal with modules removed from php and not moved to PECL
11# (existing only in php4):
737e42ad 12# db, hyperwave, java, mcal, overload, qtdom
1ffa7abd 13# - mime_magic can't handle new "string/*" entries in magic.mime
6392ee57 14# - make additional headers added by mail patch configurable
543a3683 15# - apply -hardened patch by default ?
11ef833d 16# - ftp module needs to be linked with -lssl if openssl module is enabled
82bb3a40 17#
6f91d99f
JB
18# Conditional build:
19%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 20%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
4f8ad92f 21%bcond_with hardened # build with hardened patch applied (http://www.hardened-php.net/)
28106fe7 22%bcond_with hwapi # with Hw API support (BR: proprietary libs)
6f91d99f 23%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f
JB
24%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
25%bcond_with oracle # with oracle extension module (BR: proprietary libs)
74f7e4ba 26%bcond_with apache1 # build with apache1
ec7c6e14 27%bcond_without mysqli # with mysqli support (Requires mysql > 4.1)
6f91d99f
JB
28%bcond_without cpdf # without cpdf extension module
29%bcond_without curl # without CURL extension module
8c91402c 30%bcond_without fam # without FAM (File Alteration Monitor) extension module
6f91d99f 31%bcond_without imap # without IMAP extension module
b0aaf6c7 32%bcond_with interbase # with InterBase extension module
6f91d99f
JB
33%bcond_without ldap # without LDAP extension module
34%bcond_without mhash # without mhash extension module
35%bcond_without ming # without ming extension module
36%bcond_without mm # without mm support for session storage
37%bcond_without mnogosearch # without mnogosearch extension module
38%bcond_without msession # without msession extension module
39%bcond_without mssql # without MS SQL extension module
40%bcond_without odbc # without ODBC extension module
41%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
42%bcond_without pcre # without PCRE extension module
6f91d99f 43%bcond_without pgsql # without PostgreSQL extension module
274395e3 44%bcond_without pspell # without pspell extension module
6f91d99f 45%bcond_without recode # without recode extension module
6f91d99f 46%bcond_without snmp # without SNMP extension module
8c91402c 47%bcond_without sqlite # without SQLite extension module
41a6f471 48%bcond_without sybase # without Sybase extension module
4cc60252 49%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 50%bcond_without tidy # without Tidy extension module
6f91d99f
JB
51%bcond_without wddx # without WDDX extension module
52%bcond_without xmlrpc # without XML-RPC extension module
74f7e4ba
ER
53
54%define _apache2 %{?with_apache1:0}%{!?with_apache1:1}
7f3d706a 55%if %{_apache2}
41a9af21 56%define apxs /usr/sbin/apxs
7f3d706a 57%else
85a72066 58%define apxs /usr/sbin/apxs1
7f3d706a 59%endif
6f91d99f 60# some problems with apache 2.x
ab092fe1 61%if %{_apache2}
6f91d99f 62%undefine with_mm
ab092fe1 63%endif
1ce8316b 64%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
6f91d99f 65%undefine with_interbase
52bba439 66%endif
6e4962cf 67# x86-only lib
52bba439 68%ifnarch %{ix86}
6f91d99f 69%undefine with_msession
c2388c7d 70%endif
6f91d99f 71%include /usr/lib/rpm/macros.php
caff8ce9 72Summary: The PHP HTML-embedded scripting language for use with Apache
73Summary(fr): Le langage de script embarque-HTML PHP pour Apache
881802d3 74