]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- rel 2
[packages/php.git] / php.spec
CommitLineData
82bb3a40 1# TODO:
8c91402c
AM
2# - think of including support for:
3# - mcve,
4# - ovrimos,
5# - pfpro,
8c91402c 6# These extensions BuildRequires proprietary libraries...
d0822c6c 7# - deal with modules removed from php and not moved to PECL
5aa15110 8# removed from php 5.2:
7aa94fdb 9# filepro, hw
1ffa7abd 10# - mime_magic can't handle new "string/*" entries in magic.mime
9091cd7b 11# thus doesn't work with system magic.mime database
6392ee57 12# - make additional headers added by mail patch configurable
543a3683 13# - apply -hardened patch by default ?
768d3bda 14# - modularize session, standard (output from pure php -m)?
82bb3a40 15#
6f91d99f
JB
16# Conditional build:
17%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 18%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
43d48a12 19%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
6f91d99f 20%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f 21%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
ffda81cd 22%bcond_without curl # without CURL extension module
696cac8d 23%bcond_without filter # without filter extension module
6f91d99f 24%bcond_without imap # without IMAP extension module
da7819f0 25%bcond_with interbase # with InterBase extension module
6f91d99f
JB
26%bcond_without ldap # without LDAP extension module
27%bcond_without mhash # without mhash extension module
420fb8d4 28%bcond_without mime_magic # without mime-magic module
6f91d99f
JB
29%bcond_without ming # without ming extension module
30%bcond_without mm # without mm support for session storage
6f91d99f 31%bcond_without mssql # without MS SQL extension module
ffda81cd 32%bcond_without mysqli # without mysqli support (Requires mysql > 4.1)
6f91d99f
JB
33%bcond_without odbc # without ODBC extension module
34%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
35%bcond_without pcre # without PCRE extension module
6f91d99f 36%bcond_without pgsql # without PostgreSQL extension module
274395e3 37%bcond_without pspell # without pspell extension module
6f91d99f 38%bcond_without recode # without recode extension module
6f91d99f 39%bcond_without snmp # without SNMP extension module
8c91402c 40%bcond_without sqlite # without SQLite extension module
41a6f471 41%bcond_without sybase # without Sybase extension module
4cc60252 42%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 43%bcond_without tidy # without Tidy extension module
6f91d99f
JB
44%bcond_without wddx # without WDDX extension module
45%bcond_without xmlrpc # without XML-RPC extension module
aa39c584 46%bcond_without apache1 # disable building apache 1.3.x module
3f700db8 47%bcond_without apache2 # disable building apache 2.x module
e8c48c38 48%bcond_without fcgi # disable building FCGI SAPI
1a64b68d 49%bcond_without zts # disable experimental-zts
8938ce4f 50%bcond_with versioning # build with experimental versioning (to load php4/php5 into same apache)
74f7e4ba 51
3f700db8
ER
52%define apxs1 /usr/sbin/apxs1
53%define apxs2 /usr/sbin/apxs
54
6f91d99f 55# some problems with apache 2.x
3f700db8 56%if %{with apache2}
6f91d99f 57%undefine with_mm
ab092fe1 58%endif
3f700db8 59
1ce8316b 60%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
6f91d99f 61%undefine with_interbase
52bba439 62%endif
3f700db8 63
f6477c6e 64%if !%{with apache1} && !%{with apache2}
8d79014f
ER
65ERROR: You need to select at least one Apache SAPI to build shared modules.
66%endif
67
696cac8d
ER
68# filter depends on pcre
69%if %{without pcre}
70%undefine with_filter
71%endif
72
acda9180 73%define _rel 2
c256acfe 74Summary: PHP: Hypertext Preprocessor
0c6ea8ca
JB
75Summary(fr): Le langage de script embarque-HTML PHP
76