]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- cosmetics
[packages/php.git] / php.spec
CommitLineData
6404edba 1#
82bb3a40 2# TODO:
4a3031fc
JB
3# - loading pgsql+mnogosearch+snmp (only in this order!) causes php -i to SEGV on exit
4# (postgresql-libs-8.0.1-1, net-snmp-libs-5.2.1-0.2, mnogosearch-lib-3.2.32-1)
5# (only php.cli; php.cgi and apache2 module are not affected)
a4466573 6# same result on mysql+curl+msession (on php.cli -i or php.cgi with empty imput)
4a3031fc 7#
54eb743b 8# - php-shared is SERIOUSLY broken. Try compiling with --enable-versioning.
8c91402c
AM
9# - think of including support for:
10# - mcve,
11# - ovrimos,
12# - pfpro,
13# - ircg,
14# These extensions BuildRequires proprietary libraries...
d0822c6c
JB
15# - deal with modules removed from php and not moved to PECL
16# (existing only in php4):
737e42ad 17# db, hyperwave, java, mcal, overload, qtdom
1ffa7abd
JB
18# - enabling sybase+sybase_ct+mssql together causes SEGV beside warnings
19# - mime_magic can't handle new "string/*" entries in magic.mime
6392ee57 20# - make additional headers added by mail patch configurable
543a3683 21# - apply -hardened patch by default ?
82bb3a40 22#
6f91d99f
JB
23# Conditional build:
24%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 25%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
4f8ad92f 26%bcond_with hardened # build with hardened patch applied (http://www.hardened-php.net/)
28106fe7 27%bcond_with hwapi # with Hw API support (BR: proprietary libs)
6f91d99f 28%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f
JB
29%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
30%bcond_with oracle # with oracle extension module (BR: proprietary libs)
74f7e4ba 31%bcond_with apache1 # build with apache1
ec7c6e14 32%bcond_without mysqli # with mysqli support (Requires mysql > 4.1)
6f91d99f
JB
33%bcond_without cpdf # without cpdf extension module
34%bcond_without curl # without CURL extension module
8c91402c 35%bcond_without fam # without FAM (File Alteration Monitor) extension module
6f91d99f
JB
36%bcond_without imap # without IMAP extension module
37%bcond_without interbase # without InterBase extension module
38%bcond_without ldap # without LDAP extension module
39%bcond_without mhash # without mhash extension module
40%bcond_without ming # without ming extension module
41%bcond_without mm # without mm support for session storage
42%bcond_without mnogosearch # without mnogosearch extension module
43%bcond_without msession # without msession extension module
44%bcond_without mssql # without MS SQL extension module
45%bcond_without odbc # without ODBC extension module
46%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
47%bcond_without pcre # without PCRE extension module
6f91d99f 48%bcond_without pgsql # without PostgreSQL extension module
274395e3 49%bcond_without pspell # without pspell extension module
6f91d99f 50%bcond_without recode # without recode extension module
6f91d99f 51%bcond_without snmp # without SNMP extension module
8c91402c 52%bcond_without sqlite # without SQLite extension module
41a6f471 53%bcond_without sybase # without Sybase extension module
4cc60252 54%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 55%bcond_without tidy # without Tidy extension module
6f91d99f
JB
56%bcond_without wddx # without WDDX extension module
57%bcond_without xmlrpc # without XML-RPC extension module
74f7e4ba
ER
58
59%define _apache2 %{?with_apache1:0}%{!?with_apache1:1}
7f3d706a 60%if %{_apache2}
41a9af21 61%define apxs /usr/sbin/apxs
7f3d706a 62%else
85a72066 63%define apxs /usr/sbin/apxs1
7f3d706a 64%endif
6f91d99f 65# some problems with apache 2.x
ab092fe1 66%if %{_apache2}
6f91d99f 67%undefine with_mm
ab092fe1 68%endif
c37dabc8 69%ifnarch %{ix86} amd64 sparc sparcv9 alpha ppc
6f91d99f 70%undefine with_interbase
52bba439 71%endif
6e4962cf 72# x86-only lib
52bba439 73%ifnarch %{ix86}
6f91d99f 74%undefine with_msession
c2388c7d 75%endif
6f91d99f 76%include /usr/lib/rpm/macros.php
caff8ce9 77Summary: The PHP HTML-embedded scripting language for use with Apache
78Summary(fr): Le langage de script embarque-HTML PHP pour Apache
881802d3 79