]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- noted TODO
[packages/php.git] / php.spec
CommitLineData
6404edba 1#
82bb3a40
JB
2# TODO:
3# - cannot find libexpat for XML module,
4# with --with-expat-dir=/usr finds, but xmlrpc is built as static
5# - libphp4.so is linked with -lnsl
6# - msession.so isn't linked with -lphoenix
7# - odbc.so isn't linked with -lodbc*
8# - wddx.so isn't linked with anything except libc
9#
6404edba
PG
10# Automatic pear requirements finding:
11%include /usr/lib/rpm/macros.php
c2388c7d 12
13%define _apache2 %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
e621d4e8 14%define apxs /usr/sbin/apxs
ab092fe1
AM
15
16%if %{_apache2}
17%define _without_recode 1
18%define _without_mm 1
19%endif
20
c2388c7d 21%ifnarch %{ix86}
22%define _without_msession 1
23%endif
24
e1126429 25# Conditional build:
e2263ce4
JB
26# _with_db3 - use db3 packages instead of db (4.x) for Berkeley DB support
27# _with_interbase_inst - use InterBase install., not Firebird (BR: proprietary libs)
efe52553
JB
28# _with_java - with Java extension module (BR: jdk)
29# _with_oci8 - with Oracle oci8 extension module (BR: proprietary libs)
30# _with_oracle - with oracle extension module (BR: proprietary libs)
31# _with_pcntl - with pcntl extension module (problems: SEGV on exit)
32# _without_cpdf - without cpdf extension module
2bb29330 33# _without_curl - without CURL extension module
c2388c7d 34# _without_domxslt - without DOM XSLT/EXSLT support in DOM XML extension module
efe52553 35# _without_gif - build GD extension module with gd library without GIF support
c2388c7d 36# _without_imap - without IMAP extension module
e2263ce4 37# _without_interbase - without InterBase extension module
c2388c7d 38# _without_ldap - without LDAP extension module
2bb29330
JB
39# _without_mhash - without mhash extension module
40# _without_ming - without ming extension module
c2388c7d 41# _without_mm - without mm support for session storage
2bb29330 42# _without_mnogosearch - without mnogosearch extension module
c2388c7d 43# _without_msession - without msession extension module
44# _without_odbc - without ODBC extension module
bdd27482 45# _without_openssl - without OpenSSL support and OpenSSL extension module
efe52553 46# _without_pcre - without PCRE extension module
bdd27482 47# _without_pdf - without PDF extension module
2bb29330 48# _without_pspell - without pspell extension module
8c56345a 49# _without_pgsql - without PostgreSQL extension module
c2388c7d 50# _without_snmp - without SNMP extension module
51# _without_recode - without recode extension module
efe52553 52# _without_sybase_ct - without Sybase-CT extension module
c2388c7d 53# _without_wddx - without WDDX extension module
efe52553
JB
54# _without_xml - without XML extension module
55# _without_xmlrpc - without XML-RPC extension module
c2388c7d 56# _without_xslt - without XSLT extension module
90df7549 57
caff8ce9 58Summary: The PHP HTML-embedded scripting language for use with Apache
59Summary(fr): Le langage de script embarque-HTML PHP pour Apache
60