]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- disable interbase/firebird for now; it's in bad shape in Th
[packages/php.git] / php.spec
CommitLineData
82bb3a40 1# TODO:
8c91402c
AM
2# - think of including support for:
3# - mcve,
4# - ovrimos,
5# - pfpro,
8c91402c 6# These extensions BuildRequires proprietary libraries...
d0822c6c
JB
7# - deal with modules removed from php and not moved to PECL
8# (existing only in php4):
737e42ad 9# db, hyperwave, java, mcal, overload, qtdom
1017a8f0 10# and removed from php 5.1:
60218d7e 11# cpdf, fam, yp, oracle
1ffa7abd 12# - mime_magic can't handle new "string/*" entries in magic.mime
6392ee57 13# - make additional headers added by mail patch configurable
543a3683 14# - apply -hardened patch by default ?
768d3bda 15# - modularize session, standard (output from pure php -m)?
82bb3a40 16#
6f91d99f
JB
17# Conditional build:
18%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 19%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
43d48a12 20%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
28106fe7 21%bcond_with hwapi # with Hw API support (BR: proprietary libs)
6f91d99f 22%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f 23%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
ffda81cd 24%bcond_without curl # without CURL extension module
6f91d99f 25%bcond_without imap # without IMAP extension module
7895eb4e 26%bcond_with interbase # with InterBase extension module
6f91d99f
JB
27%bcond_without ldap # without LDAP extension module
28%bcond_without mhash # without mhash extension module
29%bcond_without ming # without ming extension module
30%bcond_without mm # without mm support for session storage
6f91d99f
JB
31%bcond_without msession # without msession extension module
32%bcond_without mssql # without MS SQL extension module
ffda81cd 33%bcond_without mysqli # without mysqli support (Requires mysql > 4.1)
cfff29a1 34%bcond_without mime_magic # without mime-magic module
6f91d99f
JB
35%bcond_without odbc # without ODBC extension module
36%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
37%bcond_without pcre # without PCRE extension module
6f91d99f 38%bcond_without pgsql # without PostgreSQL extension module
274395e3 39%bcond_without pspell # without pspell extension module
6f91d99f 40%bcond_without recode # without recode extension module
6f91d99f 41%bcond_without snmp # without SNMP extension module
8c91402c 42%bcond_without sqlite # without SQLite extension module
41a6f471 43%bcond_without sybase # without Sybase extension module
4cc60252 44%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 45%bcond_without tidy # without Tidy extension module
6f91d99f
JB
46%bcond_without wddx # without WDDX extension module
47%bcond_without xmlrpc # without XML-RPC extension module
aa39c584 48%bcond_without apache1 # disable building apache 1.3.x module
3f700db8 49%bcond_without apache2 # disable building apache 2.x module
e8c48c38 50%bcond_without fcgi # disable building FCGI SAPI
1a64b68d 51%bcond_without zts # disable experimental-zts
74f7e4ba 52
3f700db8
ER
53%define apxs1 /usr/sbin/apxs1
54%define apxs2 /usr/sbin/apxs
55
6f91d99f 56# some problems with apache 2.x
3f700db8 57%if %{with apache2}
6f91d99f 58%undefine with_mm
ab092fe1 59%endif
3f700db8 60
1ce8316b 61%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
6f91d99f 62%undefine with_interbase
52bba439 63%endif
3f700db8 64
8d79014f
ER
65%if %{without apache1} && %{without apache2}
66ERROR: You need to select at least one Apache SAPI to build shared modules.
67%endif
68
6e4962cf 69# x86-only lib
52bba439 70%ifnarch %{ix86}
6f91d99f 71%undefine with_msession
c2388c7d 72%endif
3f700db8 73
c256acfe 74Summary: PHP: Hypertext Preprocessor
0c6ea8ca
JB
75Summary(fr): Le langage de script embarque-HTML PHP
76