]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- switch order of autotools and buildconf invocation; builds now
[packages/php.git] / php.spec
CommitLineData
82bb3a40 1# TODO:
54eb743b 2# - php-shared is SERIOUSLY broken. Try compiling with --enable-versioning.
8c91402c
AM
3# - think of including support for:
4# - mcve,
5# - ovrimos,
6# - pfpro,
8c91402c 7# These extensions BuildRequires proprietary libraries...
d0822c6c
JB
8# - deal with modules removed from php and not moved to PECL
9# (existing only in php4):
737e42ad 10# db, hyperwave, java, mcal, overload, qtdom
1ffa7abd 11# - mime_magic can't handle new "string/*" entries in magic.mime
6392ee57 12# - make additional headers added by mail patch configurable
543a3683 13# - apply -hardened patch by default ?
768d3bda
AM
14# - modularize session, standard (output from pure php -m)?
15# - having pcre module loaded cli crashes
82bb3a40 16#
6f91d99f
JB
17# Conditional build:
18%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 19%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
43d48a12 20%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
28106fe7 21%bcond_with hwapi # with Hw API support (BR: proprietary libs)
6f91d99f 22%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f
JB
23%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
24%bcond_with oracle # with oracle extension module (BR: proprietary libs)
ec7c6e14 25%bcond_without mysqli # with mysqli support (Requires mysql > 4.1)
6f91d99f 26%bcond_without curl # without CURL extension module
6f91d99f 27%bcond_without imap # without IMAP extension module
768d3bda 28%bcond_with interbase # with InterBase extension module
6f91d99f
JB
29%bcond_without ldap # without LDAP extension module
30%bcond_without mhash # without mhash extension module
31%bcond_without ming # without ming extension module
32%bcond_without mm # without mm support for session storage
6f91d99f
JB
33%bcond_without msession # without msession extension module
34%bcond_without mssql # without MS SQL extension module
1a64b68d 35%bcond_without mime_magic # without mime-magic module
6f91d99f
JB
36%bcond_without odbc # without ODBC extension module
37%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
38%bcond_without pcre # without PCRE extension module
6f91d99f 39%bcond_without pgsql # without PostgreSQL extension module
274395e3 40%bcond_without pspell # without pspell extension module
6f91d99f 41%bcond_without recode # without recode extension module
6f91d99f 42%bcond_without snmp # without SNMP extension module
8c91402c 43%bcond_without sqlite # without SQLite extension module
41a6f471 44%bcond_without sybase # without Sybase extension module
4cc60252 45%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 46%bcond_without tidy # without Tidy extension module
6f91d99f
JB
47%bcond_without wddx # without WDDX extension module
48%bcond_without xmlrpc # without XML-RPC extension module
aa39c584 49%bcond_without apache1 # disable building apache 1.3.x module
3f700db8 50%bcond_without apache2 # disable building apache 2.x module
e8c48c38 51%bcond_without fcgi # disable building FCGI SAPI
1a64b68d 52%bcond_without zts # disable experimental-zts
74f7e4ba 53
3f700db8
ER
54%define apxs1 /usr/sbin/apxs1
55%define apxs2 /usr/sbin/apxs
56
6f91d99f 57# some problems with apache 2.x
3f700db8 58%if %{with apache2}
6f91d99f 59%undefine with_mm
ab092fe1 60%endif
3f700db8 61
1ce8316b 62%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
6f91d99f 63%undefine with_interbase
52bba439 64%endif
3f700db8 65
8d79014f
ER
66%if %{without apache1} && %{without apache2}
67ERROR: You need to select at least one Apache SAPI to build shared modules.
68%endif
69
6e4962cf 70# x86-only lib
52bba439 71%ifnarch %{ix86}
6f91d99f 72%undefine with_msession
c2388c7d 73%endif
3f700db8 74
caff8ce9 75Summary: The PHP HTML-embedded scripting language for use with Apache
76Summary(fr): Le langage de script embarque-HTML PHP pour Apache
881802d3 77