]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- libxml and simplexml extensions cannot be built as shared (they are used in SPL);
[packages/php.git] / php.spec
CommitLineData
6404edba 1#
82bb3a40 2# TODO:
ce68b400
JB
3# - make sure that session-unregister patch is no longer needed
4# (any crash reports related to session modules?)
8c91402c
AM
5# - think of including support for:
6# - mcve,
7# - ovrimos,
8# - pfpro,
9# - ircg,
10# These extensions BuildRequires proprietary libraries...
f1f28175 11# - fix building of sybase extensions
8c91402c 12# - test if php.cgi segfaults after ctrl+d when overload.so is loaded
82bb3a40 13#
6f91d99f
JB
14# Conditional build:
15%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
8c91402c 16%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary libs)
4f8ad92f 17%bcond_with hardened # build with hardened patch applied (http://www.hardened-php.net/)
28106fe7 18%bcond_with hwapi # with Hw API support (BR: proprietary libs)
6f91d99f 19%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f
JB
20%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
21%bcond_with oracle # with oracle extension module (BR: proprietary libs)
22%bcond_without cpdf # without cpdf extension module
23%bcond_without curl # without CURL extension module
8c91402c 24%bcond_without fam # without FAM (File Alteration Monitor) extension module
6f91d99f
JB
25%bcond_without imap # without IMAP extension module
26%bcond_without interbase # without InterBase extension module
27%bcond_without ldap # without LDAP extension module
28%bcond_without mhash # without mhash extension module
29%bcond_without ming # without ming extension module
30%bcond_without mm # without mm support for session storage
31%bcond_without mnogosearch # without mnogosearch extension module
32%bcond_without msession # without msession extension module
33%bcond_without mssql # without MS SQL extension module
34%bcond_without odbc # without ODBC extension module
35%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
36%bcond_without pcre # without PCRE extension module
6f91d99f 37%bcond_without pgsql # without PostgreSQL extension module
274395e3 38%bcond_without pspell # without pspell extension module
6f91d99f 39%bcond_without recode # without recode extension module
6f91d99f 40%bcond_without snmp # without SNMP extension module
8c91402c 41%bcond_without sqlite # without SQLite extension module
41a6f471 42%bcond_without sybase # without Sybase extension module
4cc60252 43%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 44%bcond_without tidy # without Tidy extension module
6f91d99f
JB
45%bcond_without wddx # without WDDX extension module
46%bcond_without xmlrpc # without XML-RPC extension module
6f91d99f 47#
c2388c7d 48%define _apache2 %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
41a9af21 49%define apxs /usr/sbin/apxs
6f91d99f 50# some problems with apache 2.x
ab092fe1 51%if %{_apache2}
6f91d99f 52%undefine with_mm
ab092fe1 53%endif
c37dabc8 54%ifnarch %{ix86} amd64 sparc sparcv9 alpha ppc
6f91d99f 55%undefine with_interbase
52bba439 56%endif
8c91402c 57# x86-only libs
52bba439 58%ifnarch %{ix86}
6f91d99f 59%undefine with_msession
c2388c7d 60%endif
6f91d99f 61%include /usr/lib/rpm/macros.php
caff8ce9 62Summary: The PHP HTML-embedded scripting language for use with Apache
63Summary(fr): Le langage de script embarque-HTML PHP pour Apache
881802d3 64