]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- dropped, Ra is dead
[packages/php.git] / php.spec
CommitLineData
82bb3a40 1# TODO:
d0822c6c 2# - deal with modules removed from php and not moved to PECL
5aa15110 3# removed from php 5.2:
7aa94fdb 4# filepro, hw
1ffa7abd 5# - mime_magic can't handle new "string/*" entries in magic.mime
9091cd7b 6# thus doesn't work with system magic.mime database
1706bf93 7# - make additional headers and checking added by mail patch configurable
543a3683 8# - apply -hardened patch by default ?
768d3bda 9# - modularize session, standard (output from pure php -m)?
82bb3a40 10#
6f91d99f
JB
11# Conditional build:
12%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 13%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
43d48a12 14%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
6f91d99f 15%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f 16%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
ffda81cd 17%bcond_without curl # without CURL extension module
696cac8d 18%bcond_without filter # without filter extension module
6f91d99f 19%bcond_without imap # without IMAP extension module
8279590e 20%bcond_without interbase # without InterBase extension module
6f91d99f
JB
21%bcond_without ldap # without LDAP extension module
22%bcond_without mhash # without mhash extension module
420fb8d4 23%bcond_without mime_magic # without mime-magic module
6f91d99f
JB
24%bcond_without ming # without ming extension module
25%bcond_without mm # without mm support for session storage
6f91d99f 26%bcond_without mssql # without MS SQL extension module
ffda81cd 27%bcond_without mysqli # without mysqli support (Requires mysql > 4.1)
6f91d99f
JB
28%bcond_without odbc # without ODBC extension module
29%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
30%bcond_without pcre # without PCRE extension module
6f91d99f 31%bcond_without pgsql # without PostgreSQL extension module
274395e3 32%bcond_without pspell # without pspell extension module
6f91d99f 33%bcond_without recode # without recode extension module
6f91d99f 34%bcond_without snmp # without SNMP extension module
8c91402c 35%bcond_without sqlite # without SQLite extension module
41a6f471 36%bcond_without sybase # without Sybase extension module
4cc60252 37%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 38%bcond_without tidy # without Tidy extension module
6f91d99f
JB
39%bcond_without wddx # without WDDX extension module
40%bcond_without xmlrpc # without XML-RPC extension module
aa39c584 41%bcond_without apache1 # disable building apache 1.3.x module
3f700db8 42%bcond_without apache2 # disable building apache 2.x module
e8c48c38 43%bcond_without fcgi # disable building FCGI SAPI
1a64b68d 44%bcond_without zts # disable experimental-zts
1706bf93 45%bcond_with versioning # build with experimental versioning (to load php4/php5 into same apache)
74f7e4ba 46
3f700db8
ER
47%define apxs1 /usr/sbin/apxs1
48%define apxs2 /usr/sbin/apxs
49
6f91d99f 50# some problems with apache 2.x
3f700db8 51%if %{with apache2}
6f91d99f 52%undefine with_mm
ab092fe1 53%endif
3f700db8 54
8279590e
JB
55%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha
56# ppc disabled (broken on th-ppc)
6f91d99f 57%undefine with_interbase
52bba439 58%endif
3f700db8 59
f6477c6e 60%if !%{with apache1} && !%{with apache2}
8d79014f
ER
61ERROR: You need to select at least one Apache SAPI to build shared modules.
62%endif
63
696cac8d
ER
64# filter depends on pcre
65%if %{without pcre}
66%undefine with_filter
67%endif
68
1706bf93 69%define _rel 5
c256acfe 70Summary: PHP: Hypertext Preprocessor
0c6ea8ca
JB
71Summary(fr): Le langage de script embarque-HTML PHP
72