]> git.pld-linux.org Git - packages/php.git/blame - php.spec
*** empty log message ***
[packages/php.git] / php.spec
CommitLineData
82bb3a40 1# TODO:
54eb743b 2# - php-shared is SERIOUSLY broken. Try compiling with --enable-versioning.
8c91402c
AM
3# - think of including support for:
4# - mcve,
5# - ovrimos,
6# - pfpro,
7# - ircg,
8# These extensions BuildRequires proprietary libraries...
d0822c6c
JB
9# - deal with modules removed from php and not moved to PECL
10# (existing only in php4):
737e42ad 11# db, hyperwave, java, mcal, overload, qtdom
1ffa7abd 12# - mime_magic can't handle new "string/*" entries in magic.mime
6392ee57 13# - make additional headers added by mail patch configurable
543a3683 14# - apply -hardened patch by default ?
11ef833d 15# - ftp module needs to be linked with -lssl if openssl module is enabled
82bb3a40 16#
6f91d99f
JB
17# Conditional build:
18%bcond_with db3 # use db3 packages instead of db (4.x) for Berkeley DB support
6e4962cf 19%bcond_with fdf # with FDF (PDF forms) module (BR: proprietary lib)
43d48a12 20%bcond_with hardening # build with hardening patch applied (http://www.hardened-php.net/)
28106fe7 21%bcond_with hwapi # with Hw API support (BR: proprietary libs)
6f91d99f 22%bcond_with interbase_inst # use InterBase install., not Firebird (BR: proprietary libs)
6f91d99f
JB
23%bcond_with oci8 # with Oracle oci8 extension module (BR: proprietary libs)
24%bcond_with oracle # with oracle extension module (BR: proprietary libs)
ec7c6e14 25%bcond_without mysqli # with mysqli support (Requires mysql > 4.1)
6f91d99f
JB
26%bcond_without cpdf # without cpdf extension module
27%bcond_without curl # without CURL extension module
8c91402c 28%bcond_without fam # without FAM (File Alteration Monitor) extension module
6f91d99f 29%bcond_without imap # without IMAP extension module
b0aaf6c7 30%bcond_with interbase # with InterBase extension module
6f91d99f
JB
31%bcond_without ldap # without LDAP extension module
32%bcond_without mhash # without mhash extension module
33%bcond_without ming # without ming extension module
34%bcond_without mm # without mm support for session storage
35%bcond_without mnogosearch # without mnogosearch extension module
36%bcond_without msession # without msession extension module
37%bcond_without mssql # without MS SQL extension module
38%bcond_without odbc # without ODBC extension module
39%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
40%bcond_without pcre # without PCRE extension module
6f91d99f 41%bcond_without pgsql # without PostgreSQL extension module
274395e3 42%bcond_without pspell # without pspell extension module
6f91d99f 43%bcond_without recode # without recode extension module
6f91d99f 44%bcond_without snmp # without SNMP extension module
8c91402c 45%bcond_without sqlite # without SQLite extension module
41a6f471 46%bcond_without sybase # without Sybase extension module
4cc60252 47%bcond_without sybase_ct # without Sybase-CT extension module
8c91402c 48%bcond_without tidy # without Tidy extension module
6f91d99f
JB
49%bcond_without wddx # without WDDX extension module
50%bcond_without xmlrpc # without XML-RPC extension module
aa39c584 51%bcond_without apache1 # disable building apache 1.3.x module
3f700db8 52%bcond_without apache2 # disable building apache 2.x module
74f7e4ba 53
3f700db8
ER
54%define apxs1 /usr/sbin/apxs1
55%define apxs2 /usr/sbin/apxs
56
6f91d99f 57# some problems with apache 2.x
3f700db8 58%if %{with apache2}
6f91d99f 59%undefine with_mm
ab092fe1 60%endif
3f700db8 61
1ce8316b 62%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
6f91d99f 63%undefine with_interbase
52bba439 64%endif
3f700db8 65
6e4962cf 66# x86-only lib
52bba439 67%ifnarch %{ix86}
6f91d99f 68%undefine with_msession
c2388c7d 69%endif
3f700db8 70
6f91d99f 71%include /usr/lib/rpm/macros.php
caff8ce9 72Summary: The PHP HTML-embedded scripting language for use with Apache
73Summary(fr): Le langage de script embarque-HTML PHP pour Apache
881802d3 74