]> git.pld-linux.org Git - packages/php.git/blame - php.spec
- fixed PROG_SENDMAIL
[packages/php.git] / php.spec
CommitLineData
6404edba 1#
82bb3a40 2# TODO:
68669980
AM
3# - make sure that session-unregister patch is no longer needed
4# (any crash reports related to session modules?)
5#
6# Conditional build:
7%bcond_without db3 # do not use db3 packages instead of db (4.x) for Berkeley DB support
8%bcond_with fdf # with FDF (PDF forms) module (BR:proprietary lib)
9%bcond_with interbase_inst # use InterBase install., not Firebird (BR:proprietary libs)
10%bcond_with java # with Java extension module (BR:jdk)
11%bcond_with oci8 # with Oracle oci8 extension module (BR:proprietary libs)
12%bcond_with oracle # with oracle extension module (BR:proprietary libs)
13%bcond_without cpdf # without cpdf extension module
14%bcond_without curl # without CURL extension module
15%bcond_without domxslt # without DOM XSLT/EXSLT support in DOM XML extension module
16%bcond_with fribidi # with FriBiDi extension module
17%bcond_without gif # build GD extension module with gd library without GIF support
18%bcond_without imap # without IMAP extension module
19%bcond_with interbase # with InterBase extension module
20%bcond_without ldap # without LDAP extension module
21%bcond_without mhash # without mhash extension module
22%bcond_without ming # without ming extension module
23%bcond_without mm # without mm support for session storage
24%bcond_without mnogosearch # without mnogosearch extension module
25%bcond_without msession # without msession extension module
26%bcond_without mssql # without MS SQL extension module
27%bcond_without odbc # without ODBC extension module
28%bcond_without openssl # without OpenSSL support and OpenSSL extension (module)
29%bcond_without pcre # without PCRE extension module
30%bcond_without pdf # without PDF extension module
31%bcond_without pgsql # without PostgreSQL extension module
32%bcond_without pspell # without pspell extension module
33%bcond_without recode # without recode extension module
34%bcond_with qtdom # with QT DOM extension module
35%bcond_without snmp # without SNMP extension module
36%bcond_without sybase # without Sybase and Sybase-CT extension modules
37%bcond_without wddx # without WDDX extension module
38%bcond_without xmlrpc # without XML-RPC extension module
39%bcond_without xml # without XML and DOMXML extension modules
40%bcond_without xslt # without XSLT extension module
41%bcond_without yaz # without YAZ extension module
82bb3a40 42#
c2388c7d 43%define _apache2 %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
68669980
AM
44%define apxs /usr/sbin/apxs
45# some problems with apache 2.x
ab092fe1 46%if %{_apache2}
68669980
AM
47%undefine with_recode
48%undefine with_mm
ab092fe1 49%endif
68669980
AM
50%ifnarch %{ix86} sparc sparcv9 ppc
51%undefine with_interbase
52%endif
53# x86-only lib
c2388c7d 54%ifnarch %{ix86}
68669980 55%undefine with_msession
c2388c7d 56%endif
871f7ae3 57# Automatic pear requirements finding:
68669980 58%include /usr/lib/rpm/macros.php
caff8ce9 59Summary: The PHP HTML-embedded scripting language for use with Apache
60Summary(fr): Le langage de script embarque-HTML PHP pour Apache
61