]> git.pld-linux.org Git - packages/php-redis.git/blame - php-redis.spec
- rel 2; just BR cli
[packages/php-redis.git] / php-redis.spec
CommitLineData
2b82b6de
ER
1# TODO
2# - use external igbinary and make it's dependency optional
b91beefc
ER
3#
4# Conditional build:
5%bcond_without tests # build without tests
6
67fa4b41 7%define php_name php%{?php_suffix}
48db7d63
ER
8%define modname redis
9Summary: %{modname} A PHP extension for Redis
67fa4b41 10Name: %{php_name}-%{modname}
bc808e49 11Version: 3.1.4
c61b27e4 12Release: 2
48db7d63
ER
13License: PHP 3.01
14Group: Development/Languages/PHP
d3d2f6ca 15Source0: https://github.com/nicolasff/phpredis/tarball/%{version}/%{modname}-%{version}.tar.gz
bc808e49 16# Source0-md5: c5ba8b560b5766d5318d25ea65ca929f
12140a38 17Source1: https://github.com/ukko/phpredis-phpdoc/tarball/master/%{modname}-phpdoc.tar.gz
bc808e49 18# Source1-md5: eb4163a1c5eaaa41beccfba9be0a9878
48db7d63 19URL: https://github.com/nicolasff/phpredis
67fa4b41 20BuildRequires: %{php_name}-devel >= 4:5.0.4
c61b27e4
AM
21%if %{with tests}
22BuildRequires: %{php_name}-pcre
23BuildRequires: %{php_name}-session
24BuildRequires: %{php_name}-simplexml
25BuildRequires: %{php_name}-cli
26%endif
48db7d63
ER
27BuildRequires: rpmbuild(macros) >= 1.519
28%{?requires_php_extension}
67fa4b41 29Requires: %{php_name}-session
54d79b38 30Provides: php(%{modname}) = %{version}
e15e2353 31Obsoletes: php-redis < 2.2.5-1
48db7d63
ER
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35The phpredis extension provides an API for communicating with the
36Redis key-value store.
37
38This extension also provides session support.
39
40%prep
2b82b6de 41%setup -qc -a1
bc808e49 42mv phpredis-phpredis-*/* .
2b82b6de 43mv ukko-phpredis-phpdoc-* phpdoc
48db7d63
ER
44
45%build
46phpize
47%configure
48%{__make}
49
b91beefc
ER
50%if %{with tests}
51# simple module load test
52%{__php} -n \
53 -dextension_dir=modules \
fd0294ec 54 -dextension=%{php_extensiondir}/pcre.so \
b91beefc 55 -dextension=%{php_extensiondir}/spl.so \
fd0294ec 56 -dextension=%{php_extensiondir}/simplexml.so \
b91beefc
ER
57 -dextension=%{php_extensiondir}/session.so \
58 -dextension=%{modname}.so \
59 -m > modules.log
60grep %{modname} modules.log
61%endif
62
48db7d63
ER
63%install
64rm -rf $RPM_BUILD_ROOT
48db7d63
ER
65%{__make} install \
66 EXTENSION_DIR=%{php_extensiondir} \
67 INSTALL_ROOT=$RPM_BUILD_ROOT
68
69install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
70cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
71; Enable %{modname} extension module
72extension=%{modname}.so
73EOF
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post
79%php_webserver_restart
80
81%postun
82if [ "$1" = 0 ]; then
83 %php_webserver_restart
84fi
85
86%files
87%defattr(644,root,root,755)
2b82b6de 88%doc CREDITS README.markdown phpdoc
48db7d63
ER
89%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
90%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.079694 seconds and 5 git commands to generate.