]> git.pld-linux.org Git - packages/php-phpmailer.git/commitdiff
- fixup testing; cosmetics
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 22 Apr 2012 11:57:21 +0000 (11:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-phpmailer.spec -> 1.20
    tests.patch -> 1.1

php-phpmailer.spec
tests.patch [new file with mode: 0644]

index 21a1dd182b73dd90678835995e89abf3355791c3..650492f277c7faf285b1d8755675beb84e307422 100644 (file)
@@ -11,9 +11,10 @@ Source0:     http://phpmailer.apache-extras.org.codespot.com/files/PHPMailer_%{versi
 # Source0-md5: 2ef9a089aa9aae9899b4ab785ef873c3
 Patch0:                paths.patch
 Patch1:                phpmailer-update-et.patch
+Patch2:                tests.patch
 URL:           http://code.google.com/a/apache-extras.org/p/phpmailer/
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
-BuildRequires: rpmbuild(macros) >= 1.520
+BuildRequires: rpmbuild(macros) >= 1.553
 Requires:      php-common >= 4:%{php_min_version}
 Requires:      php-date
 Requires:      php-pcre
@@ -47,19 +48,19 @@ poprzez SMTP. Metody są oparte na popularnym komponencie AspEmail.
 %setup -q -n PHPMailer_%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
-find '(' -name '*.php' -o -name '*.html' -o -name '*.txt' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
-%{__sed} -i -e 's,\r$,,' README LICENSE
+%undos -f php,html,txt README LICENSE
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_appdir}/language
 
-cp -a class.phpmailer.php $RPM_BUILD_ROOT%{php_data_dir}
+cp -p class.phpmailer.php $RPM_BUILD_ROOT%{php_data_dir}
 # plugins: for smtp and pop before smtp auth
-cp -a class.{smtp,pop3}.php  $RPM_BUILD_ROOT%{_appdir}
+cp -p class.{smtp,pop3}.php  $RPM_BUILD_ROOT%{_appdir}
 # language: translations of error messages
-cp -a language/*.php $RPM_BUILD_ROOT%{_appdir}/language
+cp -p language/*.php $RPM_BUILD_ROOT%{_appdir}/language
 
 # examples
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
diff --git a/tests.patch b/tests.patch
new file mode 100644 (file)
index 0000000..c1a02b1
--- /dev/null
@@ -0,0 +1,27 @@
+--- PHPMailer_5.2.1/test/phpmailerTest.php~    2012-04-22 14:55:00.201857103 +0300
++++ PHPMailer_5.2.1/test/phpmailerTest.php     2012-04-22 14:54:00.232668489 +0300
+@@ -13,7 +13,6 @@
+ * @license http://www.gnu.org/copyleft/lesser.html GNU Lesser General Public License
+ */
+-require 'PHPUnit/Framework.php';
+ $INCLUDE_DIR = "../";
+@@ -146,7 +145,7 @@
+         $ReportBody .= "---------------------" . $eol;
+         $ReportBody .= "Unit Test Information" . $eol;
+         $ReportBody .= "---------------------" . $eol;
+-        $ReportBody .= "phpmailer version: " . PHPMailer::VERSION . $eol;
++        $ReportBody .= "phpmailer version: " . $this->Mail->Version . $eol;
+         $ReportBody .= "Content Type: " . $this->Mail->ContentType . $eol;
+         
+         if(strlen($this->Mail->Host) > 0)
+@@ -637,7 +636,6 @@
+           $this->Mail->CreateHeader();
+           $this->assertFalse($this->Mail->set('x', 'y'), 'Invalid property set succeeded');
+           $this->assertTrue($this->Mail->set('Timeout', 11), 'Valid property set failed');
+-          $this->Mail->getFile(__FILE__);
+       }
+ }  
+  
This page took 0.044281 seconds and 4 git commands to generate.