]> git.pld-linux.org Git - packages/php-pecl-zstd.git/commitdiff
Update php8 argument/parameter difference
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 3 Jan 2021 09:20:39 +0000 (11:20 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Sun, 3 Jan 2021 09:20:54 +0000 (11:20 +0200)
php-pecl-zstd.spec
php8-argument.patch [new file with mode: 0644]

index 8933e1f5a4ff8c376a834ea309c2449f2bbf19c1..4f7b50d79c84705ceb1be38e966dcf97bf6818c6 100644 (file)
@@ -17,6 +17,7 @@ License:      PHP 3.01
 Group:         Development/Languages/PHP
 Source0:       https://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: 6a3b741d39c7bccae0f20a42b03bfd6c
+Patch0:                php8-argument.patch
 URL:           https://pecl.php.net/package/zstd/
 BuildRequires: %{php_name}-cli
 BuildRequires: %{php_name}-devel
@@ -37,6 +38,7 @@ library.
 %prep
 %setup -qc
 mv %{modname}-%{version}/* .
+%patch0 -p1
 rm -r zstd
 
 cat <<'EOF' > run-tests.sh
diff --git a/php8-argument.patch b/php8-argument.patch
new file mode 100644 (file)
index 0000000..1bac4c1
--- /dev/null
@@ -0,0 +1,25 @@
+002- ArgumentCountError: zstd_compress() expects at least 1 parameter, 0 given
+002+ ArgumentCountError: zstd_compress() expects at least 1 argument, 0 given
+
+--- php80-pecl-zstd-0.9.0/tests/002_b.phpt~    2020-06-04 08:14:49.000000000 +0300
++++ php80-pecl-zstd-0.9.0/tests/002_b.phpt     2021-01-03 11:18:38.017531735 +0200
+@@ -29,7 +29,7 @@
+ ===Done===
+ --EXPECTF--
+ *** Testing zstd_compress() function with Zero arguments ***
+-ArgumentCountError: zstd_compress() expects at least 1 parameter, 0 given in %s:%d
++ArgumentCountError: zstd_compress() expects at least 1 %s, 0 given in %s:%d
+ Stack trace:
+ #0 %s(%d): zstd_compress()
+ #1 {main}
+--- php80-pecl-zstd-0.9.0/tests/005_b.phpt~    2020-06-04 08:14:49.000000000 +0300
++++ php80-pecl-zstd-0.9.0/tests/005_b.phpt     2021-01-03 11:19:37.230586143 +0200
+@@ -33,7 +33,7 @@
+ ===DONE===
+ --EXPECTF--
+ *** Testing zstd_uncompress() function with Zero arguments ***
+-ArgumentCountError: zstd_uncompress() expects exactly 1 parameter, 0 given in %s:%d
++ArgumentCountError: zstd_uncompress() expects exactly 1 %s, 0 given in %s:%d
+ Stack trace:
+ #0 %s(%d): zstd_uncompress()
+ #1 {main}
This page took 0.199951 seconds and 4 git commands to generate.