]> git.pld-linux.org Git - packages/php-pecl-zendopcache.git/blame - php-pecl-zendopcache.spec
https urls
[packages/php-pecl-zendopcache.git] / php-pecl-zendopcache.spec
CommitLineData
43eeafa3
ER
1# NOTE:
2# This version of Zend OPcache is compatible with PHP 5.2.*, 5.3.*, 5.4.*
ac06be23 3# and PHP-5.5 development branch. PHP 5.2 support may be removed in the future.
82862555 4%define php_name php%{?php_suffix}
43eeafa3
ER
5%define modname zendopcache
6Summary: Zend Optimizer+ - PHP code optimizer
7Summary(pl.UTF-8): Zend Optimizer+ - optymalizator kodu PHP
82862555 8Name: %{php_name}-pecl-%{modname}
ac06be23
ER
9Version: 7.0.5
10Release: 1
43eeafa3 11License: PHP 3.01
82862555 12Group: Development/Languages/PHP
64478465 13Source0: https://pecl.php.net/get/%{modname}-%{version}.tgz
ac06be23 14# Source0-md5: 0c2710c272e398bea89d41dee42ee633
223ba653 15Source1: %{modname}.ini
64478465 16URL: https://pecl.php.net/package/zendopcache
cb6dd693 17BuildRequires: %{php_name}-devel >= 4:5.2
82208cb9 18BuildRequires: rpmbuild(macros) >= 1.650
43eeafa3 19%{?requires_php_extension}
dc2606bb 20Provides: php(%{modname}) = %{version}
642c93d0 21Obsoletes: php-pecl-zendopcache < 7.0.3-1
43eeafa3
ER
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25The Zend OPcache provides faster PHP execution through opcode caching
26and optimization. It improves PHP performance by storing precompiled
27script bytecode in the shared memory. This eliminates the stages of
28reading code from the disk and compiling it on future access. In
29addition, it applies a few bytecode optimization patterns that make
30code execution faster.
31
32%prep
33%setup -qc
34mv %{modname}-%{version}/* .
35
642c93d0 36if [ %{php_major_version} -ge 5 -a %{php_minor_version} -ge 5 ]; then
8206b2d5
ER
37 echo >&2 "pointless to build, PHP >= 5.5 has php-opcache package"
38 exit 1
39fi
40
43eeafa3
ER
41%build
42phpize
43%configure
44%{__make}
45
46%install
47rm -rf $RPM_BUILD_ROOT
48%{__make} install \
49 EXTENSION_DIR=%{php_extensiondir} \
50 INSTALL_ROOT=$RPM_BUILD_ROOT
51
43eeafa3
ER
52# NOTE: In case you are going to use Zend OPcache together with Xdebug,
53# be sure that Xdebug is loaded after OPcache. "php -v" must show Xdebug
54# after OPcache.
55install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
223ba653 56sed -e 's,@extensiondir@,%{php_extensiondir},' %{SOURCE1} > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
43eeafa3
ER
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62%php_webserver_restart
63
64%postun
65if [ "$1" = 0 ]; then
66 %php_webserver_restart
67fi
68
69%files
70%defattr(644,root,root,755)
71%doc README LICENSE
82862555 72%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
43eeafa3 73%attr(755,root,root) %{php_extensiondir}/opcache.so
This page took 0.04471 seconds and 4 git commands to generate.