]> git.pld-linux.org Git - packages/php-pecl-xslcache.git/blame - php-pecl-xslcache.spec
- remove unused tests bcond
[packages/php-pecl-xslcache.git] / php-pecl-xslcache.spec
CommitLineData
58838bce 1%define modname xslcache
2Summary: %{modname} - A modification of PHP's standard XSL extension that caches the parsed XSL stylesheet representation
3Summary(pl.UTF-8): %{modname} - modyfikacja standardowego rozszerzenia XSL PHP, które buforuje przetworzone reprezentacje arkuszów stylów XSL
4Name: php-pecl-%{modname}
5Version: 0.7.1
d33238aa 6Release: 3
58838bce 7License: PHP 3.01
8Group: Development/Languages/PHP
9Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
10# Source0-md5: 1e32327f62122055ece6f78fa2b851b2
11URL: http://pecl.php.net/package/xslcache
fb30ee94 12BuildRequires: libxslt-devel >= 1.1.0
58838bce 13BuildRequires: php-devel >= 3:5.0.0
14BuildRequires: rpmbuild(macros) >= 1.519
15%{?requires_php_extension}
16Requires: php-common >= 4:5.0.4
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%description
20The XSL Cache extension is a modification of PHP's standard XSL
21extension that caches the parsed XSL stylesheet representation between
22sessions for 2.5x boost in performance for sites that repeatedly apply
23the same transform. Although there is still some further work that
24could be done on the extension, this code is already proving
25beneficial in production use for a few applications on the New York
26Times' website.
27
58838bce 28%prep
29%setup -q -c
30mv %{modname}-%{version}/* .
31
32%build
33phpize
34%configure \
35 --with-xslcache=%{_libdir} \
36 --with-xsl-exsl-dir=%{_libdir}
37%{__make}
38
39%install
e91f8a5e 40rm -rf $RPM_BUILD_ROOT
58838bce 41install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
58838bce 42
43%{__make} install \
44 INSTALL_ROOT=$RPM_BUILD_ROOT \
45 EXTENSION_DIR=%{php_extensiondir}
46cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
47; Enable %{modname} extension module
48extension=%{modname}.so
49EOF
50
58838bce 51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%post
55%php_webserver_restart
56
57%postun
58if [ "$1" = 0 ]; then
59 %php_webserver_restart
60fi
61
62%files
63%defattr(644,root,root,755)
fb30ee94 64%doc CREDITS
58838bce 65%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
66%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.186537 seconds and 4 git commands to generate.