]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blobdiff - php-pecl-xdebug.spec
up to 2.6.1 [2018-08-01]
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
index ac3f498b502040d1e1a0719cee682beba6c83cb4..f3bbf16b61d5381c38bbbf5097868ab0123b678e 100644 (file)
@@ -1,26 +1,39 @@
-%define                _modname        xdebug
-%define                _status         stable
-
-Summary:       %{_modname} - provides functions for functions traces and profiling
-Summary(pl):   %{_modname} - funkcje do ¶ledzenia i profilowania funkcji
-Name:          php-pecl-%{_modname}
-Version:       2.0.0
-%define        _snap   beta2
-Release:       0.%{_snap}.1
-License:       BSD style
+#
+# Conditional build:
+%bcond_without vim             # make vim syntax package
+
+# build noarch packages only for 7.0 version
+%if 0%{?_pld_builder:1} && "%{?php_suffix}" != "70"
+%undefine      with_vim
+%endif
+
+%define                php_name        php%{?php_suffix}
+%define                modname xdebug
+Summary:       %{modname} - provides functions for functions traces and profiling
+Summary(pl.UTF-8):     %{modname} - funkcje do śledzenia i profilowania funkcji
+Name:          %{php_name}-pecl-%{modname}
+Version:       2.6.1
+Release:       1
+# The Xdebug License, version 1.01
+# (Based on "The PHP License", version 3.0)
+License:       PHP
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}%{_snap}.tgz
-# Source0-md5: e2fc53f2a7ee87cee9aab200bb17ae73
-URL:           http://pecl.php.net/package/xdebug/
+Source0:       https://xdebug.org/files/xdebug-%{version}.tgz
+# Source0-md5: 35cc0f2e8b7d40556a9ad9afd9c49aee
+Source1:       %{modname}.ini
+Source2:       vim-xt-filetype.vim
+URL:           https://xdebug.org/
+BuildRequires: %{php_name}-devel >= 4:7.0
 BuildRequires: libedit-devel
 BuildRequires: libtool
-BuildRequires: php-devel
-Requires:      php-common
-Obsoletes:     php-pear-%{_modname}
+BuildRequires: rpmbuild(macros) >= 1.650
+%{?requires_zend_extension}
+Provides:      php(%{modname}) = %{version}
+Obsoletes:     php-pecl-xdebug < 2.2.4-1
+Conflicts:     ZendOptimizer
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc/php
-%define                extensionsdir   %{_libdir}/php
+%define                _vimdatadir             %{_datadir}/vim
 
 %description
 The Xdebug extension helps you debugging your script by providing a
@@ -28,79 +41,120 @@ lot of valuable debug information. The debug information that Xdebug
 can provide includes the following:
 
 - stack and function traces in error messages with:
      - full parameter display for user defined functions
      - function name, file name and line indications
      - support for member functions
-         memory allocation
+ - full parameter display for user defined functions
+ - function name, file name and line indications
+ - support for member functions
+- memory allocation
 - protection for infinite recursions
 
 Xdebug also provides:
 
 - profiling information for PHP scripts
-- script execution analysis
+- code coverage analysis
 - capabilities to debug your scripts interactively with a debug client
 
-In PECL status of this package is: %{_status}.
+%description -l pl.UTF-8
+Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
+dużo wartościowych informacji. Informacje przydatne do śledzenia,
+które może zapewnić Xdebug, obejmują:
 
-%description -l pl
-Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczaj±c
-du¿o warto¶ciowych informacji. Informacje przydatne do ¶ledzenia,
-które mo¿e zapewniæ Xdebug, obejmuj±:
+- śledzenie stosu i funkcji w komunikatach błędów wraz z:
+ - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
+   użytkownika
+ - nazwami funkcji, nazwami plików i numerami linii
+ - obsługą metod klas
+- przydzielanie pamięci
+- zabezpieczenie przed nieskończoną rekurencją
 
-- ¶ledzenie stosu i funkcji w komunikatach b³êdów wraz z:
-       - pe³nym wy¶wietlaniem parametrów dla funkcji zdefiniowanych przez
-         u¿ytkownika
-       - nazwami funkcji, nazwami plików i numerami linii
-       - obs³ug± metod klas
-- przydzielanie pamiêci
-- zabezpieczenie przed nieskoñczon± rekurencj±
+Xdebug dostarcza także:
 
-Xdebug dostarcza tak¿e:
-
-- informacje do profilowania skryptów PHP
-- analizê wywo³añ skryptu
-- mo¿liwo¶æ ¶ledzenia skryptów interaktywnie przy pomocy klienta
+- informacje do profilowania skryptów PHP
+- analizę wywołań skryptu
+- możliwość śledzenia skryptów interaktywnie przy pomocy klienta
   odpluskwiacza
 
-To rozszerzenie ma w PECL status: %{_status}.
+%package -n vim-syntax-xdebug
+Summary:       Vim syntax: Xdebug trace files
+Group:         Applications/Editors/Vim
+Requires:      php(%{modname}) = %{version}
+Requires:      vim-rt >= 4:7.2.170
+BuildArch:     noarch
+
+%description -n vim-syntax-xdebug
+This plugin provides syntax highlighting Xdebug trace files (context
+or unified).
 
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}*/* .
+chmod +x debugclient/configure
+
+%{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
+
+install -d vim/{syntax,ftdetect}
+mv contrib/xt.vim vim/syntax
+cp -p %{SOURCE2} vim/ftdetect/xt.vim
 
 %build
-cd %{_modname}-%{version}%{_snap}
+# libtool 2.2 build fix
+if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
+       cat %{_aclocaldir}/ltsugar.m4 >> config.m4
+       cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
+
+       cat %{_aclocaldir}/ltversion.m4 >> config.m4
+       cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
+
+       cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
+       cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
+
+       cat %{_aclocaldir}/ltoptions.m4 >> config.m4
+       cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
+
+       cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
+fi
 phpize
 %configure
 %{__make}
 cd debugclient
-install %{_datadir}/automake/config.* .
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
 %configure \
        --with-libedit
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{extensionsdir}}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
 
-install %{_modname}-*/debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{_modname}-debugclient
-install %{_modname}-*/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
+install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}%{?php_suffix}-debugclient
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
+
+%if %{with vim}
+# vim syntax
+install -d $RPM_BUILD_ROOT%{_vimdatadir}
+cp -a vim/* $RPM_BUILD_ROOT%{_vimdatadir}
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-%{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
+%php_webserver_restart
 
-%preun
-if [ "$1" = "0" ]; then
-       %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
+%postun
+if [ "$1" = 0 ]; then
+       %php_webserver_restart
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-*/{README,NEWS,Changelog,CREDITS}
-%attr(755,root,root) %{extensionsdir}/%{_modname}.so
-%attr(755,root,root) %{_bindir}/*
+%doc README.rst CREDITS contrib
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
+%attr(755,root,root) %{_bindir}/xdebug*-debugclient
+
+%if %{with vim}
+%files -n vim-syntax-xdebug
+%defattr(644,root,root,755)
+%{_vimdatadir}/ftdetect/xt.vim
+%{_vimdatadir}/syntax/xt.vim
+%endif
This page took 0.03924 seconds and 4 git commands to generate.