]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blobdiff - php-pecl-xdebug.spec
up to 2.6.1 [2018-08-01]
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
index 86a16da1d855a80e9d9589158600d1cd1919fec7..f3bbf16b61d5381c38bbbf5097868ab0123b678e 100644 (file)
@@ -1,24 +1,40 @@
+#
+# Conditional build:
+%bcond_without vim             # make vim syntax package
+
+# build noarch packages only for 7.0 version
+%if 0%{?_pld_builder:1} && "%{?php_suffix}" != "70"
+%undefine      with_vim
+%endif
+
+%define                php_name        php%{?php_suffix}
 %define                modname xdebug
-%define                status  stable
 Summary:       %{modname} - provides functions for functions traces and profiling
 Summary(pl.UTF-8):     %{modname} - funkcje do śledzenia i profilowania funkcji
-Name:          php-pecl-%{modname}
-Version:       2.1.0
-Release:       2
-License:       BSD style
+Name:          %{php_name}-pecl-%{modname}
+Version:       2.6.1
+Release:       1
+# The Xdebug License, version 1.01
+# (Based on "The PHP License", version 3.0)
+License:       PHP
 Group:         Development/Languages/PHP
-Source0:       http://www.xdebug.org/files/xdebug-%{version}.tgz
-# Source0-md5: 2abf000f8d94af469773b31772aa96ab
-Source1:       %{name}.ini
-URL:           http://www.xdebug.org/
+Source0:       https://xdebug.org/files/xdebug-%{version}.tgz
+# Source0-md5: 35cc0f2e8b7d40556a9ad9afd9c49aee
+Source1:       %{modname}.ini
+Source2:       vim-xt-filetype.vim
+URL:           https://xdebug.org/
+BuildRequires: %{php_name}-devel >= 4:7.0
 BuildRequires: libedit-devel
 BuildRequires: libtool
-BuildRequires: php-devel >= 4:5.0.4
-BuildRequires: rpmbuild(macros) >= 1.519
+BuildRequires: rpmbuild(macros) >= 1.650
 %{?requires_zend_extension}
+Provides:      php(%{modname}) = %{version}
+Obsoletes:     php-pecl-xdebug < 2.2.4-1
 Conflicts:     ZendOptimizer
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _vimdatadir             %{_datadir}/vim
+
 %description
 The Xdebug extension helps you debugging your script by providing a
 lot of valuable debug information. The debug information that Xdebug
@@ -27,17 +43,16 @@ can provide includes the following:
 - stack and function traces in error messages with:
  - full parameter display for user defined functions
  - function name, file name and line indications
- - support for member functions memory allocation
+ - support for member functions
+- memory allocation
 - protection for infinite recursions
 
 Xdebug also provides:
 
 - profiling information for PHP scripts
-- script execution analysis
+- code coverage analysis
 - capabilities to debug your scripts interactively with a debug client
 
-In PECL status of this package is: %{status}.
-
 %description -l pl.UTF-8
 Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
 dużo wartościowych informacji. Informacje przydatne do śledzenia,
@@ -58,14 +73,27 @@ Xdebug dostarcza także:
 - możliwość śledzenia skryptów interaktywnie przy pomocy klienta
   odpluskwiacza
 
-To rozszerzenie ma w PECL status: %{status}.
+%package -n vim-syntax-xdebug
+Summary:       Vim syntax: Xdebug trace files
+Group:         Applications/Editors/Vim
+Requires:      php(%{modname}) = %{version}
+Requires:      vim-rt >= 4:7.2.170
+BuildArch:     noarch
+
+%description -n vim-syntax-xdebug
+This plugin provides syntax highlighting Xdebug trace files (context
+or unified).
 
 %prep
 %setup -qc
 mv %{modname}-%{version}*/* .
 chmod +x debugclient/configure
 
-%{__sed} -e 's#^;zend_extension.*#zend_extension%{?zend_zts:_ts}=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
+%{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
+
+install -d vim/{syntax,ftdetect}
+mv contrib/xt.vim vim/syntax
+cp -p %{SOURCE2} vim/ftdetect/xt.vim
 
 %build
 # libtool 2.2 build fix
@@ -84,15 +112,10 @@ if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
 
        cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
 fi
-
 phpize
 %configure
 %{__make}
 cd debugclient
-install /usr/share/automake/{config.*,depcomp} .
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
 %configure \
        --with-libedit
 %{__make}
@@ -101,10 +124,16 @@ install /usr/share/automake/{config.*,depcomp} .
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
 
-install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}-debugclient
+install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}%{?php_suffix}-debugclient
 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
 cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
 
+%if %{with vim}
+# vim syntax
+install -d $RPM_BUILD_ROOT%{_vimdatadir}
+cp -a vim/* $RPM_BUILD_ROOT%{_vimdatadir}
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -118,7 +147,14 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README NEWS Changelog CREDITS contrib/xt.vim
+%doc README.rst CREDITS contrib
 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
-%attr(755,root,root) %{_bindir}/xdebug-debugclient
+%attr(755,root,root) %{_bindir}/xdebug*-debugclient
+
+%if %{with vim}
+%files -n vim-syntax-xdebug
+%defattr(644,root,root,755)
+%{_vimdatadir}/ftdetect/xt.vim
+%{_vimdatadir}/syntax/xt.vim
+%endif
This page took 0.152989 seconds and 4 git commands to generate.