]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blame - php-pecl-xdebug.spec
Vim syntax does not require ext-xdebug
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
CommitLineData
3dda0a07
ER
1#
2# Conditional build:
3%bcond_without vim # make vim syntax package
4
16fe691e
ER
5# build noarch packages only for 7.0 version
6%if 0%{?_pld_builder:1} && "%{?php_suffix}" != "70"
bcd8bd1a 7%undefine with_vim
3dda0a07
ER
8%endif
9
d412cdf0 10%define php_name php%{?php_suffix}
266b1c9d 11%define modname xdebug
266b1c9d
ER
12Summary: %{modname} - provides functions for functions traces and profiling
13Summary(pl.UTF-8): %{modname} - funkcje do śledzenia i profilowania funkcji
05ed2ac4 14Name: %{php_name}-pecl-%{modname}
ad7fe8d7 15Version: 2.9.4
9106015e 16Release: 1
fe451dff
ER
17# The Xdebug License, version 1.01
18# (Based on "The PHP License", version 3.0)
19License: PHP
d6c5cc9f 20Group: Development/Languages/PHP
9106015e 21Source0: https://xdebug.org/files/xdebug-%{version}.tgz
ad7fe8d7 22# Source0-md5: a77d203543a4d837819017162acd9240
05ed2ac4 23Source1: %{modname}.ini
3dda0a07 24Source2: vim-xt-filetype.vim
3ea10353 25URL: https://xdebug.org/
16fe691e 26BuildRequires: %{php_name}-devel >= 4:7.0
e8a9b5ad 27BuildRequires: libedit-devel
aba255b5 28BuildRequires: libtool
8096f627 29BuildRequires: rpmbuild(macros) >= 1.650
3464b421 30%{?requires_zend_extension}
5423a009 31Provides: php(%{modname}) = %{version}
b8ab7bee 32Obsoletes: php-pecl-xdebug < 2.2.4-1
022c051a 33Conflicts: ZendOptimizer
d6c5cc9f
AG
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
3dda0a07
ER
36%define _vimdatadir %{_datadir}/vim
37
d6c5cc9f 38%description
cc7edbad
JB
39The Xdebug extension helps you debugging your script by providing a
40lot of valuable debug information. The debug information that Xdebug
41can provide includes the following:
82a74d97
AG
42
43- stack and function traces in error messages with:
20519407
ER
44 - full parameter display for user defined functions
45 - function name, file name and line indications
fe451dff
ER
46 - support for member functions
47- memory allocation
82a74d97
AG
48- protection for infinite recursions
49
50Xdebug also provides:
d6c5cc9f 51
82a74d97 52- profiling information for PHP scripts
fe451dff 53- code coverage analysis
82a74d97 54- capabilities to debug your scripts interactively with a debug client
98b3abb8 55
2c8c4667
JR
56%description -l pl.UTF-8
57Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
58dużo wartościowych informacji. Informacje przydatne do śledzenia,
59które może zapewnić Xdebug, obejmują:
cc7edbad 60
2c8c4667
JR
61- śledzenie stosu i funkcji w komunikatach błędów wraz z:
62 - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
63 użytkownika
64 - nazwami funkcji, nazwami plików i numerami linii
65 - obsługą metod klas
66- przydzielanie pamięci
67- zabezpieczenie przed nieskończoną rekurencją
cc7edbad 68
2c8c4667 69Xdebug dostarcza także:
cc7edbad 70
2c8c4667
JR
71- informacje do profilowania skryptów PHP
72- analizę wywołań skryptu
73- możliwość śledzenia skryptów interaktywnie przy pomocy klienta
cc7edbad
JB
74 odpluskwiacza
75
3dda0a07
ER
76%package -n vim-syntax-xdebug
77Summary: Vim syntax: Xdebug trace files
78Group: Applications/Editors/Vim
3dda0a07 79Requires: vim-rt >= 4:7.2.170
3dda0a07 80BuildArch: noarch
3dda0a07
ER
81
82%description -n vim-syntax-xdebug
83This plugin provides syntax highlighting Xdebug trace files (context
84or unified).
85
d6c5cc9f 86%prep
266b1c9d
ER
87%setup -qc
88mv %{modname}-%{version}*/* .
d6c5cc9f 89
7c227a4b 90%{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
50d01b8c 91
3dda0a07
ER
92install -d vim/{syntax,ftdetect}
93mv contrib/xt.vim vim/syntax
94cp -p %{SOURCE2} vim/ftdetect/xt.vim
95
aba255b5 96%build
d6c5cc9f
AG
97phpize
98%configure
99%{__make}
e8a9b5ad 100cd debugclient
e8a9b5ad
AM
101%configure \
102 --with-libedit
103%{__make}
d6c5cc9f
AG
104
105%install
106rm -rf $RPM_BUILD_ROOT
266b1c9d 107install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
d6c5cc9f 108
2ba22e49 109install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}%{?php_suffix}-debugclient
266b1c9d
ER
110install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
111cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
d6c5cc9f 112
3dda0a07
ER
113%if %{with vim}
114# vim syntax
115install -d $RPM_BUILD_ROOT%{_vimdatadir}
116cp -a vim/* $RPM_BUILD_ROOT%{_vimdatadir}
117%endif
118
d6c5cc9f
AG
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%post
bc9b2fd3 123%php_webserver_restart
d6c5cc9f 124
eb5447da
AG
125%postun
126if [ "$1" = 0 ]; then
bc9b2fd3 127 %php_webserver_restart
d6c5cc9f
AG
128fi
129
130%files
131%defattr(644,root,root,755)
18fda282 132%doc README.rst CREDITS contrib
266b1c9d
ER
133%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
134%attr(755,root,root) %{php_extensiondir}/%{modname}.so
2ba22e49 135%attr(755,root,root) %{_bindir}/xdebug*-debugclient
3dda0a07
ER
136
137%if %{with vim}
138%files -n vim-syntax-xdebug
139%defattr(644,root,root,755)
140%{_vimdatadir}/ftdetect/xt.vim
141%{_vimdatadir}/syntax/xt.vim
142%endif
This page took 0.183574 seconds and 4 git commands to generate.