]> git.pld-linux.org Git - packages/php-pecl-tcpwrap.git/blobdiff - php-pecl-tcpwrap.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-tcpwrap.git] / php-pecl-tcpwrap.spec
index 5b8b38fc4a2b544273ebed2061b36bc5aa38f951..12b3758380fde7c838f0fe78a13ccefc90b2e7a7 100644 (file)
@@ -1,39 +1,41 @@
-%define                _modname        tcpwrap
-%define                _status         stable
-Summary:       %{_modname} - tcpwrapper bindings
-Summary(pl.UTF-8):     %{_modname} - dowiązania tcpwrapper
-Name:          php-pecl-%{_modname}
+%define                php_name        php%{?php_suffix}
+%define                modname tcpwrap
+%define                status          stable
+Summary:       %{modname} - tcpwrapper bindings
+Summary(pl.UTF-8):     %{modname} - dowiązania tcpwrapper
+Name:          %{php_name}-pecl-%{modname}
 Version:       1.1.3
-Release:       3
+Release:       6
 License:       PHP 3.01
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: 6db26ebbf6c59fedf2228e662fe78e3e
 URL:           http://pecl.php.net/package/tcpwrap/
+BuildRequires: %{php_name}-devel >= 3:5.0.0
 BuildRequires: libwrap-devel
-BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.344
+BuildRequires: rpmbuild(macros) >= 1.650
 %{?requires_php_extension}
-Requires:      php-common >= 4:5.0.4
-Obsoletes:     php-pear-%{_modname}
+Requires:      php(core) >= 5.0.4
+Provides:      php(%{modname}) = %{version}
+Obsoletes:     php-pear-%{modname}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 This package handles /etc/hosts.allow and /etc/hosts.deny files.
 
-In PECL status of this package is: %{_status}.
+In PECL status of this package is: %{status}.
 
 %description -l pl.UTF-8
 Za pomocą tego pakietu możliwa jest obsługa plików /etc/hosts.allow
 oraz /etc/hosts.deny.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}/* .
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
@@ -41,11 +43,10 @@ phpize
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
-
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
@@ -61,6 +62,6 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc %{_modname}-%{version}/{CREDITS,EXPERIMENTAL}
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%doc CREDITS EXPERIMENTAL
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.130926 seconds and 4 git commands to generate.