]> git.pld-linux.org Git - packages/php-pecl-ssh2.git/blobdiff - php-pecl-ssh2.spec
use 00 prefix for extname
[packages/php-pecl-ssh2.git] / php-pecl-ssh2.spec
index f7568297f1f43940483076ebc7bdae9bc82587c9..fd3d43d7e2b080fbc9a4a1f4ae41bc81aec2c4be 100644 (file)
@@ -1,41 +1,37 @@
-%define                _modname        ssh2
-%define                _status         beta
-Summary:       %{_modname} - bindings for the libssh2 library
-Summary(pl.UTF-8):   %{_modname} - dowiązania do biblioteki libssh2
-Name:          php-pecl-%{_modname}
-Version:       0.10
+%define                php_name        php%{?php_suffix}
+%define                modname ssh2
+Summary:       %{modname} - bindings for the libssh2 library
+Summary(pl.UTF-8):     %{modname} - dowiązania do biblioteki libssh2
+Name:          %{php_name}-pecl-%{modname}
+Version:       1.1.2
 Release:       1
 License:       PHP
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
-# Source0-md5: 95bdbd6a9a0d14cb65c6d6bdc9ee1770
-URL:           http://pecl.php.net/package/ssh2/
-BuildRequires: libssh2-devel >= 0.5
+Source0:       https://pecl.php.net/get/%{modname}-%{version}.tgz
+# Source0-md5: 0bb1b02ae6d1d1a86134959e9b45ae69
+URL:           https://pecl.php.net/package/ssh2
+BuildRequires: %{php_name}-devel >= 4:5.0.4
+BuildRequires: libssh2-devel >= 1.2.9
 BuildRequires: openssl-devel >= 0.9.7d
-BuildRequires: php-devel >= 3:5.0.0
-BuildRequires: rpmbuild(macros) >= 1.344
+BuildRequires: rpmbuild(macros) >= 1.650
 %{?requires_php_extension}
-Requires:      php-common >= 4:5.0.4
-Obsoletes:     php-pear-%{_modname}
+Provides:      php(%{modname}) = %{version}
+Obsoletes:     php-pecl-ssh2 < 0.12-4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Provides bindings to the functions of libssh2 which implements the
 SSH2 protocol.
 
-In PECL status of this extension is: %{_status}.
-
 %description -l pl.UTF-8
 Dostarcza dowiązań do różnych funkcji biblioteki libssh2
 implementującej protokół SSH2.
 
-To rozszerzenie ma w PECL status: %{_status}.
-
 %prep
-%setup -q -c
+%setup -qc
+mv %{modname}-%{version}/* .
 
 %build
-cd %{_modname}-%{version}
 phpize
 %configure
 %{__make}
@@ -43,11 +39,10 @@ phpize
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
-
-install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/00_%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
@@ -63,5 +58,5 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/*_%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.130584 seconds and 4 git commands to generate.