]> git.pld-linux.org Git - packages/php-pecl-solr.git/commitdiff
fix extension version
authorElan Ruusamäe <glen@delfi.ee>
Sat, 26 Oct 2013 18:44:15 +0000 (21:44 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 14 May 2015 13:02:14 +0000 (16:02 +0300)
php-pecl-solr.spec

index d33c66afb12bf67761f17fc65bf8d0b309d5fe96..fd95afd399c25015a51b478b055d213eb4c7eaf5 100644 (file)
@@ -78,9 +78,19 @@ find -newer TODO -o -print | xargs touch --reference %{SOURCE0}
 
 %patch0 -p1
 
+# Fix version
+sed -i -e '/PHP_SOLR_DOTTED_VERSION/s/1.0.1/1.0.2/' php_solr_version.h
+
 %build
 packagexml2cl package.xml > ChangeLog
 
+# Check version
+extver=$(sed -n '/#define PHP_SOLR_DOTTED_VERSION/{s/.* "//;s/".*$//;p}' php_solr_version.h)
+if test "x${extver}" != "x%{version}"; then
+       : Error: Upstream version is ${extver}, expecting %{version}.
+       exit 1
+fi
+
 phpize
 %configure
 %{__make}
This page took 0.083471 seconds and 4 git commands to generate.