]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blame_incremental - php-pecl-sasl.spec
- license fixes Andrzej Mateja <amateja () pimpek.one.pl>
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
... / ...
CommitLineData
1%define _modname sasl
2%define _status alpha
3Summary: %{_modname} - Cyrus SASL extension
4Summary(pl.UTF-8): %{_modname} - rozszerzenie Cyrus SASL
5Name: php-pecl-%{_modname}
6Version: 0.1.0
7Release: 7
8License: PHP 3.01
9Group: Development/Languages/PHP
10Source0: http://pecl.php.net/get/%{_modname}-%{version}.tgz
11# Source0-md5: 8431731cc8a7921a2922af23a57a572f
12Patch0: %{name}-lib_fix.patch
13Patch1: %{name}-lib64_fix.patch
14URL: http://pecl.php.net/package/sasl/
15BuildRequires: cyrus-sasl-devel
16BuildRequires: php-devel >= 3:5.0.0
17BuildRequires: rpmbuild(macros) >= 1.344
18%{?requires_php_extension}
19Requires: php-common >= 4:5.0.4
20Obsoletes: php-pear-%{_modname}
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24SASL is the Simple Authentication and Security Layer (as defined by
25RFC 2222). It provides a system for adding plugable authenticating
26support to connection-based protocols. The SASL extension for PHP
27makes the Cyrus SASL library functions available to PHP. It aims to
28provide a 1-to-1 wrapper around the SASL library to provide the
29greatest amount of implementation flexibility. To that end, it is
30possible to build both a client-side and server-side SASL
31implementation entirely in PHP.
32
33In PECL status of this extension is: %{_status}.
34
35%description -l pl.UTF-8
36SASL to warstwa prostego uwierzytelnienia i bezpieczeństwa (Simple
37Authentication and Security Layer) zdefiniowana w RFC 2222. Dostarcza
38system do dodawania wtyczek obsługujących uwierzytelnianie do
39protokołów opartych na połączeniach. Rozszerzenie SASL dla PHP
40udostępnia w PHP funkcje biblioteki Cyrus SASL. Celem jest
41dostarczenie obudowania 1-do-1 biblioteki SASL, aby udostępnić jak
42największą elastyczność implementacji. W tym celu możliwe jest
43zbudowanie zarówno klienckiej jak i serwerowej implementacji SASL
44całkowicie w PHP.
45
46To rozszerzenie ma w PECL status: %{_status}.
47
48%prep
49%setup -q -c
50# Ugly, could be done somehow prettier (one combined patch?)
51%if "%{_lib}" == "lib64"
52%patch1 -p1
53%else
54%patch0 -p1
55%endif
56
57%build
58cd %{_modname}-%{version}
59phpize
60%configure
61%{__make}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
66
67install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
68cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
69; Enable %{_modname} extension module
70extension=%{_modname}.so
71EOF
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77%php_webserver_restart
78
79%postun
80if [ "$1" = 0 ]; then
81 %php_webserver_restart
82fi
83
84%files
85%defattr(644,root,root,755)
86%doc %{_modname}-%{version}/docs/TODO
87%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
88%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.070592 seconds and 4 git commands to generate.