]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blame - php-pecl-sasl.spec
add module load test
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
CommitLineData
b963a42b
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
b7b553cd
ER
5%define php_name php%{?php_suffix}
6%define modname sasl
7%define status alpha
8Summary: %{modname} - Cyrus SASL extension
9Summary(pl.UTF-8): %{modname} - rozszerzenie Cyrus SASL
10Name: %{php_name}-pecl-%{modname}
3230199c
ER
11Version: 0.2.0
12Release: 1
2afbc69d 13License: PHP 3.01
9b3ecba9 14Group: Development/Languages/PHP
3230199c 15Source0: http://pecl.php.net/get/%{modname}-0.1.0.tgz
9b3ecba9 16# Source0-md5: 8431731cc8a7921a2922af23a57a572f
3230199c
ER
17Patch99: prepatch.patch
18Patch100: branch.diff
b7b553cd 19Patch1: php-pecl-%{modname}-lib64_fix.patch
9b3ecba9 20URL: http://pecl.php.net/package/sasl/
12a8a0bb 21BuildRequires: %{php_name}-devel >= 3:5.0.4
cc0eadf7 22BuildRequires: cyrus-sasl-devel
b7b553cd 23BuildRequires: rpmbuild(macros) >= 1.650
b963a42b 24%{?with_tests:BuildRequires: %{php_name}-cli}
c3a5ebc9 25%{?requires_php_extension}
cc0eadf7 26Provides: php(%{modname}) = %{version}
12b1ccc3 27Obsoletes: php-pecl-sasl < 0.1.0-14
9b3ecba9
AG
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
9b3ecba9
AG
30%description
31SASL is the Simple Authentication and Security Layer (as defined by
32RFC 2222). It provides a system for adding plugable authenticating
f735bf96 33support to connection-based protocols. The SASL extension for PHP
9b3ecba9
AG
34makes the Cyrus SASL library functions available to PHP. It aims to
35provide a 1-to-1 wrapper around the SASL library to provide the
36greatest amount of implementation flexibility. To that end, it is
37possible to build both a client-side and server-side SASL
38implementation entirely in PHP.
39
b7b553cd 40In PECL status of this extension is: %{status}.
9b3ecba9 41
0cb9801d
JR
42%description -l pl.UTF-8
43SASL to warstwa prostego uwierzytelnienia i bezpieczeństwa (Simple
241d2ddc 44Authentication and Security Layer) zdefiniowana w RFC 2222. Dostarcza
0cb9801d
JR
45system do dodawania wtyczek obsługujących uwierzytelnianie do
46protokołów opartych na połączeniach. Rozszerzenie SASL dla PHP
47udostępnia w PHP funkcje biblioteki Cyrus SASL. Celem jest
48dostarczenie obudowania 1-do-1 biblioteki SASL, aby udostępnić jak
49największą elastyczność implementacji. W tym celu możliwe jest
50zbudowanie zarówno klienckiej jak i serwerowej implementacji SASL
51całkowicie w PHP.
241d2ddc 52
b7b553cd 53To rozszerzenie ma w PECL status: %{status}.
9b3ecba9
AG
54
55%prep
b7b553cd 56%setup -qc
3230199c
ER
57mv %{modname}-*/* .
58%patch99 -p1
59%patch100 -p0
1de3250c 60%if "%{_lib}" == "lib64"
3230199c 61%patch1 -p1
7265728d 62%endif
9b3ecba9
AG
63
64%build
9b3ecba9 65phpize
7265728d 66%configure
9b3ecba9
AG
67%{__make}
68
b963a42b
ER
69%if %{with tests}
70# simple module load test
71%{__php} -n \
72 -dextension_dir=modules \
73 -dextension=%{modname}.so \
74 -m > modules.log
75grep %{modname} modules.log
76%endif
77
9b3ecba9
AG
78%install
79rm -rf $RPM_BUILD_ROOT
1302764a 80install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
b7b553cd
ER
81install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
82cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
83; Enable %{modname} extension module
84extension=%{modname}.so
c3a5ebc9 85EOF
9b3ecba9
AG
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post
1302764a 91%php_webserver_restart
9b3ecba9 92
c3a5ebc9
ER
93%postun
94if [ "$1" = 0 ]; then
1302764a 95 %php_webserver_restart
9b3ecba9
AG
96fi
97
98%files
99%defattr(644,root,root,755)
3230199c 100%doc docs/TODO docs/guide.txt
b7b553cd
ER
101%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
102%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.092115 seconds and 4 git commands to generate.