]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blame - php-pecl-sasl.spec
- try to build this on amd64
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
CommitLineData
9b3ecba9
AG
1%define _modname sasl
2%define _status alpha
3
f735bf96 4Summary: %{_modname} - Cyrus SASL extension
5Summary(pl): %{_modname} - rozszerzenie Cyrus SASL
9b3ecba9
AG
6Name: php-pecl-%{_modname}
7Version: 0.1.0
8Release: 1
9License: PHP 2.02
10Group: Development/Languages/PHP
11Source0: http://pecl.php.net/get/%{_modname}-%{version}.tgz
12# Source0-md5: 8431731cc8a7921a2922af23a57a572f
73709d12 13Patch0: %{name}-lib_fix.patch
9b3ecba9
AG
14URL: http://pecl.php.net/package/sasl/
15BuildRequires: cyrus-sasl-devel
16BuildRequires: libtool
17BuildRequires: php-devel
18Requires: php-common
19Obsoletes: php-pear-%{_modname}
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define _sysconfdir /etc/php
23%define extensionsdir %{_libdir}/php
24
25%description
26SASL is the Simple Authentication and Security Layer (as defined by
27RFC 2222). It provides a system for adding plugable authenticating
f735bf96 28support to connection-based protocols. The SASL extension for PHP
9b3ecba9
AG
29makes the Cyrus SASL library functions available to PHP. It aims to
30provide a 1-to-1 wrapper around the SASL library to provide the
31greatest amount of implementation flexibility. To that end, it is
32possible to build both a client-side and server-side SASL
33implementation entirely in PHP.
34
35In PECL status of this extension is: %{_status}.
36
37#%description -l pl
38#
39#To rozszerzenie ma w PECL status: %{_status}.
40
41%prep
42%setup -q -c
73709d12 43%patch0 -p1
9b3ecba9
AG
44
45%build
46cd %{_modname}-%{version}
47phpize
2423279f 48LDFLAGS="%{_rpmldflags} -L%{_libdir}" %configure
9b3ecba9
AG
49%{__make}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53install -d $RPM_BUILD_ROOT%{extensionsdir}
54
55install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%post
61%{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
62
63%preun
64if [ "$1" = "0" ]; then
65 %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
66fi
67
68%files
69%defattr(644,root,root,755)
70%doc %{_modname}-%{version}/docs/TODO
71%attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.09377 seconds and 4 git commands to generate.