]> git.pld-linux.org Git - packages/php-pecl-raphf.git/blob - php-pecl-raphf.spec
- updated to 2.0.0
[packages/php-pecl-raphf.git] / php-pecl-raphf.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname         raphf
3 %define         status          stable
4 Summary:        %{modname} - Resource and persistent handles factory
5 Name:           %{php_name}-pecl-%{modname}
6 Version:        2.0.0
7 Release:        1
8 License:        BSD, revised
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
11 # Source0-md5:  bc465eb5caa9d0f09cced121a8ac2e8e
12 URL:            http://pecl.php.net/package/raphf/
13 BuildRequires:  %{php_name}-devel >= 3:5.3.0
14 BuildRequires:  rpmbuild(macros) >= 1.650
15 %{?requires_php_extension}
16 Provides:       php(%{modname}) = %{version}
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 A reusable split-off of pecl_http's persistent handle and resource
21 factory API.
22
23 In PECL status of this extension is: %{status}.
24
25 %package devel
26 Summary:        Header files for raphf PECL extension
27 Group:          Development/Libraries
28 # does not require base
29 Requires:       %{php_name}-devel >= 4:5.2.0
30
31 %description devel
32 Header files for raphf PECL extension.
33
34 %prep
35 %setup -qc
36 mv %{modname}-%{version}/* .
37
38 %build
39 phpize
40 %{__libtoolize}
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
47
48 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
49 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
50 ; Enable %{modname} extension module
51 extension=%{modname}.so
52 EOF
53
54 install -p -D php_raphf.h $RPM_BUILD_ROOT%{_includedir}/php/ext/raphf/php_raphf.h
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %php_webserver_restart
61
62 %postun
63 if [ "$1" = 0 ]; then
64         %php_webserver_restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
70 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
71
72 %files devel
73 %defattr(644,root,root,755)
74 %dir %{php_includedir}/ext/raphf
75 %{php_includedir}/ext/raphf/php_raphf.h
This page took 0.06608 seconds and 3 git commands to generate.