]> git.pld-linux.org Git - packages/php-pecl-paradox.git/blobdiff - php-pecl-paradox.spec
support building for multiple php versions
[packages/php-pecl-paradox.git] / php-pecl-paradox.spec
index 2ef06d62591af4afe10acd3f8679ea83f2a6353b..8a85b62f66a4ab88e1570f476e6cfefb660e46a4 100644 (file)
@@ -1,18 +1,19 @@
-%define                _modname        paradox
-%define                _status         stable
+%define                php_name        php%{?php_suffix}
+%define                modname paradox
+%define                status          stable
 Summary:       read and write Paradox files
 Summary(pl.UTF-8):     odczyt i zapis z/do plików Paradox
-Name:          php-pecl-%{_modname}
+Name:          %{php_name}-pecl-%{modname}
 Version:       1.4.3
 Release:       5
 License:       PHP 3.01
 Group:         Development/Languages/PHP
-Source0:       http://pecl.php.net/get/%{_modname}-%{version}.tgz
+Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: aab0bc4146bc2852a9623b635fa20c17
 URL:           http://pecl.php.net/package/Paradox/
-BuildRequires: php-devel >= 3:5.0.0
+BuildRequires: %{php_name}-devel >= 3:5.0.0
 BuildRequires: pxlib-devel >= 0.6.0
-BuildRequires: rpmbuild(macros) >= 1.344
+BuildRequires: rpmbuild(macros) >= 1.650
 %{?requires_php_extension}
 Requires:      php(core) >= 5.0.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -22,7 +23,7 @@ Paradox is an extension to read and write Paradox .DB and .PX files.
 It can handle almost all field types and binary large objects stored
 in .MB files.
 
-In PECL status of this extension is: %{_status}.
+In PECL status of this extension is: %{status}.
 
 %description -l pl.UTF-8
 Paradox to rozszerzenie pozwalające na dostęp w trybie odczyt/zapis do
@@ -30,11 +31,11 @@ plików .DB oraz .PX bazy Paradox. Rozszerzenie pozwala na obsługę
 prawie wszystkich typów pól i dużych obiektów binarnych (ang. binary
 large objects, blob) przechowywanych w plikach .MB.
 
-To rozszerzenie ma w PECL status: %{_status}.
+To rozszerzenie ma w PECL status: %{status}.
 
 %prep
 %setup -q -c
-mv %{_modname}-%{version}/* .
+mv %{modname}-%{version}/* .
 
 %build
 phpize
@@ -48,9 +49,9 @@ install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT \
        EXTENSION_DIR=%{php_extensiondir}
-cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-; Enable %{_modname} extension module
-extension=%{_modname}.so
+cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+; Enable %{modname} extension module
+extension=%{modname}.so
 EOF
 
 %clean
@@ -67,5 +68,5 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc CREDITS
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.074903 seconds and 4 git commands to generate.