]> git.pld-linux.org Git - packages/php-pecl-paradox.git/blob - php-pecl-paradox.spec
a56906e8e217cdd178bb92c62971cd51a920cc7c
[packages/php-pecl-paradox.git] / php-pecl-paradox.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname paradox
3 %define         status          stable
4 Summary:        read and write Paradox files
5 Summary(pl.UTF-8):      odczyt i zapis z/do plików Paradox
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        1.4.3
8 Release:        6
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-%{version}.tgz
12 # Source0-md5:  aab0bc4146bc2852a9623b635fa20c17
13 Patch0:         format-security.patch
14 URL:            http://pecl.php.net/package/Paradox/
15 BuildRequires:  %{php_name}-devel >= 3:5.0.0
16 BuildRequires:  pxlib-devel >= 0.6.0
17 BuildRequires:  rpmbuild(macros) >= 1.650
18 %{?requires_php_extension}
19 Requires:       php(core) >= 5.0.4
20 Provides:       php(%{modname}) = %{version}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Paradox is an extension to read and write Paradox .DB and .PX files.
25 It can handle almost all field types and binary large objects stored
26 in .MB files.
27
28 In PECL status of this extension is: %{status}.
29
30 %description -l pl.UTF-8
31 Paradox to rozszerzenie pozwalające na dostęp w trybie odczyt/zapis do
32 plików .DB oraz .PX bazy Paradox. Rozszerzenie pozwala na obsługę
33 prawie wszystkich typów pól i dużych obiektów binarnych (ang. binary
34 large objects, blob) przechowywanych w plikach .MB.
35
36 To rozszerzenie ma w PECL status: %{status}.
37
38 %prep
39 %setup -q -c
40 mv %{modname}-%{version}/* .
41 %patch0 -p1
42
43 %build
44 phpize
45 %configure
46 %{__make}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
51
52 %{__make} install \
53         INSTALL_ROOT=$RPM_BUILD_ROOT \
54         EXTENSION_DIR=%{php_extensiondir}
55 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
56 ; Enable %{modname} extension module
57 extension=%{modname}.so
58 EOF
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post
64 %php_webserver_restart
65
66 %postun
67 if [ "$1" = 0 ]; then
68         %php_webserver_restart
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc CREDITS
74 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
75 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.047497 seconds and 2 git commands to generate.