]> git.pld-linux.org Git - packages/php-pecl-paradox.git/blob - php-pecl-paradox.spec
- use php(core) as dependency to require php version
[packages/php-pecl-paradox.git] / php-pecl-paradox.spec
1 %define         _modname        paradox
2 %define         _status         stable
3 Summary:        read and write Paradox files
4 Summary(pl.UTF-8):      odczyt i zapis z/do plików Paradox
5 Name:           php-pecl-%{_modname}
6 Version:        1.4.3
7 Release:        5
8 License:        PHP 3.01
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  aab0bc4146bc2852a9623b635fa20c17
12 URL:            http://pecl.php.net/package/Paradox/
13 BuildRequires:  php-devel >= 3:5.0.0
14 BuildRequires:  pxlib-devel >= 0.6.0
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 %{?requires_php_extension}
17 Requires:       php(core) >= 5.0.4
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Paradox is an extension to read and write Paradox .DB and .PX files.
22 It can handle almost all field types and binary large objects stored
23 in .MB files.
24
25 In PECL status of this extension is: %{_status}.
26
27 %description -l pl.UTF-8
28 Paradox to rozszerzenie pozwalające na dostęp w trybie odczyt/zapis do
29 plików .DB oraz .PX bazy Paradox. Rozszerzenie pozwala na obsługę
30 prawie wszystkich typów pól i dużych obiektów binarnych (ang. binary
31 large objects, blob) przechowywanych w plikach .MB.
32
33 To rozszerzenie ma w PECL status: %{_status}.
34
35 %prep
36 %setup -q -c
37 mv %{_modname}-%{version}/* .
38
39 %build
40 phpize
41 %configure
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
47
48 %{__make} install \
49         INSTALL_ROOT=$RPM_BUILD_ROOT \
50         EXTENSION_DIR=%{php_extensiondir}
51 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
52 ; Enable %{_modname} extension module
53 extension=%{_modname}.so
54 EOF
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %php_webserver_restart
61
62 %postun
63 if [ "$1" = 0 ]; then
64         %php_webserver_restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc CREDITS
70 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
71 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.066207 seconds and 3 git commands to generate.