]> git.pld-linux.org Git - packages/php-pecl-paradox.git/blame_incremental - php-pecl-paradox.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-paradox.git] / php-pecl-paradox.spec
... / ...
CommitLineData
1%define php_name php%{?php_suffix}
2%define modname paradox
3%define status stable
4Summary: read and write Paradox files
5Summary(pl.UTF-8): odczyt i zapis z/do plików Paradox
6Name: %{php_name}-pecl-%{modname}
7Version: 1.4.3
8Release: 6
9License: PHP 3.01
10Group: Development/Languages/PHP
11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
12# Source0-md5: aab0bc4146bc2852a9623b635fa20c17
13URL: http://pecl.php.net/package/Paradox/
14BuildRequires: %{php_name}-devel >= 3:5.0.0
15BuildRequires: pxlib-devel >= 0.6.0
16BuildRequires: rpmbuild(macros) >= 1.650
17%{?requires_php_extension}
18Requires: php(core) >= 5.0.4
19Provides: php(%{modname}) = %{version}
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Paradox is an extension to read and write Paradox .DB and .PX files.
24It can handle almost all field types and binary large objects stored
25in .MB files.
26
27In PECL status of this extension is: %{status}.
28
29%description -l pl.UTF-8
30Paradox to rozszerzenie pozwalające na dostęp w trybie odczyt/zapis do
31plików .DB oraz .PX bazy Paradox. Rozszerzenie pozwala na obsługę
32prawie wszystkich typów pól i dużych obiektów binarnych (ang. binary
33large objects, blob) przechowywanych w plikach .MB.
34
35To rozszerzenie ma w PECL status: %{status}.
36
37%prep
38%setup -q -c
39mv %{modname}-%{version}/* .
40
41%build
42phpize
43%configure
44%{__make}
45
46%install
47rm -rf $RPM_BUILD_ROOT
48install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
49
50%{__make} install \
51 INSTALL_ROOT=$RPM_BUILD_ROOT \
52 EXTENSION_DIR=%{php_extensiondir}
53cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
54; Enable %{modname} extension module
55extension=%{modname}.so
56EOF
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62%php_webserver_restart
63
64%postun
65if [ "$1" = 0 ]; then
66 %php_webserver_restart
67fi
68
69%files
70%defattr(644,root,root,755)
71%doc CREDITS
72%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
73%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.039881 seconds and 4 git commands to generate.