]> git.pld-linux.org Git - packages/php-pecl-paradox.git/blame_incremental - php-pecl-paradox.spec
- obsolete old php name
[packages/php-pecl-paradox.git] / php-pecl-paradox.spec
... / ...
CommitLineData
1%define php_name php%{?php_suffix}
2%define modname paradox
3%define status stable
4Summary: read and write Paradox files
5Summary(pl.UTF-8): odczyt i zapis z/do plików Paradox
6Name: %{php_name}-pecl-%{modname}
7Version: 1.4.3
8Release: 7
9License: PHP 3.01
10Group: Development/Languages/PHP
11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
12# Source0-md5: aab0bc4146bc2852a9623b635fa20c17
13Patch0: format-security.patch
14URL: http://pecl.php.net/package/Paradox/
15BuildRequires: %{php_name}-devel >= 3:5.0.4
16BuildRequires: pxlib-devel >= 0.6.0
17BuildRequires: rpmbuild(macros) >= 1.650
18%{?requires_php_extension}
19Provides: php(%{modname}) = %{version}
20Obsoletes: php-pecl-paradox < 1.4.3-6
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Paradox is an extension to read and write Paradox .DB and .PX files.
25It can handle almost all field types and binary large objects stored
26in .MB files.
27
28In PECL status of this extension is: %{status}.
29
30%description -l pl.UTF-8
31Paradox to rozszerzenie pozwalające na dostęp w trybie odczyt/zapis do
32plików .DB oraz .PX bazy Paradox. Rozszerzenie pozwala na obsługę
33prawie wszystkich typów pól i dużych obiektów binarnych (ang. binary
34large objects, blob) przechowywanych w plikach .MB.
35
36To rozszerzenie ma w PECL status: %{status}.
37
38%prep
39%setup -q -c
40mv %{modname}-%{version}/* .
41%patch0 -p1
42
43%build
44phpize
45%configure
46%{__make}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
51
52%{__make} install \
53 INSTALL_ROOT=$RPM_BUILD_ROOT \
54 EXTENSION_DIR=%{php_extensiondir}
55cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
56; Enable %{modname} extension module
57extension=%{modname}.so
58EOF
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%post
64%php_webserver_restart
65
66%postun
67if [ "$1" = 0 ]; then
68 %php_webserver_restart
69fi
70
71%files
72%defattr(644,root,root,755)
73%doc CREDITS
74%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
75%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.022258 seconds and 4 git commands to generate.