]> git.pld-linux.org Git - packages/php-pecl-openal.git/blame - php-pecl-openal.spec
support building for multiple php versions
[packages/php-pecl-openal.git] / php-pecl-openal.spec
CommitLineData
2d4a91ad
ER
1%define php_name php%{?php_suffix}
2%define modname openal
3%define status beta
4Summary: %{modname} - bindings to OpenAL
5Summary(pl.UTF-8): %{modname} - dowiązania do OpenAL
6Name: %{php_name}-pecl-%{modname}
84a2321e 7Version: 0.1
e48c2f0e 8Release: 1
84a2321e
AG
9License: PHP
10Group: Development/Languages/PHP
2d4a91ad 11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
84a2321e 12# Source0-md5: d6dd7f9d47997928e6d897cb711317ba
55c69710 13URL: http://pecl.php.net/package/openal/
84a2321e 14BuildRequires: OpenAL-devel
2d4a91ad
ER
15BuildRequires: %{php_name}-devel >= 3:5.0.0
16BuildRequires: rpmbuild(macros) >= 1.650
355f404f 17%{?requires_php_extension}
9124cbd1 18Requires: php-common >= 4:5.0.4
2d4a91ad 19Obsoletes: php-pear-%{modname}
84a2321e
AG
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
84a2321e
AG
22%description
23This extension provides platform independent sound bindings.
24
2d4a91ad 25In PECL status of this package is: %{status}.
84a2321e 26
0ab2c209
JR
27%description -l pl.UTF-8
28To rozszerzenie dostarcza niezależnych od platformy dowiązań
29dotyczących dźwięku.
84a2321e 30
2d4a91ad 31To rozszerzenie ma w PECL status: %{status}.
84a2321e
AG
32
33%prep
2d4a91ad
ER
34%setup -qc
35mv %{modname}-%{version}/* .
84a2321e
AG
36
37%build
84a2321e
AG
38phpize
39%configure
40%{__make}
41
42%install
43rm -rf $RPM_BUILD_ROOT
9124cbd1 44install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
2d4a91ad
ER
45install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
46cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
47; Enable %{modname} extension module
48extension=%{modname}.so
355f404f 49EOF
84a2321e
AG
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%post
9124cbd1 55%php_webserver_restart
84a2321e 56
355f404f
ER
57%postun
58if [ "$1" = 0 ]; then
9124cbd1 59 %php_webserver_restart
84a2321e
AG
60fi
61
62%files
63%defattr(644,root,root,755)
2d4a91ad
ER
64%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
65%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.146801 seconds and 4 git commands to generate.